Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2000756 - error: ../../grub-core/loader/arm64/linux.c:326:Invalid PE optional header magic.
Summary: error: ../../grub-core/loader/arm64/linux.c:326:Invalid PE optional header ma...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: grub2
Version: 35
Hardware: armhfp
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Javier Martinez Canillas
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: ARMTracker F35BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2021-09-02 19:58 UTC by Paul Whalen
Modified: 2021-09-20 19:54 UTC (History)
8 users (show)

Fixed In Version: grub2-2.06-5.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-09-20 19:54:50 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Paul Whalen 2021-09-02 19:58:41 UTC
Description of problem:

After updating to grub2-2.06-4.fc35 on armhfp, system fails to boot with the error:

error: ../../grub-core/loader/arm64/linux.c:326:Invalid PE optional header
magic.
error: ../../grub-core/loader/arm64/linux.c:279:you need to load the kernel
first.

Press any key to continue...


Version-Release number of selected component (if applicable):
grub2-2.06-4.fc35

How reproducible:
Always. 

Steps to Reproduce:
1. Boot a f35 armhfp disk image
2. Update to grub2-2.06-4.fc35, reboot

Comment 1 Fedora Update System 2021-09-10 14:59:16 UTC
FEDORA-2021-51f205d5af has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-51f205d5af

Comment 2 Fedora Update System 2021-09-10 14:59:19 UTC
FEDORA-2021-51f205d5af has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-51f205d5af

Comment 3 Fedora Update System 2021-09-10 22:11:08 UTC
FEDORA-2021-51f205d5af has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-51f205d5af`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-51f205d5af

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Fedora Blocker Bugs Application 2021-09-19 15:12:31 UTC
Proposed as a Blocker for 35-beta by Fedora user pbrobinson using the blocker tracking app because:

 grub2 revision 4 fixed some issues on aarch64 and power64le but regressed on armhfp, revision 5 fixed the armhfp issues. It would be useful to get this build in for beta to clean up those issues with grub 2.06 on those arches.

````
* Thu Sep 09 2021 Peter Jones <pjones> - 2.06-5
- Fix the 32-bit Arm PE header magic check
  Resolves: rhbz#2000756

* Tue Aug 24 2021 Peter Jones <pjones> - 2.06-4
- Fix aarch64 kernel alignment.
- Fix annobin regexp on ppc64le
````

Comment 5 Adam Williamson 2021-09-20 15:05:20 UTC
+4 in https://pagure.io/fedora-qa/blocker-review/issue/464 , marking accepted.

Comment 6 Fedora Update System 2021-09-20 19:54:50 UTC
FEDORA-2021-51f205d5af has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.