Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2001261 - qt5-qtwebengine rendering broken in F35
Summary: qt5-qtwebengine rendering broken in F35
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qt5-qtwebengine
Version: 35
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker AcceptedFreezeException
Depends On:
Blocks: F35BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2021-09-05 01:34 UTC by Steven Usdansky
Modified: 2021-09-07 19:07 UTC (History)
8 users (show)

Fixed In Version: qt5-qtwebengine-5.15.6-1.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-09-07 19:07:45 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
crashlog (deleted)
2021-09-05 01:34 UTC, Steven Usdansky
no flags Details

Description Steven Usdansky 2021-09-05 01:34:54 UTC
Created attachment 1820550 [details]
crashlog

Description of problem:
falkon-3.1.0-9.fc35.x86_64 hangs on startup; throbber on the tab goes round and round but nothing happens. No change when URL entered in address bar.

Version-Release number of selected component (if applicable):
falkon-3.1.0-9.fc35.x86_64

How reproducible:
100%


Steps to Reproduce:
1. start falkon
2.
3.

Actual results: 
see description of problem


Expected results:
falcon loads contents of address bar

Additional info:

Comment 1 Mattia Verga 2021-09-05 08:45:22 UTC
This is caused by a problem with qt5-qtwebengine and should be fixed by qt5-qtwebengine-5.15.6-1.fc35 in https://bodhi.fedoraproject.org/updates/FEDORA-2021-2b436cae88

Can you try that update?

Comment 2 Fedora Blocker Bugs Application 2021-09-05 08:48:46 UTC
Proposed as a Blocker for 35-beta by Fedora user mattia using the blocker tracking app because:

 All programs that rely on qt5-qtwebengine (Falkon, KMail, Akregator, ...) are currently broken in F35, because no web content is showed.

Comment 3 Fedora Update System 2021-09-06 14:54:16 UTC
FEDORA-2021-2b436cae88 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-2b436cae88

Comment 4 Adam Williamson 2021-09-06 15:12:10 UTC
+3 for Beta FE in https://pagure.io/fedora-qa/blocker-review/issue/433 , marking accepted.

Comment 5 Steven Usdansky 2021-09-06 17:38:50 UTC
qt5-qtwebengine-5.15.6-1.fc35 fixed the problem for me

Comment 6 Lukas Ruzicka 2021-09-07 08:34:07 UTC
I can confirm that Falkon works normally with that update.

Comment 7 Adam Williamson 2021-09-07 17:13:07 UTC
Discussed at 2021-09-06 blocker/FE review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2021/fedora-blocker-review.2021-09-06-16.00.html . Rejected as a Beta blocker as there is no Beta criterion that this violates, really (the default browser on KDE is Firefox, as noted). It is already accepted as an FE, so the fix will be pulled in.

Comment 8 Fedora Update System 2021-09-07 19:07:45 UTC
FEDORA-2021-2b436cae88 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.