Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2007221 - version downgrade from f34 -> f35, updates stuck in bodhi
Summary: version downgrade from f34 -> f35, updates stuck in bodhi
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: conmon
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lokesh Mandvekar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-09-23 11:25 UTC by Fabio Valentini
Modified: 2021-10-05 15:49 UTC (History)
5 users (show)

Fixed In Version: conmon-2.0.30-2.fc36 conmon-2.0.30-2.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-05 15:49:04 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Fabio Valentini 2021-09-23 11:25:49 UTC
Right now, conmon in Fedora 34 is newer than in Fedora 35:

conmon-2:2.0.29-2.fc34 > conmon-2:2.0.29-0.2.dev.git2947bb2.fc35

This should never be the case.

Looking at bodhi updates, they seem to be stuck due to failed gating tests. Please look at them and make sure that *older* Fedora releases never get version updates earlier (or ever) than *newer* Fedora releases:

https://bodhi.fedoraproject.org/updates/?packages=conmon

At least some of the updates that are still in "testing" state, some after *months*, seem to be stuck. Either fix the problems caused by failed gating tests, or unpush them, but don't ignore them. I thought we agreed on this in the FESCo issue about rhcontainerbot.

Comment 2 Lokesh Mandvekar 2021-09-23 19:33:19 UTC
errr ... i see it's not rawhide. Fixing.

Comment 3 Lokesh Mandvekar 2021-09-23 19:41:56 UTC
Peter, please file a bodhi with the v2.0.30 build. That should take care of this issue.

Comment 5 Fedora Update System 2021-09-24 13:27:44 UTC
FEDORA-2021-87e84e3404 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-87e84e3404

Comment 6 Fedora Update System 2021-09-24 21:44:45 UTC
FEDORA-2021-65e0c8c284 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-65e0c8c284`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-65e0c8c284

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2021-09-25 01:38:50 UTC
FEDORA-2021-65e0c8c284 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-65e0c8c284

Comment 8 Fedora Update System 2021-09-26 00:57:28 UTC
FEDORA-2021-65e0c8c284 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-65e0c8c284`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-65e0c8c284

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2021-09-27 18:39:42 UTC
FEDORA-2021-65e0c8c284 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-65e0c8c284

Comment 10 Fedora Update System 2021-09-29 02:10:44 UTC
FEDORA-2021-65e0c8c284 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-65e0c8c284`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-65e0c8c284

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2021-09-30 20:26:35 UTC
FEDORA-2021-65e0c8c284 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-65e0c8c284

Comment 12 Fedora Update System 2021-10-01 01:38:28 UTC
FEDORA-2021-65e0c8c284 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-65e0c8c284`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-65e0c8c284

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Fedora Update System 2021-10-05 15:49:04 UTC
FEDORA-2021-65e0c8c284 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.