Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2008422 - Since the upgrade to Fedora 35 Beta quodlibet won't start
Summary: Since the upgrade to Fedora 35 Beta quodlibet won't start
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: quodlibet
Version: 35
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: hannes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-09-28 08:33 UTC by pzeppegno
Modified: 2021-10-05 00:51 UTC (History)
2 users (show)

Fixed In Version: quodlibet-4.5.0-0.1.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-05 00:51:05 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github quodlibet quodlibet issues 3818 0 None open quodlibet fails to start with python 3.10 2021-09-30 05:20:35 UTC

Description pzeppegno 2021-09-28 08:33:04 UTC
Description of problem:
Since the upgrade from Fedora 34 to Fedora 35 Beta (using dnf system-upgrade) quodlibet won't start.

Version-Release number of selected component (if applicable):
quodlibet-4.4.0-3.fc35.noarch

How reproducible:


Steps to Reproduce:
1. Run quodlibet
2. See a crash
3.

Actual results:
Quodlibet won't run

Expected results:
Quodlibet should run

Additional info:
Here's the python stack trace taken from a terminal:

> quodlibet
E: 0.321: errorreport.main.errorhook: collection.py:27:<module>: ImportError: cannot import name 'Iterable' from 'collections' (/usr/lib64/python3.10/collections/__init__.py)
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/python3.10/site-packages/quodlibet/errorreport/main.py", line 175, in errorhook
    sentry_error = sentry.capture(exc_info, fingerprint=fingerprint)
  File "/usr/lib/python3.10/site-packages/quodlibet/errorreport/sentrywrapper.py", line 247, in capture
    client = Client(
  File "/usr/lib/python3.10/site-packages/quodlibet/packages/raven/base.py", line 224, in __init__
    from raven.context import Context
  File "/usr/lib/python3.10/site-packages/quodlibet/_import.py", line 47, in load_module
    mod = importlib.import_module(loadname)
  File "/usr/lib64/python3.10/importlib/__init__.py", line 126, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "/usr/lib/python3.10/site-packages/quodlibet/packages/raven/context.py", line 10, in <module>
    from collections import Mapping, Iterable
ImportError: cannot import name 'Mapping' from 'collections' (/usr/lib64/python3.10/collections/__init__.py)

Original exception was:
Traceback (most recent call last):
  File "/usr/bin/quodlibet", line 14, in <module>
    sys.exit(main())
  File "/usr/lib/python3.10/site-packages/quodlibet/main.py", line 44, in main
    import quodlibet.library
  File "/usr/lib/python3.10/site-packages/quodlibet/library/__init__.py", line 20, in <module>
    from quodlibet.library.libraries import SongFileLibrary, SongLibrary
  File "/usr/lib/python3.10/site-packages/quodlibet/library/libraries.py", line 32, in <module>
    from quodlibet.util.collection import Album
  File "/usr/lib/python3.10/site-packages/quodlibet/util/collection.py", line 27, in <module>
    from collections import Iterable
ImportError: cannot import name 'Iterable' from 'collections' (/usr/lib64/python3.10/collections/__init__.py)

Comment 1 hannes 2021-09-30 05:20:35 UTC
Thanks for the report, I've reported it downstream, but I am not yet on fedora 35.

Comment 2 Jonathan S. 2021-09-30 18:23:34 UTC
I think this has to due with the Python 3.9 -> Python 3.10 migration. https://github.com/quodlibet/quodlibet/pull/3800/commits/49dd6474484f9f157adae485a51afc37e6c884f4 should fix it.

Could we either cherry-pick the fix or downgrade quodlibet to Python 3.9 again?

Comment 3 hannes 2021-10-01 18:00:46 UTC
Please see if this scratch build of current git master fixes the issue.
https://koji.fedoraproject.org/koji/taskinfo?taskID=76574947
I think either cherry-picking or using the git master is better. Ideally, they would release a new version before fedora 35 comes out, but if not I think incorporating the patch is easiest.

Comment 4 Fedora Update System 2021-10-01 18:25:21 UTC
FEDORA-2021-bc2d15e0a2 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-bc2d15e0a2

Comment 5 Fedora Update System 2021-10-02 02:23:35 UTC
FEDORA-2021-bc2d15e0a2 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-bc2d15e0a2`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-bc2d15e0a2

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Jonathan S. 2021-10-02 09:54:28 UTC
That fixes quodlibet for me, thanks!

Comment 7 pzeppegno 2021-10-03 13:38:49 UTC
Yes, I can confirm I have quodlibet running again on my pc. Thanks a lot.

Comment 8 Fedora Update System 2021-10-05 00:51:05 UTC
FEDORA-2021-bc2d15e0a2 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.