Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2008684 - F35FailsToInstall: rust-spinning_top+nightly-devel
Summary: F35FailsToInstall: rust-spinning_top+nightly-devel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rust-spinning_top
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rust SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F35FinalFreezeException F35FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2021-09-28 20:14 UTC by Miro Hrončok
Modified: 2021-10-13 23:12 UTC (History)
3 users (show)

Fixed In Version: rust-spinning_top-0.2.4-3.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-13 23:12:45 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Miro Hrončok 2021-09-28 20:14:29 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (rust-spinning_top) Fails To Install in Fedora 35:

can't install rust-spinning_top+nightly-devel:
  - nothing provides (crate(lock_api/nightly) >= 0.4.0 with crate(lock_api/nightly) < 0.5.0~) needed by rust-spinning_top+nightly-devel-0.2.4-2.fc35.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Miro Hrončok 2021-10-08 17:08:20 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 2 Fabio Valentini 2021-10-08 18:12:02 UTC
Should be fixed by this update:
https://bodhi.fedoraproject.org/updates/FEDORA-2021-1327cb206c

Comment 3 Fedora Blocker Bugs Application 2021-10-12 21:11:17 UTC
Proposed as a Freeze Exception for 35-final by Fedora user decathorpe using the blocker tracking app because:

 It would be great to have the GA "fedora" repository contain the version of the package *without* the broken dependencies, otherwise the subpackages with FTI issues will stay around for the lifetime of the F35 release (and show up as a problem on the packager dashboard, for example). The update only fixes the broken dependency issue and has already been pushed to Rawhide and Fedora 34 stable repositories (and it was also confirmed that the issue is now gone there by the automatic FTI checking scripts).

Comment 4 Adam Williamson 2021-10-13 19:51:48 UTC
+3 in https://pagure.io/fedora-qa/blocker-review/issue/538 , marking accepted FE. Is any other update needed as with the diesel case, or just that one?

Comment 5 Fedora Update System 2021-10-13 19:52:21 UTC
FEDORA-2021-1327cb206c has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-1327cb206c

Comment 6 Fabio Valentini 2021-10-13 20:00:34 UTC
In this case this issue is fixed by the single update I linked above. Thanks!

Comment 7 Fedora Update System 2021-10-13 23:12:45 UTC
FEDORA-2021-1327cb206c has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.