Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2010567 - nothing provides python3-file-magic needed by cobbler-3.2.2-2.module_el8+13025+a3efc95c.noarch
Summary: nothing provides python3-file-magic needed by cobbler-3.2.2-2.module_el8+1302...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: cobbler
Version: epel8
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2011473 2012113 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-10-05 04:21 UTC by James
Modified: 2021-10-11 21:38 UTC (History)
10 users (show)

Fixed In Version: cobbler-3-820211008043036.9edba152
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-11 21:38:25 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description James 2021-10-05 04:21:46 UTC
Description of problem:
 In cento8, nothing provides python3-file-magic needed by cobbler-3.2.2 2.module_el8+13025+a3efc95c.noarch 

Version-Release number of selected component (if applicable):
cobbler-3.2.2 2.module_el8+13025+a3efc95c.noarch

How reproducible:
dnf install cobbler


Steps to Reproduce:
1. dnf install cobbler
2.
3.

Actual results:
nothing provides python3-file-magic needed by cobbler-3.2.2 2.module_el8+13025+a3efc95c.noarch

Expected results:
success install cobbler

Additional info:

Comment 1 Stefan Bluhm 2021-10-06 08:52:00 UTC
The dependency should be python3-magic.

Comment 2 Stefan Bluhm 2021-10-06 09:41:04 UTC
PRs have been raised upstream for cobbler master, 3.3 and 3.2

Comment 3 Orion Poplawski 2021-10-06 14:31:26 UTC
The dependency probably should be python3dist(file-magic).

Comment 4 Stefan Bluhm 2021-10-06 14:57:40 UTC
It will be

%define py3_module_file python%{python3_pkgversion}-magic

conforming to the rest of the upstream spec file and has already been accepted into master. It will be cherry picked to 3.3. A 3.2 release is not expected.

Comment 5 Orion Poplawski 2021-10-07 01:19:10 UTC
*** Bug 2011473 has been marked as a duplicate of this bug. ***

Comment 6 Orion Poplawski 2021-10-08 22:25:49 UTC
*** Bug 2012113 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2021-10-08 22:27:28 UTC
FEDORA-EPEL-MODULAR-2021-e87db55d54 has been submitted as an update to Fedora Epel 8 Modular. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-MODULAR-2021-e87db55d54

Comment 8 Fedora Update System 2021-10-09 01:08:03 UTC
FEDORA-EPEL-MODULAR-2021-e87db55d54 has been pushed to the Fedora Epel 8 Modular testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-MODULAR-2021-e87db55d54

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2021-10-11 21:38:25 UTC
FEDORA-EPEL-MODULAR-2021-e87db55d54 has been pushed to the Fedora Epel 8 Modular stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.