Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2019579 - dasbus.error.DBusError: [Errno 2] No such file or directory: '/mnt/sysroot/etc/resolv.conf'
Summary: dasbus.error.DBusError: [Errno 2] No such file or directory: '/mnt/sysroot/et...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 35
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:7017ff42f044eba15f051231dfe...
: 2019580 2020016 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-11-02 21:13 UTC by Stephan
Modified: 2022-05-02 11:35 UTC (History)
17 users (show)

Fixed In Version: anaconda-35.22.2-4 anaconda-35.22.2-4.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-02-13 01:15:40 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: anaconda-tb (deleted)
2021-11-02 21:13 UTC, Stephan
no flags Details
File: anaconda.log (deleted)
2021-11-02 21:13 UTC, Stephan
no flags Details
File: dbus.log (deleted)
2021-11-02 21:13 UTC, Stephan
no flags Details
File: dnf.librepo.log (deleted)
2021-11-02 21:13 UTC, Stephan
no flags Details
File: environ (deleted)
2021-11-02 21:13 UTC, Stephan
no flags Details
File: hawkey.log (deleted)
2021-11-02 21:13 UTC, Stephan
no flags Details
File: ks.cfg (deleted)
2021-11-02 21:13 UTC, Stephan
no flags Details
File: lorax-packages.log (deleted)
2021-11-02 21:13 UTC, Stephan
no flags Details
File: lsblk_output (deleted)
2021-11-02 21:13 UTC, Stephan
no flags Details
File: nmcli_dev_list (deleted)
2021-11-02 21:13 UTC, Stephan
no flags Details
File: os_info (deleted)
2021-11-02 21:13 UTC, Stephan
no flags Details
File: program.log (deleted)
2021-11-02 21:13 UTC, Stephan
no flags Details
File: storage.log (deleted)
2021-11-02 21:13 UTC, Stephan
no flags Details
File: syslog (deleted)
2021-11-02 21:13 UTC, Stephan
no flags Details
File: packaging.log (deleted)
2021-11-02 21:13 UTC, Stephan
no flags Details
F35 with updates inside kickstart (deleted)
2022-01-18 08:57 UTC, Christoph Karl
no flags Details

Description Stephan 2021-11-02 21:13:15 UTC
Description of problem:
during install

Version-Release number of selected component:
anaconda-35.22.2

The following was filed automatically by anaconda:
anaconda 35.22.2 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.10/site-packages/dasbus/client/handler.py", line 497, in _handle_method_error
    raise exception from None
  File "/usr/lib/python3.10/site-packages/dasbus/client/handler.py", line 477, in _get_method_reply
    return self._handle_method_error(error)
  File "/usr/lib/python3.10/site-packages/dasbus/client/handler.py", line 444, in _call_method
    return self._get_method_reply(
  File "/usr/lib64/python3.10/site-packages/pyanaconda/modules/common/task/__init__.py", line 46, in sync_run_task
    task_proxy.Finish()
  File "/usr/lib64/python3.10/site-packages/pyanaconda/network.py", line 293, in write_configuration
    sync_run_task(task_proxy)
  File "/usr/lib64/python3.10/site-packages/pyanaconda/installation_tasks.py", line 458, in run_task
    self._task(*self._task_args, **self._task_kwargs)
  File "/usr/lib64/python3.10/site-packages/pyanaconda/installation_tasks.py", line 496, in start
    self.run_task()
  File "/usr/lib64/python3.10/site-packages/pyanaconda/installation_tasks.py", line 311, in start
    item.start()
  File "/usr/lib64/python3.10/site-packages/pyanaconda/installation_tasks.py", line 311, in start
    item.start()
  File "/usr/lib64/python3.10/site-packages/pyanaconda/installation_tasks.py", line 311, in start
    item.start()
  File "/usr/lib64/python3.10/site-packages/pyanaconda/installation.py", line 415, in run_installation
    queue.start()
  File "/usr/lib64/python3.10/threading.py", line 946, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.10/site-packages/pyanaconda/threading.py", line 275, in run
    threading.Thread.run(self)
dasbus.error.DBusError: [Errno 2] No such file or directory: '/mnt/sysroot/etc/resolv.conf'

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   inst.ks=file:/tmp.8Ub9qW3EsP inst.repo=http://www.nic.funet.fi/pub/Linux/INSTALL/fedora/linux/releases/35/Everything/x86_64/os/
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         5.14.10-300.fc35.x86_64
product:        Fedora
release:        Fedora release 35 (Thirty Five)
type:           anaconda
version:        35

Comment 1 Stephan 2021-11-02 21:13:19 UTC
Created attachment 1839386 [details]
File: anaconda-tb

Comment 2 Stephan 2021-11-02 21:13:21 UTC
Created attachment 1839387 [details]
File: anaconda.log

Comment 3 Stephan 2021-11-02 21:13:22 UTC
Created attachment 1839388 [details]
File: dbus.log

Comment 4 Stephan 2021-11-02 21:13:24 UTC
Created attachment 1839389 [details]
File: dnf.librepo.log

Comment 5 Stephan 2021-11-02 21:13:25 UTC
Created attachment 1839390 [details]
File: environ

Comment 6 Stephan 2021-11-02 21:13:26 UTC
Created attachment 1839391 [details]
File: hawkey.log

Comment 7 Stephan 2021-11-02 21:13:27 UTC
Created attachment 1839392 [details]
File: ks.cfg

Comment 8 Stephan 2021-11-02 21:13:28 UTC
Created attachment 1839393 [details]
File: lorax-packages.log

Comment 9 Stephan 2021-11-02 21:13:29 UTC
Created attachment 1839394 [details]
File: lsblk_output

Comment 10 Stephan 2021-11-02 21:13:30 UTC
Created attachment 1839395 [details]
File: nmcli_dev_list

Comment 11 Stephan 2021-11-02 21:13:32 UTC
Created attachment 1839396 [details]
File: os_info

Comment 12 Stephan 2021-11-02 21:13:33 UTC
Created attachment 1839397 [details]
File: program.log

Comment 13 Stephan 2021-11-02 21:13:34 UTC
Created attachment 1839398 [details]
File: storage.log

Comment 14 Stephan 2021-11-02 21:13:36 UTC
Created attachment 1839399 [details]
File: syslog

Comment 15 Stephan 2021-11-02 21:13:37 UTC
Created attachment 1839400 [details]
File: packaging.log

Comment 16 Stephan 2021-11-02 21:19:44 UTC
*** Bug 2019580 has been marked as a duplicate of this bug. ***

Comment 17 Stephan 2021-11-03 20:53:59 UTC
*** Bug 2020016 has been marked as a duplicate of this bug. ***

Comment 18 Radek Vykydal 2021-11-12 14:30:42 UTC
This happens when installing from Fedora 34 repository where /etc/resolv.conf created by NM is replaced by symlink created by systemd rpm post script. The symlink is dangling on which anaconda crashes.

The fix:
https://github.com/rhinstaller/anaconda/pull/3702

When installing Fedora 35 systemd packages the symlink is not created - which is a bug 2018913.

When installing with the Fedora 34 installer the symlink is created and pointing to a file (/run/systemd/resolve/stub-resolv.conf) which is preventing the crash happening in this BZ.

Comment 19 David Jansen 2021-11-18 11:29:52 UTC
Similar problem has been detected:

Attempting to install Fedora 35 using a kickstart file.

Problem seems to be related to /mnt/sysroor/etc/resolv.conf which is a symbolic link to ../run/systemd/reolve/stub-resolve.conf and that file doesn't exist (probably because systemd-resolv isn't running in the chroot environment (yet)

addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=(hd0,msdos1)//boot/installer/vmlinuz inst.ks=hd:vda1:/boot/installer/ks.cfg inst.stage2=http://fedora.strw.leidenuniv.nl/fedora35/x86_64/os/ inst.vnc inst.vncconnect=132.229.214.49:5500 noshell inst.selinux=0 ip=dhcp ipv6.disable=1 rd.net.timeout.carrier=30
hashmarkername: anaconda
kernel:         5.14.10-300.fc35.x86_64
package:        anaconda-35.22.2
product:        Fedora
reason:         dasbus.error.DBusError: [Errno 2] No such file or directory: '/mnt/sysroot/etc/resolv.conf'
release:        Fedora release 35 (Thirty Five)
version:        35

Comment 20 Christoph Karl 2022-01-06 09:04:01 UTC
Will this be fixed for F35?

Comment 21 Paul Whalen 2022-01-17 21:31:43 UTC
Similar problem has been detected:

Attempted installation of Fedora 35 (armhfp) with updates enabled. 

addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   inst.repo=https://dl.fedoraproject.org/pub/fedora/linux/releases/35/Everything/armhfp/os/ initrd=initrd
hashmarkername: anaconda
kernel:         5.14.10-300.fc35.armv7hl
package:        anaconda-35.22.2
product:        Fedora
reason:         dasbus.error.DBusError: [Errno 2] No such file or directory: '/mnt/sysroot/etc/resolv.conf'
release:        Fedora release 35 (Thirty Five)
version:        35

Comment 22 Christoph Karl 2022-01-18 08:56:51 UTC
Sorry for the screenshot, but I do not know howto log into a broken kickstart installation.

First part:
Seems like anaconda is installing systemd-249.9-1.fc35

Second part:
But installed version seems to be: v249.4-2.fc35

Third part:
Maybe this is due to the following line:
protected_packages = ..., systemd, ...

Comment 23 Christoph Karl 2022-01-18 08:57:45 UTC
Created attachment 1851532 [details]
F35 with updates inside kickstart

Comment 24 Radek Vykydal 2022-01-18 10:29:04 UTC
(In reply to Christoph Karl from comment #20)
> Will this be fixed for F35?

We are not able to fix the issue on Anaconda side for F35 as we do not do respins of installer images.
I've prepared updates image with the fix (https://github.com/rhinstaller/anaconda/pull/3702) for F35:
https://rvykydal.fedorapeople.org/update-images/updates.f35-2019579-resolvconf.img

It can be applied either by installer boot option:

inst.updates=https://rvykydal.fedorapeople.org/update-images/updates.f35-2019579-resolvconf.img

or via kickstart command

updates https://rvykydal.fedorapeople.org/update-images/updates.f35-2019579-resolvconf.img

Comment 25 Christoph Karl 2022-01-18 14:45:33 UTC
(In reply to Radek Vykydal from comment #24)
> It can be applied either by installer boot option:
> 
> inst.updates=https://rvykydal.fedorapeople.org/update-images/updates.f35-
> 2019579-resolvconf.img


Thank you this is working.

Comment 26 Andrew Rechenberg 2022-01-22 16:27:37 UTC
(In reply to Radek Vykydal from comment #24)

> 
> It can be applied either by installer boot option:
> 
> inst.updates=https://rvykydal.fedorapeople.org/update-images/updates.f35-
> 2019579-resolvconf.img
> 
> or via kickstart command
> 
> updates
> https://rvykydal.fedorapeople.org/update-images/updates.f35-2019579-
> resolvconf.img

Not sure if this is just for my installation, but the updates command doesn't work in my kickstart file - I have to use the inst.upates boot option to get this working (and in my case I have to use http not https for rvykydal.fedorapeople.org).

Kickstart file is below (crypted passwords removed)

--------------


lang en_US
keyboard us
timezone America/Chicago --utc
rootpw REDACTED --iscrypted
#platform x86_64
reboot
text
url --url=https://fedora.mirror.constant.com/fedora/linux/releases/35/Everything/x86_64/os/
bootloader --append="rhgb quiet crashkernel=auto"
zerombr
clearpart --all --initlabel
autopart
#auth --passalgo=sha512 --useshadow
selinux --enforcing
firewall --enabled --http --ssh
skipx
firstboot --disable
repo --name=updates
user --name=djflux --iscrypted --password=REDACTED

# Fix resolv.conf bug - https://bugzilla.redhat.com/show_bug.cgi?id=2019579
updates https://rvykydal.fedorapeople.org/update-images/updates.f35-2019579-resolvconf.img

%packages
@^minimal-environment
kexec-tools
net-tools
vim-enhanced
%end

%post
cat >> /etc/profile.d/flux.sh << EOF
alias dir='ls -la --color | more'
alias vi=vim

export PS1="[\u@\h \w]\\$ "
EOF
%end

Comment 27 Peter Robinson 2022-01-31 14:57:10 UTC
> We are not able to fix the issue on Anaconda side for F35 as we do not do
> respins of installer images.
> I've prepared updates image with the fix
> (https://github.com/rhinstaller/anaconda/pull/3702) for F35:
> https://rvykydal.fedorapeople.org/update-images/updates.f35-2019579-
> resolvconf.img

There's unofficial respins though, and IoT does respin the installers every few weeks (this is affecting us), can we please have this pushed as a proper update.

Comment 28 Radek Vykydal 2022-02-08 09:12:15 UTC
(In reply to Peter Robinson from comment #27)
> > We are not able to fix the issue on Anaconda side for F35 as we do not do
> > respins of installer images.
> > I've prepared updates image with the fix
> > (https://github.com/rhinstaller/anaconda/pull/3702) for F35:
> > https://rvykydal.fedorapeople.org/update-images/updates.f35-2019579-
> > resolvconf.img
> 
> There's unofficial respins though, and IoT does respin the installers every
> few weeks (this is affecting us), can we please have this pushed as a proper
> update.

We are going to port the fix to F35.

Comment 29 Fedora Update System 2022-02-09 00:28:41 UTC
FEDORA-2022-6ceb71ae38 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-6ceb71ae38

Comment 30 Martin Kolman 2022-02-09 00:43:35 UTC
(In reply to Peter Robinson from comment #27)
> > We are not able to fix the issue on Anaconda side for F35 as we do not do
> > respins of installer images.
> > I've prepared updates image with the fix
> > (https://github.com/rhinstaller/anaconda/pull/3702) for F35:
> > https://rvykydal.fedorapeople.org/update-images/updates.f35-2019579-
> > resolvconf.img
> 
> There's unofficial respins though, and IoT does respin the installers every
> few weeks (this is affecting us), can we please have this pushed as a proper
> update.

(In reply to Radek Vykydal from comment #28)
> (In reply to Peter Robinson from comment #27)
> > > We are not able to fix the issue on Anaconda side for F35 as we do not do
> > > respins of installer images.
> > > I've prepared updates image with the fix
> > > (https://github.com/rhinstaller/anaconda/pull/3702) for F35:
> > > https://rvykydal.fedorapeople.org/update-images/updates.f35-2019579-
> > > resolvconf.img
> > 
> > There's unofficial respins though, and IoT does respin the installers every
> > few weeks (this is affecting us), can we please have this pushed as a proper
> > update.
> 
> We are going to port the fix to F35.

As agreed, I did a F35 build (anaconda-35.22.2-4) with (only) the resolv.conf fix, which is now in Bodhi. :)

Comment 31 Fedora Update System 2022-02-10 02:56:36 UTC
FEDORA-2022-6ceb71ae38 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-6ceb71ae38`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-6ceb71ae38

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 32 Fedora Update System 2022-02-13 01:15:40 UTC
FEDORA-2022-6ceb71ae38 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 33 Brian J. Murrell 2022-04-11 13:02:46 UTC
I am seeing this on current F35 kickstarts also.  Is it updated in current F35?  This is not clear to me.  If so, is there anything special I have to do to get the update in my KS or should it "just happen"?

Comment 34 Radek Vykydal 2022-04-11 14:49:34 UTC
(In reply to Brian J. Murrell from comment #33)
> I am seeing this on current F35 kickstarts also.  Is it updated in current
> F35?  This is not clear to me.  If so, is there anything special I have to
> do to get the update in my KS or should it "just happen"?

The anaconda package for F35 was updated, but to be applied in the installation the installer iso would need to be rebuilt with the updated package.
For the existing F35 isos the updates image with fix needs to be used as described in comment #24.

Comment 35 Brian J. Murrell 2022-04-11 14:52:54 UTC
What I don't understand is why this all "just worked" as recent as a couple of days ago and is now broken, when all of the activity on this issue is a couple of months old.

Comment 36 Radek Vykydal 2022-04-12 11:20:07 UTC
(In reply to Brian J. Murrell from comment #35)
> What I don't understand is why this all "just worked" as recent as a couple
> of days ago and is now broken, when all of the activity on this issue is a
> couple of months old.

Maybe a new F35 version of systemd (systemd-249.11-1.fc35) which gets installed (using repo with f35 updates) ?
The https://koji.fedoraproject.org/koji/buildinfo?buildID=1943441 built on Apr 6 has

> * Wed Apr 06 2022 Zbigniew Jędrzejewski-Szmek <zbyszek.pl> - 249.11-1
> - Update to latest bugfix release (#2039854)
> - Create /etc/resolv.conf symlink if nothing is present yet (#2032085)

^ this change

> - Drop scriptlet for handling nobody user upgrades from Fedora <28
> - Move part of %post scriptlet for resolved to %posttrans (#2072574)

that could trigger the issue (ie creating of the symlink working same as in comment #18 with F34 installed where the dangling symlink is created).

Comment 37 Radek Vykydal 2022-04-12 11:37:36 UTC
Indeed, see https://bugzilla.redhat.com/show_bug.cgi?id=2074083.


Note You need to log in before you can comment on or make changes to this bug.