Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2020246 - kpcli could not be installed on Fedora 35
Summary: kpcli could not be installed on Fedora 35
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kpcli
Version: 35
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Matías Kreder
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-11-04 12:49 UTC by Axel Sommerfeldt
Modified: 2021-11-09 12:53 UTC (History)
4 users (show)

Fixed In Version: kpcli-3.6-5.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-11-05 01:08:16 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Axel Sommerfeldt 2021-11-04 12:49:19 UTC
Description of problem:
The package kpcli could not be installed on Fedora 35

Version-Release number of selected component (if applicable):
3.6-4.fc35

How reproducible:
This is reproducible without problems, at least on my PC.

Steps to Reproduce:
1. Get root permissions (for example with "su -")
2. dnf install kpcli
3.

Actual results:
# LANG=C dnf install kpcli
Last metadata expiration check: 0:46:21 ago on Thu Nov  4 12:55:04 2021.
Error: 
 Problem: package kpcli-3.6-4.fc35.noarch requires perl(Crypt::PWSafe3), but none of the providers can be installed
  - package perl-Crypt-PWSafe3-1.22-17.fc34.noarch requires perl(:MODULE_COMPAT_5.32.1), but none of the providers can be installed
  - conflicting requests
  - package perl-libs-4:5.32.1-471.module_f35+12589+8a7d3254.x86_64 is filtered out by modular filtering
(try to add '--skip-broken' to skip uninstallable packages)

Expected results:
dnf should install kpcli without problems.

Additional info:
- none -

Comment 1 Charles R. Anderson 2021-11-04 15:39:43 UTC

*** This bug has been marked as a duplicate of bug 1964646 ***

Comment 2 Charles R. Anderson 2021-11-04 16:19:33 UTC
I've reopened this to deal with in in different way:

- Replace Requires: with Suggests: perl(Crypt::PWSafe3) due to FTBFS rhbz #1939424
- Password Safe v3 (.psafe3) files cannot be opened until #1939424 is fixed.

Comment 3 Lester Hightower 2021-11-04 16:31:43 UTC
@cra.edu - I am the author of kpcli. Changing perl(Crypt::PWSafe3) from Requires to Suggests is the correct long-term fix, regardless of the outcome of the other bug, because Crypt::PWSafe3 is an optional module for kpcli. Without Crypt::PWSafe3, the only feature lost in kpcli is importing Password Safe v3 files, a seldom used feature.

Comment 4 Fedora Update System 2021-11-04 16:44:49 UTC
FEDORA-2021-a149370187 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-a149370187

Comment 5 Charles R. Anderson 2021-11-04 16:49:20 UTC
@lester.hightower (In reply to Lester Hightower from comment #3)
> @cra.edu - I am the author of kpcli. Changing perl(Crypt::PWSafe3)
> from Requires to Suggests is the correct long-term fix, regardless of the
> outcome of the other bug, because Crypt::PWSafe3 is an optional module for
> kpcli. Without Crypt::PWSafe3, the only feature lost in kpcli is importing
> Password Safe v3 files, a seldom used feature.

Agreed, although I could change it from Suggests: to Recommends: at some point:

https://docs.fedoraproject.org/en-US/packaging-guidelines/WeakDependencies/

Comment 6 Axel Sommerfeldt 2021-11-04 22:14:38 UTC
(In reply to Fedora Update System from comment #4)
> FEDORA-2021-a149370187 has been submitted as an update to Fedora 35.
> https://bodhi.fedoraproject.org/updates/FEDORA-2021-a149370187

Installed and (superficially) tested, it works now fine for me.
(Have left positive karma)

Thank you very much for the fast fix!

Comment 7 Fedora Update System 2021-11-05 01:08:16 UTC
FEDORA-2021-a149370187 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 8 Lester Hightower 2021-11-09 12:53:01 UTC
Thanks for your work on this, Charles.


Note You need to log in before you can comment on or make changes to this bug.