Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2029396 - shimx64.efi does not boot into fwupdx64.efi
Summary: shimx64.efi does not boot into fwupdx64.efi
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: shim
Version: 35
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-12-06 11:58 UTC by Dennis Schridde
Modified: 2022-06-17 01:19 UTC (History)
10 users (show)

Fixed In Version: shim-15.6-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-06-17 01:19:11 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github fwupd firmware-lenovo-thinkpad issues 123 0 None closed A firmware update will not install on my Lenovo Thinkpad X1 Carbon 7th running Ubuntu 21.04 2021-12-06 11:59:03 UTC
Github rhboot shim pull 379 0 None Merged shim: another attempt to fix load options handling 2021-12-06 11:58:45 UTC

Description Dennis Schridde 2021-12-06 11:58:46 UTC
Description of problem:

shimx64.efi does not appear to boot into fwupdx64.efi (booting into "Linux-Firmware-Updater" behaves the same as booting into "Fedora", firmware updates do not get installed).


Version-Release number of selected component (if applicable):

Installed Packages                                                                                                                                                                                                                                                                                                            
Name         : efibootmgr                                                                                                                                                                                                                                                                                                     
Version      : 16                                                                                                                                                                                                                                                                                                             
Release      : 11.fc35                                                                                                                                                                                                                                                                                                        
Architecture : x86_64
Size         : 94 k
Source       : efibootmgr-16-11.fc35.src.rpm
Repository   : @System
From repo    : anaconda
Summary      : EFI Boot Manager
URL          : https://github.com/rhboot/efibootmgr/
License      : GPLv2+
Description  : efibootmgr displays and allows the user to edit the Intel Extensible
             : Firmware Interface (EFI) Boot Manager variables.  Additional
             : information about EFI can be found at https://uefi.org/.

Name         : fwupd
Version      : 1.7.2
Release      : 1.fc35
Architecture : x86_64
Size         : 6.9 M
Source       : fwupd-1.7.2-1.fc35.src.rpm
Repository   : @System
From repo    : updates
Summary      : Firmware update daemon
URL          : https://github.com/fwupd/fwupd
License      : LGPLv2+
Description  : fwupd is a daemon to allow session software to update device firmware.

Name         : shim-x64
Version      : 15.4
Release      : 5
Architecture : x86_64
Size         : 3.6 M
Source       : shim-15.4-5.src.rpm
Repository   : @System
From repo    : anaconda
Summary      : First-stage UEFI bootloader
URL          : https://github.com/rhboot/shim/
License      : BSD
Description  : Initial UEFI bootloader that handles chaining to a trusted full
             : bootloader under secure boot environments. This package contains the
             : version signed by the UEFI signing service.


How reproducible: Every time.


Steps to Reproduce:
1. Setup firmware update for installation with `fwupdmgr update`
2. Reboot computer (regularly, or manually booting into Linux-Firmware-Updater, no difference)
3. Observe that you are dropped straight into Grub.

Actual results:

I am being send straight into Grub.  Nothing that indicates that a firmware updater (fwupdx64.efi) is being run.


Expected results:

Firmware should update.


Additional info:

This appears to be https://bugs.launchpad.net/ubuntu/+source/shim/+bug/1929471 and https://github.com/fwupd/firmware-lenovo-thinkpad/issues/123 which are supposedly fixed by https://github.com/rhboot/shim/pull/379.

Comment 1 nh 2021-12-21 09:02:13 UTC
Exact same Problem here on Thinkpad X1 Carbon Gen 9 / Fedora Workstation 35 (up to date).

Comment 2 sorje 2021-12-21 18:41:49 UTC
i have same problem on Thinkpad X1 Carbon Gen 6 using Fedora 35 (latest) when i disable Secureboot and run fwupdmgr upgrade and reboot then it waits for a minute and then reboot into grub again.

only ME update is failing for me, i have sent debug info from fwupdmgr.

I managed to upgrade bios using fwupdmgr update <Device ID>

Comment 3 Dennis Schridde 2022-01-12 12:05:43 UTC
(In reply to sorje from comment #2)
> I managed to upgrade bios using fwupdmgr update <Device ID>

This alone did not yield success on my system.  Disabling Secure Boot is probably crucial, but I did not try that.

Comment 4 Dennis Schridde 2022-01-25 21:58:48 UTC
Persists with fwupd 1.7.4:

Last metadata expiration check: 1:10:07 ago on Tue 25 Jan 2022 09:46:32 PM CET.                                                                                                                                                                                                                                               
Installed Packages                                                                                                                                                                                                                                                                                                            
Name         : efibootmgr                                                                                                                                                                                                                                                                                                     
Version      : 16                                                                                                                                                                                                                                                                                                             
Release      : 11.fc35                                                                                                                                                                                                                                                                                                        
Architecture : x86_64
Size         : 94 k
Source       : efibootmgr-16-11.fc35.src.rpm
Repository   : @System
From repo    : anaconda
Summary      : EFI Boot Manager
URL          : https://github.com/rhboot/efibootmgr/
License      : GPLv2+
Description  : efibootmgr displays and allows the user to edit the Intel Extensible
             : Firmware Interface (EFI) Boot Manager variables.  Additional
             : information about EFI can be found at https://uefi.org/.

Name         : fwupd
Version      : 1.7.4
Release      : 1.fc35
Architecture : x86_64
Size         : 7.1 M
Source       : fwupd-1.7.4-1.fc35.src.rpm
Repository   : @System
From repo    : updates
Summary      : Firmware update daemon
URL          : https://github.com/fwupd/fwupd
License      : LGPLv2+
Description  : fwupd is a daemon to allow session software to update device firmware.

Name         : shim-x64
Version      : 15.4
Release      : 5
Architecture : x86_64
Size         : 3.6 M
Source       : shim-15.4-5.src.rpm
Repository   : @System
From repo    : anaconda
Summary      : First-stage UEFI bootloader
URL          : https://github.com/rhboot/shim/
License      : BSD
Description  : Initial UEFI bootloader that handles chaining to a trusted full
             : bootloader under secure boot environments. This package contains the
             : version signed by the UEFI signing service.

Comment 5 Kamil Páral 2022-02-28 15:49:18 UTC
This might be a duplicate of bug 2010595

Comment 6 Fedora Update System 2022-06-15 17:42:29 UTC
FEDORA-2022-98830efc68 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-98830efc68

Comment 7 Fedora Update System 2022-06-16 02:15:01 UTC
FEDORA-2022-98830efc68 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-98830efc68`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-98830efc68

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2022-06-17 01:19:11 UTC
FEDORA-2022-98830efc68 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.