Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2031379 - [regression] .dwg file no longer opens
Summary: [regression] .dwg file no longer opens
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: librecad
Version: 35
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-12-11 13:31 UTC by Jan Kratochvil
Modified: 2022-10-04 00:51 UTC (History)
2 users (show)

Fixed In Version: librecad-2.2.0-0.13.rc3.el7 librecad-2.2.0-0.13.rc3.fc34 librecad-2.2.0-0.15.rc4.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-02-12 05:23:52 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
camotes.dwg (deleted)
2021-12-11 13:31 UTC, Jan Kratochvil
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github LibreCAD libdxfrw issues 56 0 None open Regression: DWG file which worked in 0.6.3 no longer works in 1.0.1 2021-12-30 21:05:23 UTC

Description Jan Kratochvil 2021-12-11 13:31:07 UTC
Created attachment 1845818 [details]
camotes.dwg

Description of problem:
I can no longer open a .dwg file I could open before.

Version-Release number of selected component (if applicable):
PASS: librecad-2.2.0-0.10.rc2.fc35.x86_64 libdxfrw-0.6.3-19.fc35.x86_64
FAIL: librecad-2.2.0-0.11.rc2.fc35.x86_64 libdxfrw-1.0.1-1.fc35.x86_64

How reproducible:
Always.

Steps to Reproduce:
Open attached "camotes.dwg".

Actual results:
Import error: error reading DXF/DWG tables
No file opened.

Expected results:
Opened file.

Additional info:
I got the .dwg file. I cannot produce it myself. I am not aware how the file was produced, I expect it is from some commercial CAD software.

Comment 1 Fedora Update System 2022-02-03 21:07:14 UTC
FEDORA-2022-2e85e6cfc9 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-2e85e6cfc9

Comment 2 Fedora Update System 2022-02-03 21:07:25 UTC
FEDORA-2022-08d7ee21f7 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2022-08d7ee21f7

Comment 3 Fedora Update System 2022-02-03 21:08:44 UTC
FEDORA-EPEL-2022-5aac445eff has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-5aac445eff

Comment 4 Fedora Update System 2022-02-04 01:30:47 UTC
FEDORA-EPEL-2022-5aac445eff has been pushed to the Fedora EPEL 7 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-5aac445eff

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2022-02-04 02:15:16 UTC
FEDORA-2022-08d7ee21f7 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-08d7ee21f7`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-08d7ee21f7

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2022-02-04 02:28:06 UTC
FEDORA-2022-2e85e6cfc9 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-2e85e6cfc9`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-2e85e6cfc9

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Jan Kratochvil 2022-02-04 14:44:31 UTC
The issue is not yet fixed - there are missing fonts, they were not missing: https://github.com/LibreCAD/libdxfrw/issues/56#issuecomment-1030050434

Comment 8 Fedora Update System 2022-02-12 00:42:15 UTC
FEDORA-EPEL-2022-5aac445eff has been pushed to the Fedora EPEL 7 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 9 Fedora Update System 2022-02-12 01:15:10 UTC
FEDORA-2022-08d7ee21f7 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 10 Jan Kratochvil 2022-02-12 05:16:48 UTC
The issue is still not fixed as described upstream: https://github.com/LibreCAD/libdxfrw/issues/56#issuecomment-1030050434

Comment 11 Jan Kratochvil 2022-02-12 05:23:52 UTC
I will just request a new Fedora build after the upstream bug gets fixed:
https://github.com/LibreCAD/libdxfrw/issues/59

Comment 12 Fedora Update System 2022-09-26 01:28:14 UTC
FEDORA-2022-3dd3274ae2 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-3dd3274ae2`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-3dd3274ae2

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Fedora Update System 2022-10-04 00:51:24 UTC
FEDORA-2022-3dd3274ae2 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.