Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2032963 - nouveau display fails on nvidia GK107GLM [Quadro K1000M] on kernel-5.15.*
Summary: nouveau display fails on nvidia GK107GLM [Quadro K1000M] on kernel-5.15.*
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 35
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-12-15 14:55 UTC by todd_lewis
Modified: 2022-03-08 21:32 UTC (History)
19 users (show)

Fixed In Version: kernel-5.16.12-200.fc35 kernel-5.16.12-100.fc34
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-03-05 18:30:41 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description todd_lewis 2021-12-15 14:55:22 UTC
User-Agent:       Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:95.0) Gecko/20100101 Firefox/95.0
Build Identifier: 

Fedora 35 laptop, Nvidia GK107GLM [Quadro K1000M] display, nouveau driver, any 5.15.* kernel released so far:

After grub, initial text messages, when it would normally switch to the Plymouth "loading" screen, the display continues to show the text messages.

When the login greeter should appear, the text messages remain on screen. However, the greeter is running, and if I enter my password (blind), the screen clears and my MATE desktop appears -- without a mouse pointer.

Even though the mouse pointer isn't displayed, as I move the mouse around, desktop icons highlight as the invisible mouse pointer moves over them. Menus work, terminals work, text selection with the mouse works -- all without showing the mouse icon.

At this point, if the screensaver kicks in, or if I switch to a virtual terminal (Ctrl-Alt-F2, say), the screen goes blank/black and nothing I've found will show any non-black pixels before a reboot.

Although the screen is blank, I can switch to a VT, login as root, and issue a `reboot`, and it does reboot. Subsequent examination of journalctl output shows no errors. Comparing against logs from kernel-5.14.18-300.fc35 for example shows no unexpected differences.

Reproducible: Always

Steps to Reproduce:
1. Boot any released kernel-5.15.* so far (5.15.7 as of right now)
2.
3.
Actual Results:  
No Plymouth screen.
No greeter.
After (blind) login through invisible greeter, desktop works except for no mouse pointer.
If anything blanks the screen from then on, it remains blank until reboot.
Absolutely no indication of errors, warnings, or issues with nouveau or display in the logs.

Expected Results:  
Plymouth "Fedora loading..." screen, followed by greeter, followed by working desktop, with ability to switch to VTs and back to desktop, and activate/deactivate screensaver, all of which works with all Fedora 35 kernels up through 5.14.18-300.

The *only* "interesting" difference I've found between 5.14 and 5.15 reports is the "size" that `lshw` shows for "*-cpu". Under kernel-5.14.18-300 (the one in which everything works) "*-cpu / size: 1404MHz", whereas under kernel-5.15.7-200 `lshw` shows "*-cpu / size: 1832MHZ". Whether that's somehow relevant I don't know.

I'm hanging on to my 5.14.17-301 and 5.14.18-300 fc35 kernels, because the machine is essentially useless with any 5.15.* kernel's nouveau driver.

I can make available logs, dumps, reports etc. if that will help.

Comment 1 todd_lewis 2021-12-23 20:50:45 UTC
same behavior through kernel 5.15.10-200.fc35

Comment 2 todd_lewis 2022-02-04 09:51:41 UTC
There is hope upstream: https://gitlab.freedesktop.org/drm/nouveau/-/issues/137#note_1245447

Comment 3 todd_lewis 2022-02-27 21:06:52 UTC
The fix at https://cgit.freedesktop.org/drm-tip/commit/?id=6b0076540faffd47f5a899bf12f3528c4f0e726b works with all 5.15.x kernels and has been pushed to a -next branch, so it won't land until 5.18-rc1 (which will take roughly 4-5 weeks).

Any chance of getting this 2-line fix in a Fedora kernel sooner than that?

Comment 4 Fedora Update System 2022-03-03 01:45:47 UTC
FEDORA-2022-87ab5981f9 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-87ab5981f9

Comment 5 Fedora Update System 2022-03-03 01:45:50 UTC
FEDORA-2022-e13e3b6698 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2022-e13e3b6698

Comment 6 Fedora Update System 2022-03-03 16:38:59 UTC
FEDORA-2022-87ab5981f9 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-87ab5981f9`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-87ab5981f9

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2022-03-03 16:44:47 UTC
FEDORA-2022-e13e3b6698 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-e13e3b6698`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-e13e3b6698

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2022-03-05 18:30:41 UTC
FEDORA-2022-87ab5981f9 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 9 Fedora Update System 2022-03-08 21:32:56 UTC
FEDORA-2022-e13e3b6698 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.