Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2036058 - lxqt-globalkeys not running
Summary: lxqt-globalkeys not running
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lxqt-globalkeys
Version: 35
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Zamir SUN
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-12-29 15:08 UTC by andy
Modified: 2022-05-09 01:35 UTC (History)
8 users (show)

Fixed In Version: lxqt-globalkeys-0.17.0-2.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-05-09 01:35:45 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description andy 2021-12-29 15:08:35 UTC
Description of problem:
"preference -> session settings -> global keyboard shortcuts" not running
manual start does not work (most of the time)


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. "preference -> session settings -> global keyboard shortcuts"
2.
3.

Actual results:
Does not work (most of the time)
see journalctl below
=================================================
-- Journal begins at Fri 2021-07-16 22:53:56 HKT, ends at Wed 2021-12-29 22:59:54 HKT. --
Dec 29 22:33:37 MiWiFi-RM1800-srv audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=dnf-makecache>
Dec 29 22:33:37 MiWiFi-RM1800-srv audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=dnf-makecache >
Dec 29 22:33:37 MiWiFi-RM1800-srv systemd[1]: dnf-makecache.service: Consumed 22.501s CPU time.
Dec 29 22:40:38 MiWiFi-RM1800-srv lxqt-globalkeysd[4337]: The X11 connection broke: No error (code 0)
Dec 29 22:40:38 MiWiFi-RM1800-srv lxqt-globalkeysd[4337]: QSocketNotifier: Socket notifiers cannot be enabled or disabled from another thread
Dec 29 22:40:38 MiWiFi-RM1800-srv lxqt-notificationd[1264]: QToolButton(0x55b828b313f0, name="closeButton")  does not have a property named  "icon-size"
Dec 29 22:58:17 MiWiFi-RM1800-srv rtkit-daemon[843]: Supervising 6 threads of 4 processes of 1 users.
Dec 29 22:58:17 MiWiFi-RM1800-srv rtkit-daemon[843]: Supervising 6 threads of 4 processes of 1 users.
Dec 29 22:58:23 MiWiFi-RM1800-srv rtkit-daemon[843]: Supervising 6 threads of 4 processes of 1 users.
Dec 29 22:58:23 MiWiFi-RM1800-srv rtkit-daemon[843]: Supervising 6 threads of 4 processes of 1 users.
Dec 29 22:58:29 MiWiFi-RM1800-srv systemd[1]: Starting SSSD Kerberos Cache Manager...
Dec 29 22:58:30 MiWiFi-RM1800-srv systemd[1]: Started SSSD Kerberos Cache Manager.
Dec 29 22:58:30 MiWiFi-RM1800-srv audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=sssd-kcm comm>
Dec 29 22:58:30 MiWiFi-RM1800-srv sssd_kcm[4607]: Starting up
Dec 29 22:58:32 MiWiFi-RM1800-srv rtkit-daemon[843]: Supervising 6 threads of 4 processes of 1 users.
Dec 29 22:58:32 MiWiFi-RM1800-srv rtkit-daemon[843]: Supervising 6 threads of 4 processes of 1 users.
Dec 29 22:58:50 MiWiFi-RM1800-srv rtkit-daemon[843]: Supervising 6 threads of 4 processes of 1 users.
Dec 29 22:58:50 MiWiFi-RM1800-srv rtkit-daemon[843]: Supervising 6 threads of 4 processes of 1 users.
Dec 29 22:59:54 MiWiFi-RM1800-srv lxqt-globalkeysd[4673]: The X11 connection broke: No error (code 0)
Dec 29 22:59:54 MiWiFi-RM1800-srv lxqt-globalkeysd[4673]: QSocketNotifier: Socket notifiers cannot be enabled or disabled from another thread


=================================================


Expected results:
should auto start


Additional info:

seems to start some 1 month ago after some updates.
if i recall it is ibus update 
unsure if it is relevant

Comment 1 andy 2022-01-04 14:38:25 UTC
seems like it is addressed in lxqt 1.0.1 thanks

https://lxqt-project.org/release/2022/01/01/lxqt-session-1-0-1/

Comment 2 Ben Cotton 2022-04-06 16:31:18 UTC
I have scratch builds of 1.0.1 available for

Rawhide (F37): https://koji.fedoraproject.org/koji/taskinfo?taskID=85254676
F36: https://koji.fedoraproject.org/koji/taskinfo?taskID=85255824 

If someone who uses this can verify that the new builds work, I'll submit a pull request for the maintainer and file a freeze exception proposal to get this into the F36 release media.

Comment 3 andy 2022-04-10 16:26:16 UTC
Thanks.
tried download F36 lxqt-globalkeys-1.0.1-1.fc36.x86_64.rpm


andy@MiWiFi-RM1800-srv Downloads]$ ls -l lxqt-globalkeys-1.0.1-1.fc36.x86_64.rpm 
-rw-r--r--. 1 andy andy 210189 Apr 11 00:16 lxqt-globalkeys-1.0.1-1.fc36.x86_64.rpm
[andy@MiWiFi-RM1800-srv Downloads]$ sudo dnf install lxqt-globalkeys-1.0.1-1.fc36.x86_64.rpm
[sudo] password for andy: 
Last metadata expiration check: 2:23:21 ago on Sun 10 Apr 2022 09:58:18 PM HKT.
Error: 
 Problem: conflicting requests
  - nothing provides liblxqt.so.1()(64bit) needed by lxqt-globalkeys-1.0.1-1.fc36.x86_64
(try to add '--skip-broken' to skip uninstallable packages)

Comment 4 andy 2022-04-11 14:12:30 UTC
to clarify I am yet on Fedora 35 so may not be able to test it...

Comment 5 Ben Cotton 2022-04-11 14:29:00 UTC
Ah! That would explain it. Looks like the LXQt libraries it requires aren't built for F35. LXQt 1.0 is only available in F36 and Rawhide.

Would you be able to test with the Fedora LXQt 36 Beta? https://download.fedoraproject.org/pub/fedora/linux/releases/test/36_Beta/Spins/x86_64/iso/Fedora-LXQt-Live-x86_64-36_Beta-1.4.iso

Comment 6 andy 2022-04-12 14:02:14 UTC
do not have a F36 readily avail. take quite some work to insatll iso and test.
assume it could be tested after F36 live which is just a week later?
Thanks.

Assume F36 when avail comes with lxqt-globalkeys 1.0 and I would update it to lxqt-globalkeys 1.0.1 then.

Comment 7 Björn Persson 2022-04-19 21:08:46 UTC
Fix for F35:
https://src.fedoraproject.org/rpms/lxqt-globalkeys/pull-request/1

Comment 8 andy 2022-04-20 14:38:38 UTC
thanks for the f35 fix. have installed to F35
sudo dnf install lxqt-globalkeys-0.17.0-2.fc35.x86_64.rpm

have done (a) logout/login, (b) preference-> session settings-> stop/start (c) reboot.
in all cases the global keyboard shortcuts are running

Comment 9 Fedora Update System 2022-05-01 09:29:20 UTC
FEDORA-2022-7adf7cf0e9 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-7adf7cf0e9

Comment 11 Fedora Update System 2022-05-01 09:31:41 UTC
FEDORA-2022-4bb60a6cbb has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-4bb60a6cbb

Comment 12 Fedora Update System 2022-05-01 19:43:24 UTC
FEDORA-2022-4bb60a6cbb has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-4bb60a6cbb`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-4bb60a6cbb

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Fedora Update System 2022-05-09 01:35:45 UTC
FEDORA-2022-4bb60a6cbb has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.