Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2036290 - python3-dask provides "python3dist(dask) = 0"
Summary: python3-dask provides "python3dist(dask) = 0"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-dask
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Elliott Sales de Andrade
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 2036256 2036265
TreeView+ depends on / blocked
 
Reported: 2021-12-31 01:37 UTC by Miro Hrončok
Modified: 2022-01-25 01:10 UTC (History)
2 users (show)

Fixed In Version: python-dask-2022.1.0-3.fc34~bootstrap python-dask-2022.1.0-3.fc35~bootstrap
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-01-25 01:02:37 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Miro Hrončok 2021-12-31 01:37:37 UTC
Description of problem:
Latest upgrade of python3-dask provides "python3dist(dask) = 0" instead of the actual version.

Version-Release number of selected component (if applicable):
2021.12.0-1.fc34~bootstrap
2021.12.0-1.fc35~bootstrap

This affects Fedoras 34 and 35 but not 36.

Steps to Reproduce:
1. repoquery --repo=updates --releasever=34 --provides python3-dask --latest=1
2. repoquery --repo=updates --releasever=35 --provides python3-dask --latest=1

Actual results:
...
python3.10dist(dask) = 0 / python3.9dist(dask) = 0
python3dist(dask) = 0


Expected results:
...
python3.10dist(dask) = 2021.12 / python3.9dist(dask) = 2021.12
python3dist(dask) = 2021.12

Comment 1 Elliott Sales de Andrade 2021-12-31 03:41:24 UTC
Well, I don't know about that, all versions are built from the same spec commit, and there are no release-specific sections. That version is all autogenerated by the Python macros, too.

Comment 2 Miro Hrončok 2021-12-31 12:45:58 UTC
It is generated from /usr/lib/python3.10/site-packages/dask-0+unknown.dist-info/METADATA

It has:

Name: dask
Version: 0+unknown

Comment 3 Elliott Sales de Andrade 2022-01-16 05:38:39 UTC
The problem appears to be that I switched to the GitHub tarball. This was because the sdist was missing some files, which broke testing. I don't know how to override versioneer, so I grabbed _version.py from the sdist which seems to fix it.

Comment 4 Fedora Update System 2022-01-16 06:07:56 UTC
FEDORA-2022-d2e40bde02 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-d2e40bde02

Comment 5 Fedora Update System 2022-01-16 06:08:25 UTC
FEDORA-2022-235e3bac5e has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2022-235e3bac5e

Comment 6 Fedora Update System 2022-01-17 02:00:04 UTC
FEDORA-2022-d2e40bde02 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-d2e40bde02`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-d2e40bde02

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2022-01-17 02:15:31 UTC
FEDORA-2022-235e3bac5e has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-235e3bac5e`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-235e3bac5e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2022-01-25 01:02:37 UTC
FEDORA-2022-235e3bac5e has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 9 Fedora Update System 2022-01-25 01:10:08 UTC
FEDORA-2022-d2e40bde02 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.