Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2038702 - SELinux is preventing fprintd from write access on the file persist.
Summary: SELinux is preventing fprintd from write access on the file persist.
Keywords:
Status: CLOSED DUPLICATE of bug 2010925
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Pytela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-01-09 17:15 UTC by calm.lamp5744
Modified: 2022-03-30 11:39 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-03-30 11:39:16 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description calm.lamp5744 2022-01-09 17:15:25 UTC
Description of problem:

SELinux is preventing fprintd from write access on the file persist.

Version-Release number of selected component (if applicable):

selinux-policy-targeted-35.8-1.fc35.noarch

How reproducible:

Each time fingerprint authentication is requested

Steps to Reproduce:
1. Install setroubleshoot
2. Enroll fingerprint using fprintd-enroll
3. Request action that requires elevated privileges (eg. open terminal and run sudo command) 
4. Observe alert from setroubleshoot and denial message in journalctl

Actual results:

SELinux denial is generated

Expected results:

No SELinux denial is generated

Additional info:

No apparent impact on function of fingerprint authentication

Comment 1 Zdenek Pytela 2022-03-30 11:39:16 UTC

*** This bug has been marked as a duplicate of bug 2010925 ***


Note You need to log in before you can comment on or make changes to this bug.