Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2039108 - bless does not start due to wrong path
Summary: bless does not start due to wrong path
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bless
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Timotheus Pokorra
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2044694 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-01-11 01:33 UTC by Timotheus Pokorra
Modified: 2022-01-30 01:33 UTC (History)
4 users (show)

Fixed In Version: bless-0.6.3-5.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-01-30 01:33:42 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Timotheus Pokorra 2022-01-11 01:33:20 UTC
As reported by Brian (Thank you!), bless does not start.

This is the error message:

Unhandled Exception:
System.IO.DirectoryNotFoundException: /usr/lib/mono/bless/../../data or /builddir/build/BUILDROOT/bless-0.6.3-3.fc35.x86_64/usr/share/bless/
  at Bless.Util.FileResourcePath.GetDataPath (System.String[] dirs) [0x0009b] in <0e0ff530a6284ca195d5355515060880>:0 
  at BlessMain..ctor (System.String[] args) [0x0004d] in <4b733e7cab994ee983281155ad35f8ea>:0 
  at BlessMain.Main (System.String[] args) [0x00000] in <4b733e7cab994ee983281155ad35f8ea>:0 
[ERROR] FATAL UNHANDLED EXCEPTION: System.IO.DirectoryNotFoundException: /usr/lib/mono/bless/../../data or /builddir/build/BUILDROOT/bless-0.6.3-3.fc35.x86_64/usr/share/bless/
  at Bless.Util.FileResourcePath.GetDataPath (System.String[] dirs) [0x0009b] in <0e0ff530a6284ca195d5355515060880>:0 
  at BlessMain..ctor (System.String[] args) [0x0004d] in <4b733e7cab994ee983281155ad35f8ea>:0 
  at BlessMain.Main (System.String[] args) [0x00000] in <4b733e7cab994ee983281155ad35f8ea>:0 

Brian suggests:

This is because a prefix is being passed to the meson build
script that ends up getting shunted in front of some important
directories (bless's data directory and the help and locale
directories.) So "/usr/share/bless" becomes
"$RPM_BUILD_ROOT/usr/share/bless" and bless crashes on launch because
it can't find necessary files. Here's a one-line patch to the spec file
that works, but there's likely a better solution involving the meson
build system config:

  %build
  meson setup build -Dprefix=$RPM_BUILD_ROOT/usr --buildtype=release
+ sed -i "s~$RPM_BUILD_ROOT~~" build/src/ConfigureDefines.cs
  ninja -C build

Comment 1 Fedora Update System 2022-01-11 01:57:01 UTC
FEDORA-2022-9e60264a5e has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-9e60264a5e

Comment 2 Fedora Update System 2022-01-12 01:48:52 UTC
FEDORA-2022-9e60264a5e has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-9e60264a5e`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-9e60264a5e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 3 Fedora Update System 2022-01-17 21:52:56 UTC
FEDORA-2022-f7f8f59d7e has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-f7f8f59d7e

Comment 4 Fedora Update System 2022-01-18 01:44:38 UTC
FEDORA-2022-f7f8f59d7e has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-f7f8f59d7e`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-f7f8f59d7e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Timotheus Pokorra 2022-01-27 04:55:20 UTC
*** Bug 2044694 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2022-01-30 01:33:42 UTC
FEDORA-2022-f7f8f59d7e has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.