Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2043335 - gtk_widget_measure: assertion 'for_size >= -1' failed
Summary: gtk_widget_measure: assertion 'for_size >= -1' failed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk4
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kalev Lember
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F36FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2022-01-21 03:27 UTC by lnie
Modified: 2022-03-29 06:11 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-03-28 17:28:48 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
journal (deleted)
2022-01-21 03:27 UTC, lnie
no flags Details
screencast (deleted)
2022-01-21 03:28 UTC, lnie
no flags Details
screenshot (deleted)
2022-02-16 02:56 UTC, lnie
no flags Details
screencast (deleted)
2022-02-16 03:00 UTC, lnie
no flags Details
screencast (deleted)
2022-02-16 03:34 UTC, lnie
no flags Details
screencast (deleted)
2022-02-16 09:49 UTC, lnie
no flags Details
before install (deleted)
2022-02-16 10:00 UTC, lnie
no flags Details
after install (deleted)
2022-02-16 10:01 UTC, lnie
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME gnome-software issues 1646 0 None None None 2022-02-16 13:48:05 UTC
GNOME Gitlab GNOME gtk issues 4517 0 None None None 2022-01-21 07:56:51 UTC

Description lnie 2022-01-21 03:27:17 UTC
Created attachment 1852395 [details]
journal

Description of problem:
As shown in the attached screencast,gnome-software gets stuck every time when 
I try to search an app in gnome-software,and as shown in the attached journal,
there are tons of "localhost-live gnome-software[3884]: gtk_widget_measure: assertion 'for_size >= -1' failed" in journal, 3 mins journal file size is more than 20M


Version-Release number of selected component (if applicable):
gnome-software-42~alpha-1.fc36.x86_64

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 lnie 2022-01-21 03:28:21 UTC
Created attachment 1852396 [details]
screencast

Comment 2 Milan Crha 2022-01-21 07:56:51 UTC
Thanks for a bug report. This is tracked upstream as a gtk4 bug [1], thus I move this there.

[1] https://gitlab.gnome.org/GNOME/gtk/-/issues/4517

Comment 3 Ben Cotton 2022-02-08 21:09:12 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 36 development cycle.
Changing version to 36.

Comment 4 lnie 2022-02-16 02:55:46 UTC
Still happens with gnome-software-42~beta-1.fc36.x86_64,and it seems get worse,Software hangs when I searched "hexc":as shown in the attached screenshot from f35,only hexchat match that string.I thought the hang will only happen  when there are many results to be displayed.

Comment 5 lnie 2022-02-16 02:56:46 UTC
Created attachment 1861382 [details]
screenshot

Comment 6 lnie 2022-02-16 03:00:46 UTC
Created attachment 1861383 [details]
screencast

Comment 7 Fedora Blocker Bugs Application 2022-02-16 03:01:54 UTC
Proposed as a Blocker for 36-final by Fedora user lnie using the blocker tracking app because:

 This is a violation of the criteria:
All applications that can be launched using the standard graphical mechanism after a default installation of Fedora Workstation on the x86_64 architecture must start successfully and withstand a basic functionality test.

Comment 8 lnie 2022-02-16 03:20:15 UTC
The hang will be triggered when install some apps (for example, firefox or chrome)

Comment 9 lnie 2022-02-16 03:34:34 UTC
Created attachment 1861386 [details]
screencast

Comment 10 Milan Crha 2022-02-16 08:12:48 UTC
It's not about the amount of apps being found, but rather about the texts being shown for them. I've been playing with this yesterday and it resulted in a fill of a crash-variant of this bug, just by disabling wrapping for some labels. More is filled upstream at:
https://gitlab.gnome.org/GNOME/gtk/-/issues/4700

Comment 11 lnie 2022-02-16 09:48:35 UTC
I got the impression that "the hang will only happen  when there are many results to be displayed" because as shown in the attached screencast, when I search"hexc" or "hex" it will not hang,but when I delete "x" ie,when the search string is "he",the hang will be triggered.I looked into the ticket you mentioned in #Comment 2,neither "testing" nor "esting" will trigger the hang for me.

Comment 12 lnie 2022-02-16 09:49:33 UTC
Created attachment 1861434 [details]
screencast

Comment 13 lnie 2022-02-16 09:59:00 UTC
Just found out that when hexchat is not installed,the hang will not be trigger whenever you search "hexc" or "hex",but will be trigger when you search"he",however after you install hexchat,the hang will be triggered if you search string shorter than "hexch",

Comment 14 lnie 2022-02-16 10:00:41 UTC
Created attachment 1861437 [details]
before install

Comment 15 lnie 2022-02-16 10:01:39 UTC
Created attachment 1861438 [details]
after install

Comment 16 Milan Crha 2022-02-16 10:06:58 UTC
This needs to wait for the upstream bug resolution. Maybe there are workarounds, but they may or may not work (as can be seen within the upstream report).

Comment 17 Milan Crha 2022-02-16 13:48:05 UTC
I also opened a bug under gnome-software [1], whose purpose is to open a discussion about possible temporary workaround on the gnome-software side.

[1] https://gitlab.gnome.org/GNOME/gnome-software/-/issues/1646

Comment 18 Milan Crha 2022-02-16 17:19:19 UTC
(In reply to Milan Crha from comment #17)
> I also opened a bug under gnome-software [1], whose purpose is to open a
> discussion about possible temporary workaround on the gnome-software side.
> 
> [1] https://gitlab.gnome.org/GNOME/gnome-software/-/issues/1646

Even that discussion is not over yet, I added the temporary workaround from that upstream bug report into gnome-software-42~beta-2.fc36.

Comment 19 Geoffrey Marr 2022-02-21 16:32:38 UTC
The decision to classify this bug as an "AcceptedBlocker (Final)" was made as it violates the following criterion:

All applications that can be launched using the standard graphical mechanism after a default installation of Fedora Workstation on the x86_64 architecture must start successfully and withstand a basic functionality test.


https://pagure.io/fedora-qa/blocker-review/issue/613

Comment 20 Kamil Páral 2022-03-15 15:02:47 UTC
(In reply to Milan Crha from comment #18)
> Even that discussion is not over yet, I added the temporary workaround from
> that upstream bug report into gnome-software-42~beta-2.fc36.

Lili, can you please confirm whether the issue is resolved with that build (or later)? Thanks.

Comment 21 lnie 2022-03-16 02:36:57 UTC
Checked with gnome-software-42~rc-2.fc36.x86_64,didn't see this bug anymore.

Comment 22 Adam Williamson 2022-03-28 17:28:48 UTC
That's stable, so we can close this.

Comment 23 Milan Crha 2022-03-29 05:43:27 UTC
(In reply to Adam Williamson from comment #22)
> That's stable, so we can close this.

I disagree. There is no fix for this on the gtk4 side (where this bug is filled for), the gnome-software contains only a workaround, which degrades the user experience. Any other application can face the same problem. Once the workaround is removed this one is back (or when they fix another bug [1]). There is a (significant) difference between a workaround and a real fix.

I gave some details on the faulty gtk4 code upstream [2] four weeks ago, but no response from there so far.

[1] https://gitlab.gnome.org/GNOME/gtk/-/issues/4714
[2] https://gitlab.gnome.org/GNOME/gtk/-/issues/4517#note_1397148

Comment 24 Adam Williamson 2022-03-29 06:11:03 UTC
There's limited value to a downstream report if we don't have an actual concrete bug that Fedora users are hitting, since upstream doesn't really do anything much with downstream reports. But if you want to keep it open, we at least need to strip the blocker status.


Note You need to log in before you can comment on or make changes to this bug.