Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2045206 - asterisk: FTBFS in Fedora rawhide/f36: ./configure cannot find dependencies for res_calendar_ews
Summary: asterisk: FTBFS in Fedora rawhide/f36: ./configure cannot find dependencies f...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: asterisk
Version: 36
Hardware: s390x
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jared Smith
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2018890 2032705 (view as bug list)
Depends On:
Blocks: F38FTBFS F39FTBFS OpenSSL3.0 F36FTBFS 2021662 F37FTBFS
TreeView+ depends on / blocked
 
Reported: 2022-01-25 16:08 UTC by Fedora Release Engineering
Modified: 2023-03-10 02:05 UTC (History)
6 users (show)

Fixed In Version: asterisk-18.12.1-1.fc38.3
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-03-10 02:05:49 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
build.log (deleted)
2022-01-25 16:08 UTC, Fedora Release Engineering
no flags Details
root.log (deleted)
2022-01-25 16:08 UTC, Fedora Release Engineering
no flags Details
state.log (deleted)
2022-01-25 16:08 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2022-01-25 16:08:08 UTC
asterisk failed to build from source in Fedora rawhide/f36

https://koji.fedoraproject.org/koji/taskinfo?taskID=81769765


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
Please fix asterisk at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
asterisk will be orphaned. Before branching of Fedora 37,
asterisk will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 1 Fedora Release Engineering 2022-01-25 16:08:12 UTC
Created attachment 1853668 [details]
build.log

file build.log too big, will only attach last 32768 bytes

Comment 2 Fedora Release Engineering 2022-01-25 16:08:15 UTC
Created attachment 1853669 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2022-01-25 16:08:16 UTC
Created attachment 1853670 [details]
state.log

Comment 4 Petr Pisar 2022-02-07 08:43:04 UTC
The build log is truncated showing no error. Though a log from the latest build in Koji shows a failed configure:

+ ./configure --build=s390x-redhat-linux-gnu --host=s390x-redhat-linux-gnu --program-prefix= --disable-dependency-tracking --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib64 --libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/var/lib --mandir=/usr/share/man --infodir=/usr/share/info --without-imap --with-gsm=/usr --with-ilbc=/usr --with-libedit=yes --with-srtp --with-pjproject-bundled --with-externals-cache=/builddir/build/BUILD/asterisk-18.4.0/cache 'LDFLAGS=-m64 -Wl,--as-needed,--library-path=/usr/lib64 -Wl,-z,relro -Wl,--as-needed  -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1  -Wl,--build-id=sha1 ' NOISY_BUILD=1 CPPFLAGS=-fPIC
[...]
configure: Package configured for: 
configure: OS type  : linux-gnu
configure: Host CPU : s390x
configure: build-cpu:vendor:os: s390x : ibm : linux-gnu :
configure: host-cpu:vendor:os: s390x : ibm : linux-gnu :
+ /usr/bin/make -O -j2 V=1 VERBOSE=1 menuselect-tree NOISY_BUILD=1
Generating input for menuselect ...
+ /usr/bin/perl -n -i -e 'print unless /openr2/i' menuselect-tree
+ echo '### Building with plain voicemail and directory'
### Building with plain voicemail and directory
+ /usr/bin/make -O -j2 V=1 VERBOSE=1 DEBUG= OPTIMIZE= DESTDIR=/builddir/build/BUILDROOT/asterisk-18.4.0-1.fc36.4.s390x ASTVARRUNDIR=/run/asterisk ASTDATADIR=/usr/share/asterisk ASTVARLIBDIR=/usr/share/asterisk ASTDBDIR=/var/spool/asterisk NOISY_BUILD=1
CC="cc" CXX="g++" LD="" AR="" RANLIB="" CFLAGS="" LDFLAGS="" make -C menuselect CONFIGURE_SILENT="--silent" menuselect
make[1]: Entering directory '/builddir/build/BUILD/asterisk-18.4.0/menuselect'
gcc -g -D_GNU_SOURCE -Wall -DHAVE_NCURSES   -c -o strcompat.o strcompat.c
make[1]: Leaving directory '/builddir/build/BUILD/asterisk-18.4.0/menuselect'
make[1]: Entering directory '/builddir/build/BUILD/asterisk-18.4.0/menuselect'
gcc -g -D_GNU_SOURCE -Wall -DHAVE_NCURSES   -c -o menuselect_stub.o menuselect_stub.c
make[1]: Leaving directory '/builddir/build/BUILD/asterisk-18.4.0/menuselect'
make[1]: Entering directory '/builddir/build/BUILD/asterisk-18.4.0/menuselect'
gcc -g -D_GNU_SOURCE -Wall -DHAVE_NCURSES -I/usr/include/libxml2   -c -o menuselect.o menuselect.c
make[1]: Leaving directory '/builddir/build/BUILD/asterisk-18.4.0/menuselect'
make[1]: Entering directory '/builddir/build/BUILD/asterisk-18.4.0/menuselect'
gcc  -o menuselect menuselect.o strcompat.o menuselect_stub.o -lxml2 -lz -llzma -lm
make[1]: Leaving directory '/builddir/build/BUILD/asterisk-18.4.0/menuselect'
menuselect/menuselect --check-deps menuselect.makeopts
member 'LOADABLE_MODULES' in category 'MENUSELECT_CFLAGS' not found, ignoring.
category 'MENUSELECT_OPTS_app_voicemail' not found! Can't mark 'FILE_STORAGE' as disabled.
member 'test_astobj3' in category 'MENUSELECT_TESTS' not found, ignoring.
member 'test_sdp' in category 'MENUSELECT_TESTS' not found, ignoring.
***********************************************************
  The existing menuselect.makeopts file did not specify    
  that 'res_calendar_ews' should not be included.  However, either some  
  dependencies for this module were not found or a         
  conflict exists.                                         
                                                           
  Either run 'make menuselect' or remove the existing      
  menuselect.makeopts file to resolve this issue.          
***********************************************************
***********************************************************
  The existing menuselect.makeopts file did not specify    
  that 'res_snmp' should not be included.  However, either some  
  dependencies for this module were not found or a         
  conflict exists.                                         
                                                           
  Either run 'make menuselect' or remove the existing      
  menuselect.makeopts file to resolve this issue.          
***********************************************************
make: *** [Makefile:364: menuselect.makeopts] Error 255

Comment 5 Petr Pisar 2022-02-07 08:46:24 UTC
*** Bug 2018890 has been marked as a duplicate of this bug. ***

Comment 6 Petr Pisar 2022-02-07 08:49:58 UTC
*** Bug 2032705 has been marked as a duplicate of this bug. ***

Comment 7 Ben Cotton 2022-02-08 20:10:30 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 36 development cycle.
Changing version to 36.

Comment 8 Fedora Release Engineering 2023-01-22 04:22:37 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 37.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2022-03-22).

A week before the mass branching of Fedora 38 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 36 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-38/f-38-key-tasks.html

Comment 9 Mamoru TASAKA 2023-03-10 02:05:49 UTC
This already builds.


Note You need to log in before you can comment on or make changes to this bug.