Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2050952 - useradd causes avc: denied { execute } for pid=57884 comm="chpasswd" name="sss_cache"
Summary: useradd causes avc: denied { execute } for pid=57884 comm="chpasswd" name=...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 35
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
Assignee: Zdenek Pytela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-02-05 08:50 UTC by Martin Pitt
Modified: 2022-04-10 19:52 UTC (History)
9 users (show)

Fixed In Version: selinux-policy-35.16-1.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-04-10 19:52:24 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github fedora-selinux selinux-policy pull 1086 0 None open Allow chage domtrans to sssd 2022-02-16 17:27:25 UTC
Red Hat Bugzilla 2049018 1 medium CLOSED sysadm_passwd_t requires to execute sss_cache 2022-02-18 07:45:08 UTC

Description Martin Pitt 2022-02-05 08:50:16 UTC
Description of problem: In today's cockpit Fedora 35 test image refresh [1], there is a new SELinux rejection:

    avc:  denied  { execute } for  pid=57884 comm="chpasswd" name="sss_cache" dev="vda5" ino=39569 scontext=unconfined_u:unconfined_r:passwd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:sssd_exec_t:s0 tclass=file permissive=0


Full journal at [2]. This seems to happen when running `useradd -G libvirt test_user`.


Version-Release number of selected component (if applicable):

There are a lot of package updates since last week [3], but the relevant ones are:

   selinux-policy (35.11-1.fc35 -> 35.13-1.fc35)
   sssd (2.6.1-1.fc35 -> 2.6.3-1.fc35)

At first sight, running "sss_cache" from chpasswd seems plausible -- but of course, if it isn't, please reassign to sssd.

Thanks!


[1] https://github.com/cockpit-project/bots/pull/2897
[2] https://logs.cockpit-project.org/logs/pull-2897-20220205-074019-32a8cfdc-fedora-35-firefox-cockpit-project-cockpit-machines/TestMachinesLifecycle-testLibvirt-fedora-35-127.0.0.2-2201-FAIL.log.gz
[3] https://logs.cockpit-project.org/logs/image-refresh-2897-20220205-065151/log

Comment 1 Zdenek Pytela 2022-02-07 08:08:16 UTC
Needs to be addressed in selinux-policy, thanks for reporting.

Comment 2 Zdenek Pytela 2022-02-10 15:50:47 UTC
The problem is being worked on:
https://github.com/fedora-selinux/selinux-policy/pull/1046

Comment 3 Martin Pitt 2022-03-16 06:30:35 UTC
This doesn't only affect running "chpasswd", but also "chage":

   avc:  denied  { execute } for  pid=43049 comm="chage" name="sss_cache" dev="vda5" ino=47067 scontext=unconfined_u:unconfined_r:passwd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:sssd_exec_t:s0 tclass=file permissive=0


Simple reproducer:

# useradd alice

# echo alice:foobar | chpasswd
chpasswd: cannot execute /usr/sbin/sss_cache: Permission denied
chpasswd: cannot execute /usr/sbin/sss_cache: Permission denied

# chage -m 1 -M 90 alice
chage: cannot execute /usr/sbin/sss_cache: Permission denied

Comment 4 Fedora Update System 2022-04-06 15:24:39 UTC
FEDORA-2022-9681e66715 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-9681e66715

Comment 5 Fedora Update System 2022-04-06 19:48:42 UTC
FEDORA-2022-9681e66715 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-9681e66715`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-9681e66715

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2022-04-10 19:52:24 UTC
FEDORA-2022-9681e66715 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.