Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2051204 - python-javabridge fails to build with java-17-openjdk
Summary: python-javabridge fails to build with java-17-openjdk
Keywords:
Status: CLOSED DUPLICATE of bug 2104093
Alias: None
Product: Fedora
Classification: Fedora
Component: python-javabridge
Version: 37
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Raphael Groner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2098976 (view as bug list)
Depends On:
Blocks: F38FTBFS F38FailsToInstall PYTHON3.11 2024265 F37FTBFS F37FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2022-02-06 15:42 UTC by jiri vanek
Modified: 2022-09-21 10:09 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-09-21 10:06:13 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 2104093 0 unspecified CLOSED native python-javabridge depends on to be removed i686 java-openjdk packages 2022-10-04 13:45:11 UTC

Description jiri vanek 2022-02-06 15:42:48 UTC
python-javabridge fails to build with java-17-openjdk as sytem JDK. See https://fedoraproject.org/wiki/Changes/Java17 .
See especially part about known failures: https://fedoraproject.org/wiki/Changes/Java17#common_issues_packagers_can_face_and_gathered_solutions

For the build logs, see: https://koji.fedoraproject.org/koji/taskinfo?taskID=82434021
https://kojipkgs.fedoraproject.org/work/tasks/4051/82434051/mock_output.log
https://kojipkgs.fedoraproject.org/work/tasks/4051/82434051/hw_info.log
https://kojipkgs.fedoraproject.org/work/tasks/4051/82434051/state.log
https://kojipkgs.fedoraproject.org/work/tasks/4051/82434051/build.log
https://kojipkgs.fedoraproject.org/work/tasks/4051/82434051/root.log
We run the rebuild in side tag f36-java17, but as fail ratio was small, we expect this side tag to be merged into rawhide 7 or 8 of February 2022.
To reproduce before this date simply: fedpkg clone python-javabridge; cd python-javabridge;  fedpkg build --target f36-java17; #The target is crucial.
After this date the usual fedpkg build in f36 and up should do.

We run two reruns your package failed both.

We had also run the mass rebuilds in copr since November. We keep all encountered failures. See them here: https://copr.fedorainfracloud.org/coprs/jvanek/java17//package/python-javabridge
You may find interesting additional informations here. Also we were spamming maintainers regualrly, check you spam folder.
              

We had tried aprox 500 packages, and aprox 65 had failed, so the java-17-openjdk will be system JDK in f36, and you should fix your package if you want to keep it alive. Usually the fix is simple, and best is to update the package to latest upstream version.
There will be usual mass rebuild once f36 branches. You may got another FTBFS bug.
Let us know here if you have any questions, here in bug, or at java-devel.org .

We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side if needed.

Comment 1 jiri vanek 2022-02-06 16:10:05 UTC
It seems like test failures. TBH, I was not clever from log.
I noticed: ..Exception in thread "Thread-0" java.lang.NoSuchMethodError: Ljava/lang/String;.copyValueOf([C)Ljava/lang/String;

but there are others, sometimes it is output of test, sometimes real issue

Comment 2 Raphael Groner 2022-02-07 17:10:39 UTC
Thanks for analysis. Those failing tests obviously seem to not be written for java 17. We could disable execution of those and file as report to upstream.

See also rz2048091 due to missing version for the python part.

Comment 3 Ben Cotton 2022-02-08 20:08:38 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 36 development cycle.
Changing version to 36.

Comment 4 Miro Hrončok 2022-06-20 10:18:15 UTC
*** Bug 2098976 has been marked as a duplicate of this bug. ***

Comment 5 Miro Hrončok 2022-08-25 09:43:52 UTC
We are past Fedora 37 Beta Freeze and this package does not even install. What is the plan wrt this package? Can it please be removed from the distribution until this is solved?

Comment 6 Raphael Groner 2022-09-10 13:05:37 UTC
Is your comment about bug 2098976 marked as duplicate? In guess about missing numpy dependency with python 3.10 as stated there.

Comment 7 Miro Hrončok 2022-09-10 14:58:14 UTC
I have no idea what do you mean, sorry.

Comment 8 Raphael Groner 2022-09-12 22:23:59 UTC
Well, as numpy as a dependency seems to successfully rebuild now with python 3.11 please retry to rebuild also python-javabridge. No idea if there's still an issue with java 17 as well, next rebuild should tell.

Comment 10 Miro Hrončok 2022-09-13 09:14:58 UTC
Still fails.

Comment 11 Raphael Groner 2022-09-14 22:52:38 UTC
> BuildError: error building package (arch i686), mock exited with status 30; see root.log for more information

See bug #2104093. No need for freeze exception or other urgency -- please feel free to exclude/retire this package, anyways upstream seems stalled somehow and till now there were never any official release.

Comment 12 Raphael Groner 2022-09-21 10:06:13 UTC
As comment #9 clearly indicates, this is now java issue as duplication of bug #2104093. Please feel free to reopen if you think there's still a python issue, too.

*** This bug has been marked as a duplicate of bug 2104093 ***

Comment 13 Raphael Groner 2022-09-21 10:08:36 UTC
(In reply to Ben Cotton from comment #3)
> This bug appears to have been reported against 'rawhide' during the Fedora
> 36 development cycle.
> Changing version to 36.

2022-02-08 21:08:38 CET 

This is due to change in Fedora 37.


Note You need to log in before you can comment on or make changes to this bug.