Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2053627 - Copy and paste do not work
Summary: Copy and paste do not work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus
Version: 36
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F36FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2022-02-11 16:19 UTC by Lukas Ruzicka
Modified: 2022-03-15 15:56 UTC (History)
12 users (show)

Fixed In Version: nautilus-42~beta-1.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-03-15 15:56:17 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Lukas Ruzicka 2022-02-11 16:19:22 UTC
Affected version

    Nightly flatpak: Yes
    Other: Fedora 36, nautilus-42~alpha-3

Steps to reproduce

    Open Nautilus
    Click on a listed file.
    Press Ctrl-C to copy the file (a blue rectangle appears around the name)
    Go to another directory and press Ctrl-V to paste the file.

Alternatively:

    Open Nautilus
    Click on a listed file.
    Click the right button to arrive into context menu and select Copy to copy the file (a blue rectangle appears around the name)
    Go to another directory and click right button and select Paste.

Current behavior

The above described reproducer does not copy a file - nothing happens in either way. The same holds true for Ctrl-X to cut and paste the file.
Expected behavior

Copying and pasting should be available.

This has been also reported upstream.

Comment 1 Fedora Blocker Bugs Application 2022-02-11 16:20:32 UTC
Proposed as a Blocker for 36-final by Fedora user lruzicka using the blocker tracking app because:

 Proposing as a blocker because it violates the basic functionality criterion.

Comment 2 Ondrej Holy 2022-02-14 06:49:13 UTC
This and several other regressions are going to be fixed in beta...

Comment 3 Lukas Ruzicka 2022-02-14 18:10:29 UTC
This is part of a transition to GTK 4, clipboard is being tracked here:

https://gitlab.gnome.org/GNOME/nautilus/-/merge_requests/759

The original upstream report is here:

https://gitlab.gnome.org/GNOME/nautilus/-/issues/2149

Comment 4 Geoffrey Marr 2022-02-14 19:31:01 UTC
Discussed during the 2022-02-14 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedBlocker (Final)" was made as it violates the following criterion:

"All applications that can be launched using the standard graphical mechanism after a default installation of Fedora Workstation on the x86_64 architecture must start successfully and withstand a basic functionality test".

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2022-02-14/f36-blocker-review.2022-02-14-17.01.txt

Comment 5 Ondrej Holy 2022-02-25 07:24:37 UTC
https://bodhi.fedoraproject.org/updates/FEDORA-2022-62ea707376 should fix this.

Comment 6 Lukas Ruzicka 2022-02-25 11:58:37 UTC
I can confirm that the above mentioned version solves the issue and that copy and paste works inside of Nautilus.

Comment 7 Adam Williamson 2022-03-15 15:56:17 UTC
In that case we can close this, then.


Note You need to log in before you can comment on or make changes to this bug.