Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2053866 - Build ffmpeg in EPEL 9
Summary: Build ffmpeg in EPEL 9
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: ffmpeg
Version: epel9
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Neal Gompa
QA Contact:
URL:
Whiteboard:
: 2099878 (view as bug list)
Depends On: 2031212 2035373 2036549 2056016 2056017 2059006 2076578 2100646 2100651 2100655 2118467 2124924 2143289 2143561
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-02-12 19:20 UTC by Neal Gompa
Modified: 2022-11-21 01:13 UTC (History)
19 users (show)

Fixed In Version: ffmpeg-5.1.2-2.el9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-11-21 01:13:59 UTC
Type: Task
Embargoed:


Attachments (Terms of Use)
ffmpeg missing EPEL9 dependencies (deleted)
2022-03-02 00:13 UTC, Michel Lind
no flags Details

Description Neal Gompa 2022-02-12 19:20:48 UTC
This bug tracks the effort to bring ffmpeg to EPEL 9.

Comment 1 Neal Gompa 2022-02-12 19:22:33 UTC
Current dependency failures from "fedpkg --release epel9 mockbuild":

No matching package to install: 'fdk-aac-free-devel'
No matching package to install: 'game-music-emu-devel'
No matching package to install: 'glslang-devel'
No matching package to install: 'libcrystalhd-devel'
No matching package to install: 'pkgconfig(caca)'
No matching package to install: 'pkgconfig(codec2)'
No matching package to install: 'pkgconfig(enca)'
No matching package to install: 'pkgconfig(frei0r)'
No matching package to install: 'pkgconfig(ilbc)'
No matching package to install: 'pkgconfig(libass)'
No matching package to install: 'pkgconfig(libdc1394-2)'
No matching package to install: 'pkgconfig(libiec61883)'
No matching package to install: 'pkgconfig(libomxil-bellagio)'
No matching package to install: 'pkgconfig(libzmq)'
No matching package to install: 'pkgconfig(lilv-0)'
No matching package to install: 'pkgconfig(netcdf)'
No matching package to install: 'pkgconfig(opencv4)'
No matching package to install: 'pkgconfig(rav1e)'
No matching package to install: 'pkgconfig(schroedinger-1.0)'
No matching package to install: 'pkgconfig(soxr)'
No matching package to install: 'pkgconfig(srt)'
No matching package to install: 'pkgconfig(vapoursynth)'
No matching package to install: 'pkgconfig(zimg)'

Comment 2 Neal Gompa 2022-02-13 14:44:30 UTC
Also add one more...

No matching package to install: 'AMF-devel'

Comment 3 Neal Gompa 2022-02-27 18:18:12 UTC
(In reply to Neal Gompa from comment #2)
> Also add one more...
> 
> No matching package to install: 'AMF-devel'

This is now in EPEL 9, so we don't need to worry about it.

Comment 4 Neal Gompa 2022-02-27 18:18:51 UTC
For AArch64, here's what's missing:

No matching package to install: 'fdk-aac-free-devel'
No matching package to install: 'game-music-emu-devel'
No matching package to install: 'glslang-devel'
No matching package to install: 'libcrystalhd-devel'
No matching package to install: 'pkgconfig(caca)'
No matching package to install: 'pkgconfig(codec2)'
No matching package to install: 'pkgconfig(enca)'
No matching package to install: 'pkgconfig(frei0r)'
No matching package to install: 'pkgconfig(ilbc)'
No matching package to install: 'pkgconfig(libass)'
No matching package to install: 'pkgconfig(libdc1394-2)'
No matching package to install: 'pkgconfig(libiec61883)'
No matching package to install: 'pkgconfig(libomxil-bellagio)'
No matching package to install: 'pkgconfig(libva)'
No matching package to install: 'pkgconfig(libva-drm)'
No matching package to install: 'pkgconfig(libva-x11)'
No matching package to install: 'pkgconfig(libzmq)'
No matching package to install: 'pkgconfig(lilv-0)'
No matching package to install: 'pkgconfig(netcdf)'
No matching package to install: 'pkgconfig(opencv4)'
No matching package to install: 'pkgconfig(rav1e)'
No matching package to install: 'pkgconfig(schroedinger-1.0)'
No matching package to install: 'pkgconfig(vapoursynth)'
No matching package to install: 'pkgconfig(zimg)'

Comment 5 Neal Gompa 2022-02-27 18:24:17 UTC
For POWER, here's what's missing:

No matching package to install: 'fdk-aac-free-devel'
No matching package to install: 'game-music-emu-devel'
No matching package to install: 'glslang-devel'
No matching package to install: 'libcrystalhd-devel'
No matching package to install: 'pkgconfig(caca)'
No matching package to install: 'pkgconfig(codec2)'
No matching package to install: 'pkgconfig(enca)'
No matching package to install: 'pkgconfig(frei0r)'
No matching package to install: 'pkgconfig(ilbc)'
No matching package to install: 'pkgconfig(libass)'
No matching package to install: 'pkgconfig(libdc1394-2)'
No matching package to install: 'pkgconfig(libiec61883)'
No matching package to install: 'pkgconfig(libomxil-bellagio)'
No matching package to install: 'pkgconfig(libva)'
No matching package to install: 'pkgconfig(libva-drm)'
No matching package to install: 'pkgconfig(libva-x11)'
No matching package to install: 'pkgconfig(libzmq)'
No matching package to install: 'pkgconfig(lilv-0)'
No matching package to install: 'pkgconfig(netcdf)'
No matching package to install: 'pkgconfig(opencv4)'
No matching package to install: 'pkgconfig(rav1e)'
No matching package to install: 'pkgconfig(schroedinger-1.0)'
No matching package to install: 'pkgconfig(vapoursynth)'
No matching package to install: 'pkgconfig(zimg)'

Comment 6 Neal Gompa 2022-02-27 18:29:48 UTC
For IBM Z, here's what's missing:

No matching package to install: 'fdk-aac-free-devel'
No matching package to install: 'game-music-emu-devel'
No matching package to install: 'glslang-devel'
No matching package to install: 'pkgconfig(caca)'
No matching package to install: 'pkgconfig(codec2)'
No matching package to install: 'pkgconfig(enca)'
No matching package to install: 'pkgconfig(frei0r)'
No matching package to install: 'pkgconfig(ilbc)'
No matching package to install: 'pkgconfig(libass)'
No matching package to install: 'pkgconfig(libomxil-bellagio)'
No matching package to install: 'pkgconfig(libva)'
No matching package to install: 'pkgconfig(libva-drm)'
No matching package to install: 'pkgconfig(libva-x11)'
No matching package to install: 'pkgconfig(libzmq)'
No matching package to install: 'pkgconfig(lilv-0)'
No matching package to install: 'pkgconfig(netcdf)'
No matching package to install: 'pkgconfig(opencv4)'
No matching package to install: 'pkgconfig(rav1e)'
No matching package to install: 'pkgconfig(schroedinger-1.0)'
No matching package to install: 'pkgconfig(vapoursynth)'
No matching package to install: 'pkgconfig(zimg)'

Comment 7 Michel Lind 2022-03-02 00:13:11 UTC
Created attachment 1863765 [details]
ffmpeg missing EPEL9 dependencies

missing dependency report from ebranch

Comment 8 Michel Lind 2022-03-02 00:14:10 UTC
I've attached the list of missing dependencies (for x86_64) from ebranch. Will work on it to be able to file branching bugs later.

Comment 9 Gary Buhrmaster 2022-03-06 15:43:54 UTC
I have added a few (libass, libiec61883) of the existing branching bugs to the depends on.

Comment 10 Neal Gompa 2022-04-19 12:02:00 UTC
Added new libshaderc-devel CRB request now that I'm using that for Vulkan support.

Comment 11 Neal Gompa 2022-06-21 21:24:15 UTC
*** Bug 2099878 has been marked as a duplicate of this bug. ***

Comment 12 Robert Scheck 2022-06-23 12:04:31 UTC
Do you see a chance for building the in CRB missing packages for the time being as <package>-epel?

Comment 13 Neal Gompa 2022-06-23 12:09:32 UTC
(In reply to Robert Scheck from comment #12)
> Do you see a chance for building the in CRB missing packages for the time
> being as <package>-epel?

There's not a really good reason to do that yet, since we still need all these other branched into EPEL from Fedora first. But those wind up being the only thing left, sure. The devel packages are on track to be available in RHEL 9.1 and will be part of the next CentOS Stream 9 compose.

So I think if you could help with branch requests for the other build dependencies, that would tremendously help get this into EPEL 9.

Comment 14 Nicolas Chauvet (kwizart) 2022-06-24 08:33:14 UTC
This version of ffmpeg has a tremendous number of deprecated libraries enabled, please refrain from enabling any library beyond what's purposely enabled in rpmfusion's ffmpeg !

Comment 15 Neal Gompa 2022-07-13 13:07:54 UTC
(In reply to Nicolas Chauvet (kwizart) from comment #14)
> This version of ffmpeg has a tremendous number of deprecated libraries
> enabled, please refrain from enabling any library beyond what's purposely
> enabled in rpmfusion's ffmpeg !

I will enable whatever makes sense. Some of the libraries are for hardware that have no enablement in the RHEL kernel, so I'll drop those, but I will not purposely remove enablement if the package is available unless there's a really good reason not to enable it.

Comment 16 Neal Gompa 2022-09-04 14:00:38 UTC
As of now, these are the only remaining missing dependencies:

No matching package to install: 'pkgconfig(frei0r)'
No matching package to install: 'pkgconfig(lilv-0)'
No matching package to install: 'pkgconfig(opencv4)'
No matching package to install: 'pkgconfig(rav1e)'

Comment 17 Neal Gompa 2022-11-16 14:53:15 UTC
I hit one surprise today when trying to build ffmpeg in EPEL 9: jpegxl is too old. I've filed bug 2143289 to get that fixed.

Comment 18 Fedora Update System 2022-11-20 02:16:19 UTC
FEDORA-EPEL-2022-9b32bbe1e2 has been submitted as an update to Fedora EPEL 9. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-9b32bbe1e2

Comment 19 Fedora Update System 2022-11-21 01:13:59 UTC
FEDORA-EPEL-2022-9b32bbe1e2 has been pushed to the Fedora EPEL 9 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.