Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2055346 - Fedora IoT 36 /etc/os-release shows incomplete VERSION and PRETTY_NAME
Summary: Fedora IoT 36 /etc/os-release shows incomplete VERSION and PRETTY_NAME
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: IoT
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact:
URL:
Whiteboard: RejectedBlocker
Depends On:
Blocks: IoT
TreeView+ depends on / blocked
 
Reported: 2022-02-16 18:12 UTC by Geoffrey Marr
Modified: 2022-03-02 17:26 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-03-02 17:26:42 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Geoffrey Marr 2022-02-16 18:12:39 UTC
Description of problem:
As found in OpenQA [0][1], /etc/os-release VERSION and PRETTY_NAME do not include the date after "36".

[0] https://openqa.fedoraproject.org/tests/1129446#step/os_release/32
[1] https://openqa.fedoraproject.org/tests/1132002#step/os_release/32


Version-Release number of selected component (if applicable):
Fedora-IoT-36-20220214.0
Fedora-IoT-36-20220216.0

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora-IoT-36-20220214.0 or Fedora-IoT-36-20220216.0, any arch.
2. 'cat /etc/os-release'
3. View VERSION and PRETTY_NAME

Comment 1 Fedora Blocker Bugs Application 2022-02-16 20:36:46 UTC
Proposed as a Blocker for 36-final by Fedora user coremodule using the blocker tracking app because:

 Proposing as a potential violation of the following F36 Final criterion [0]:

"For each Edition... the relevant fields in /etc/os-release must include the correct Edition name."

[0] https://fedoraproject.org/wiki/Fedora_36_Final_Release_Criteria#Self-identification

Comment 2 Adam Williamson 2022-02-18 20:28:43 UTC
Yeah, I wasn't actually sure whether this was an intentional change or not, but I forgot to file it - thanks for doing so, Geoff.

Comment 3 Geoffrey Marr 2022-02-21 16:36:42 UTC
The decision to classify this bug as a "RejectedBlocker (Final)" was made based off votes here: [0]

https://pagure.io/fedora-qa/blocker-review/issue/615

Comment 4 Luca BRUNO 2022-02-22 09:06:03 UTC
Moving to fedora-iot, I think it's the treefile at https://pagure.io/fedora-iot/ostree/blob/f36/f/fedora-iot-base.json which has not been updated for F36.

Comment 5 Peter Robinson 2022-02-23 20:24:11 UTC
So I think this should be fixed with 36.20220223.0 when it's finished shortly can you verify.

Comment 6 Geoffrey Marr 2022-03-02 17:26:42 UTC
Looks good to me, checked on 20220302.0 and looks as it should. Thanks pbrobinson.


Note You need to log in before you can comment on or make changes to this bug.