Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2060868 - Cannot configure WPA2 Enterprise WiFi SSID
Summary: Cannot configure WPA2 Enterprise WiFi SSID
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libnma
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker AcceptedFreezeExcepti...
: 2062507 (view as bug list)
Depends On:
Blocks: F36BetaFreezeException F36FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2022-03-04 12:16 UTC by Alessio
Modified: 2022-03-25 07:42 UTC (History)
12 users (show)

Fixed In Version: libnma-1.8.34-2.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-03-24 19:33:52 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME libnma issues 10 0 None None None 2022-03-12 01:03:57 UTC
GNOME Gitlab GNOME libnma merge_requests 26 0 None None None 2022-03-12 01:03:57 UTC

Description Alessio 2022-03-04 12:16:35 UTC
Reported upstream

https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues/1688

gnome-control-center-42~beta-6.fc36.x86_64

In GNOME Control Center, I see the list of WiFi SSID.

If I try to connect to a WPA2 SSID the spoke requesting the password appears, and all is fine. Also connecting to an open network it works.

Instead, if I try to select an SSID that is a WPA2 Enterprise one (validated with 802.1X), nothing happens, and journalctl reports a bunch of errors

i.e.
mar 02 15:20:45 gnome-control-c[28837]: Couldn't load builder resource: <resource>/org/gnome/libnma/wifi.ui:3:1233 Unhandled tag: <packing>

Comment 1 Fedora Blocker Bugs Application 2022-03-04 12:22:36 UTC
Proposed as a Blocker for 36-final by Fedora user alciregi using the blocker tracking app because:

 "All applications that can be launched using the standard graphical mechanism after a default installation of Fedora Workstation on the x86_64 architecture must start successfully and withstand a basic functionality test."

Home users could not be affected by this bug, but office and enterprise users could be unable to configure the wifi using the graphical interface.

Comment 2 David Koppelman 2022-03-04 18:11:56 UTC
I too am having a problem connecting via wpa2 Enterprise (otherwise
wifi works normally), though it appears to be lower level (I'm using
KDE). This is on a system that had been upgraded from f35 to f36 on
2022-02-19 13:27. I encountered the wpa problem after a 2022-02-23
10:44 upgrade, and I believe the wpa connection was working fine before
then.

The relevant log entries are:

    Feb 23 10:58:47 dmk-laptop-21 wpa_supplicant[1404]: wlp147s0: CTRL-EVENT-EAP-METHOD EAP vendor 0 method 25 (PEAP) selected
    Feb 23 10:58:47 dmk-laptop-21 wpa_supplicant[1404]: SSL: SSL3 alert: write (local SSL3 detected an error):fatal:handshake failure
    Feb 23 10:58:47 dmk-laptop-21 wpa_supplicant[1404]: OpenSSL: openssl_handshake - SSL_connect error:0A000152:SSL routines::unsafe legacy renegotiation disabled
    Feb 23 10:58:48 dmk-laptop-21 wpa_supplicant[1404]: wlp147s0: CTRL-EVENT-EAP-FAILURE EAP authentication failed

The same issue has been reported here:
https://ask.fedoraproject.org/t/cannot-connect-to-wpa2-enterprise-university-wifi-on-fedora-36/20288

Does the OP see similar log entries, or are these two different problems?

Comment 3 Alessio 2022-03-04 18:58:04 UTC
I think they are different problems.
In this case the point is not that I can't connect. The point is that I can't configure the WiFi since no configuration spokes appear in GNOME Control Center.

Comment 4 Adam Williamson 2022-03-04 22:30:49 UTC
This is likely similar to https://bugzilla.redhat.com/show_bug.cgi?id=2057719 : gnome-control-center is trying to use a UI definition which has not been ported to GTK4. From the errors, the problematic UI file is https://gitlab.gnome.org/GNOME/libnma/-/blob/main/src/wifi.ui from libnma; that file has not been touched for two years.

I don't know how this is supposed to be handled for things that build both GTK3 and GTK4 versions (as libnma does), but that seems to be the problem anyway.

Comment 5 Adam Williamson 2022-03-04 22:33:37 UTC
I actually think it's worth considering this as a Beta blocker under the networking criteria we're currently discussing on test@ (and this also suggests to me we should cover specific wireless security requirements in those criteria). We may ultimately decide against it, but let's have the conversation at least.

Comment 6 Geoffrey Marr 2022-03-07 22:13:49 UTC
Discussed during the 2022-03-07 blocker review meeting: [0]

The decision to classify this bug as a "RejectedBlocker (Beta)", "AcceptedBlocker (Final)", and an "AcceptedFreezeException (Beta)" was made as this does not violate the current Beta criteria, and there wasn't enough support for applying the proposed networking criteria that do cover it to F36 Beta, but it is bad enough to be an FE. For Final, it violates the default app functionality and panel criteria.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2022-03-07/f36-blocker-review.2022-03-07-17.01.txt

Comment 7 Adam Williamson 2022-03-12 01:03:12 UTC
*** Bug 2062507 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2022-03-18 23:51:34 UTC
FEDORA-2022-5b4c506e72 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-5b4c506e72

Comment 9 Fedora Update System 2022-03-19 19:27:33 UTC
FEDORA-2022-5b4c506e72 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-5b4c506e72`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-5b4c506e72

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Brandon Nielsen 2022-03-20 16:26:28 UTC
Can someone test the PKCS 11 / Smart Card flows? Those were the problematic ui files and I'm not sure my "just deleting the packing because I can't figure anything else out" solution resulted in a usable UI. I can't come up with a way to view the UIs with what I have on hand...

Comment 11 Lubomir Rintel 2022-03-21 13:49:23 UTC
(In reply to Brandon Nielsen from comment #10)
> Can someone test the PKCS 11 / Smart Card flows? Those were the problematic
> ui files and I'm not sure my "just deleting the packing because I can't
> figure anything else out" solution resulted in a usable UI. I can't come up
> with a way to view the UIs with what I have on hand...

No. There's no Gtk4 version of GCR.

Comment 12 Fedora Update System 2022-03-24 19:33:52 UTC
FEDORA-2022-5b4c506e72 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.