Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2060899 - python-asyncmy does not support 32-bit platforms
Summary: python-asyncmy does not support 32-bit platforms
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: python-asyncmy
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ben Beasley
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FE-ExcludeArch-x86, F-ExcludeArch-x86
TreeView+ depends on / blocked
 
Reported: 2022-03-04 13:25 UTC by Ben Beasley
Modified: 2022-05-02 00:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-05-02 00:20:33 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Ben Beasley 2022-03-04 13:25:01 UTC
Description of problem:

When python-asyncmy is built on 32-bit platforms, multiple test failures and errors occur.

Version-Release number of selected component (if applicable): any


How reproducible:


Steps to Reproduce:
1. Remove the ExcludeArch in the spec file.
2. Build on i686 or armhfp.

Actual results:

Success (tests pass).

Expected results:

Failure (many tests fail or error).

Additional info:

Upstream bug with details about test failures:

https://github.com/long2ice/asyncmy/issues/34

Upstream doesn’t seem to be interested in supporting 32-bit systems.

Comment 1 Ben Beasley 2022-03-04 13:25:56 UTC
Unblocking F-ExcludeArch-ARM since 32-bit ARM is not present in Rawhide, and aarch64 is fine.


Note You need to log in before you can comment on or make changes to this bug.