Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2062507 - "Connect to hidden network..." menu does not appear
Summary: "Connect to hidden network..." menu does not appear
Keywords:
Status: CLOSED DUPLICATE of bug 2060868
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-control-center
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: GNOME SIG Unassigned
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F36FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2022-03-10 01:57 UTC by Brandon Nielsen
Modified: 2022-03-12 01:03 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-03-12 01:03:12 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
Log showing errors (deleted)
2022-03-10 01:57 UTC, Brandon Nielsen
no flags Details
Start of a patch adding gtk4 support (deleted)
2022-03-10 03:18 UTC, Brandon Nielsen
no flags Details | Diff

Description Brandon Nielsen 2022-03-10 01:57:52 UTC
Created attachment 1865036 [details]
Log showing errors

Description of problem:

Selecting "Connect to hidden network..." from the Wi-Fi spoke does not result in a menu for connecting to a hidden network.


Version-Release number of selected component (if applicable):

gnome-control-center-42~beta-6.fc36.x86_64


How reproducible:

Every time.


Steps to Reproduce:
1. Open gnome-control-center
2. Click on Wi-Fi in the panel on the right
3. Click the overflow "..." menu in the settings bar
4. Select "Connect to hidden network..."


Actual results:

No way to connect to a hidden network appears.


Expected results:

Some way to connect to a hidden network.


Additional info:

Based on the "Couldn't load builder resource: <resource>/org/gnome/libnma/wifi.ui:3:1233 Unhandled tag: <packing>" this is another bug in the same vein as 2060868[0], 2057719[1].

[0] - https://bugzilla.redhat.com/show_bug.cgi?id=2060868
[1] - https://bugzilla.redhat.com/show_bug.cgi?id=2057719

Comment 1 Fedora Blocker Bugs Application 2022-03-10 02:01:18 UTC
Proposed as a Blocker for 36-final by Fedora user nielsenb using the blocker tracking app because:

 Same as #643, #630. This is default functionality of a default application "For all release-blocking desktop / arch combinations, the following applications must start successfully and withstand a basic functionality test".

Comment 2 Brandon Nielsen 2022-03-10 02:05:30 UTC
This should probably be reassigned to the libnma component.

Comment 3 Brandon Nielsen 2022-03-10 02:10:54 UTC
Reported upstream: https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues/1700

Comment 4 Brandon Nielsen 2022-03-10 03:18:47 UTC
Created attachment 1865042 [details]
Start of a patch adding gtk4 support

I started migrating .ui files using 'gtk4-builder-tool simplify --3to4'

This seems to at least be enough to make the hidden networks menu appear with minimum warnings. It might also fix the WPA2 enterprise menu. I have not finished migrating all files. More testing needs to be done, as well as work on how to actually integrate it into the libnma specfile.

'<packing>' seems to be the major hangup: https://docs.gtk.org/gtk4/migrating-3to4.html#adapt-to-gtkcontainer-removal

Comment 5 Adam Williamson 2022-03-12 01:03:12 UTC

*** This bug has been marked as a duplicate of bug 2060868 ***


Note You need to log in before you can comment on or make changes to this bug.