Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2063381 - gnome-shell crash, clutter-actor.c:1275:clutter_actor_set_mapped: assertion failed: (!CLUTTER_ACTOR_IS_MAPPED (self))
Summary: gnome-shell crash, clutter-actor.c:1275:clutter_actor_set_mapped: assertion f...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException AcceptedBlocker
: 2061998 2063113 (view as bug list)
Depends On:
Blocks: F36BetaFreezeException F36FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2022-03-12 00:58 UTC by Chris Murphy
Modified: 2022-03-24 00:56 UTC (History)
12 users (show)

Fixed In Version: mutter-42~rc-5.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-03-24 00:56:22 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
coredumpctl gdb, thread apply all bt full (deleted)
2022-03-12 01:01 UTC, Chris Murphy
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME gnome-shell merge_requests 2231 0 None None None 2022-03-14 17:11:00 UTC
GNOME Gitlab GNOME mutter merge_requests 2299 0 None None None 2022-03-14 17:14:00 UTC

Description Chris Murphy 2022-03-12 00:58:36 UTC
Description of problem:

gnome-shell crashed soon after trying to open a PDF with Nautilus. And once while just navigating around in gnucash. Data loss due to it taking out applications with unsaved data. Both crashes with rc-1, beta didn't crash in ~two weeks.

Version-Release number of selected component (if applicable):
gnome-shell-42~rc-2.fc36.x86_64
mutter-42~rc-4.fc36.x86_64
clutter-1.26.4-8.fc36.x86_64

How reproducible:
transient, not reproducible on command
2x


Steps to Reproduce:
1.
2.
3.

Actual results:

Initially the mouse arrow just vanishes and nothing is responsive, then black screen.


Expected results:

Should not crash.


Additional info:

Looks like it's clutter related?

Mar 11 17:42:28 fovo.local systemd[1574]: Started app-glib-org.gnome.Evince-10277.scope - Application launched by org.gnome.Nautilus.
Mar 11 17:42:31 fovo.local gnome-shell[1725]: Object 0x7f377c4a9130 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:42:31 fovo.local gnome-shell[1725]: Object 0x7f377c4ab020 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:42:31 fovo.local gnome-shell[1725]: Object 0x7f377c4ad520 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:42:31 fovo.local gnome-shell[1725]: Object 0x7f377c4ad520 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:42:33 fovo.local systemd[1574]: Started app-glib-org.gnome.Evince-10292.scope - Application launched by org.gnome.Nautilus.
Mar 11 17:42:53 fovo.local gnome-shell[1725]: Object 0x7f377c4ada60 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:42:53 fovo.local gnome-shell[1725]: Object 0x7f377c4a9130 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:42:53 fovo.local gnome-shell[1725]: Object 0x7f377c4a32d0 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:42:53 fovo.local gnome-shell[1725]: Object 0x7f377c4abda0 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:42:53 fovo.local gnome-shell[1725]: Object 0x7f377c4a8ed0 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:42:53 fovo.local gnome-shell[1725]: Object 0x7f377c49b740 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:42:53 fovo.local gnome-shell[1725]: Object 0x7f377c49b6d0 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:42:53 fovo.local gnome-shell[1725]: Object 0x5613383dc290 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:42:53 fovo.local gnome-shell[1725]: Object 0x7f377c046370 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:42:53 fovo.local gnome-shell[1725]: Object 0x7f377c046370 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:42:53 fovo.local gnome-shell[1725]: Object 0x7f377c4a8660 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:42:53 fovo.local gnome-shell[1725]: Object 0x7f377c4a7750 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:42:53 fovo.local gnome-shell[1725]: Object 0x7f377c4954d0 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:42:53 fovo.local gnome-shell[1725]: Object 0x7f377c49b6d0 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:42:53 fovo.local gnome-shell[1725]: Object 0x7f377c497af0 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:03 fovo.local gnome-shell[1725]: Object 0x7f377c0469a0 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:13 fovo.local gnome-shell[1725]: Object 0x7f377c046d40 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:13 fovo.local gnome-shell[1725]: Object 0x7f377c4ab250 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:13 fovo.local gnome-shell[1725]: Object 0x7f377c497af0 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:13 fovo.local gnome-shell[1725]: Object 0x56133a855170 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:13 fovo.local gnome-shell[1725]: Object 0x7f377c0488a0 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:33 fovo.local gnome-shell[1725]: Object 0x7f377c046e20 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:33 fovo.local gnome-shell[1725]: Object 0x7f377c046e20 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:33 fovo.local gnome-shell[1725]: Object 0x7f377c046a10 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:33 fovo.local gnome-shell[1725]: Object 0x7f377c046a10 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:33 fovo.local gnome-shell[1725]: Object 0x7f377c046b60 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:33 fovo.local gnome-shell[1725]: Object 0x7f377c046cd0 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:33 fovo.local gnome-shell[1725]: Object 0x7f377c046370 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:33 fovo.local gnome-shell[1725]: Object 0x7f377c049180 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:33 fovo.local gnome-shell[1725]: Object 0x7f377c049110 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:33 fovo.local gnome-shell[1725]: Object 0x7f377c04bee0 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:33 fovo.local gnome-shell[1725]: Object 0x7f377c049030 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:33 fovo.local gnome-shell[1725]: Object 0x7f377c04bc40 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:33 fovo.local gnome-shell[1725]: Object 0x7f377c049030 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:33 fovo.local gnome-shell[1725]: Object 0x7f377c049030 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:33 fovo.local gnome-shell[1725]: Object 0x7f377c49d210 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:33 fovo.local gnome-shell[1725]: Object 0x7f377c046a80 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:33 fovo.local gnome-shell[1725]: Object 0x7f377c046300 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:33 fovo.local gnome-shell[1725]: Object 0x7f377c049110 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:33 fovo.local gnome-shell[1725]: Object 0x7f377c49d280 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:33 fovo.local gnome-shell[1725]: Object 0x7f377c4ab100 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:33 fovo.local gnome-shell[1725]: Object 0x7f377c4a8d10 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:33 fovo.local gnome-shell[1725]: Object 0x7f377c049180 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:33 fovo.local gnome-shell[1725]: Object 0x7f377c048490 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:33 fovo.local gnome-shell[1725]: Object 0x7f377c4acda0 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:33 fovo.local gnome-shell[1725]: Object 0x7f377c046b60 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:33 fovo.local gnome-shell[1725]: Object 0x7f377c0492d0 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:33 fovo.local gnome-shell[1725]: Object 0x7f377c49d360 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:33 fovo.local gnome-shell[1725]: Object 0x7f377c046cd0 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:33 fovo.local gnome-shell[1725]: Object 0x7f377c046cd0 of type IBusText has been finalized while it was still owned by gjs, this is due to invalid memory management.
Mar 11 17:43:34 fovo.local rtkit-daemon[829]: Supervising 7 threads of 4 processes of 1 users.
Mar 11 17:43:34 fovo.local rtkit-daemon[829]: Supervising 7 threads of 4 processes of 1 users.
Mar 11 17:43:34 fovo.local rtkit-daemon[829]: Supervising 7 threads of 4 processes of 1 users.
Mar 11 17:43:34 fovo.local rtkit-daemon[829]: Supervising 7 threads of 4 processes of 1 users.
Mar 11 17:43:36 fovo.local gnome-shell[1725]: **
Mar 11 17:43:36 fovo.local gnome-shell[1725]: Clutter:ERROR:../clutter/clutter/clutter-actor.c:1275:clutter_actor_set_mapped: assertion failed: (!CLUTTER_ACTOR_IS_MAPPED (self))
Mar 11 17:43:36 fovo.local gnome-shell[1725]: Bail out! Clutter:ERROR:../clutter/clutter/clutter-actor.c:1275:clutter_actor_set_mapped: assertion failed: (!CLUTTER_ACTOR_IS_MAPPED (self))
Mar 11 17:43:36 fovo.local gnome-shell[1725]: == Stack trace for context 0x5613366aa620 ==
Mar 11 17:43:36 fovo.local gnome-shell[1725]: #0   7ffca21b5e30 b   resource:///org/gnome/shell/ui/windowPreview.js:369 (1de2200081a0 @ 12)
Mar 11 17:43:36 fovo.local gnome-shell[1725]: #1   7ffca21b5ee0 b   resource:///org/gnome/shell/ui/environment.js:134 (2e06e09cc4c0 @ 98)
Mar 11 17:43:36 fovo.local gnome-shell[1725]: #2   7ffca21b5fa0 b   resource:///org/gnome/shell/ui/environment.js:221 (2e06e09cc830 @ 14)
Mar 11 17:43:36 fovo.local audit[1725]: ANOM_ABEND auid=1000 uid=1000 gid=1000 ses=3 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 pid=1725 comm="gnome-shell" exe="/usr/bin/gnome-shell" sig=6 res=1
Mar 11 17:43:36 fovo.local audit: BPF prog-id=102 op=LOAD
Mar 11 17:43:36 fovo.local audit: BPF prog-id=103 op=LOAD
Mar 11 17:43:36 fovo.local audit: BPF prog-id=104 op=LOAD
Mar 11 17:43:36 fovo.local systemd[1]: Started systemd-coredump - Process Core Dump (PID 10429/UID 0).
Mar 11 17:43:36 fovo.local audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-coredump@1-10429-0 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? te>
Mar 11 17:43:40 fovo.local [10431]: [164B blob data]
Mar 11 17:43:40 fovo.local systemd-coredump[10430]: [🡕] Process 1725 (gnome-shell) of user 1000 dumped core.
                                                    
                                                    Module linux-vdso.so.1 with build-id cf64fa256d2869039f211c7e6d2ecf99a391aa69
                                                    Module libcanberra-pulse.so with build-id 270cfa0cf9e68c317f8783ca3276ba9445f925be
                                                    Metadata for module libcanberra-pulse.so owned by FDO found: {
                                                            "type" : "rpm",
                                                            "name" : "libcanberra",
                                                            "version" : "0.30-28.fc36",
                                                            "architecture" : "x86_64",
                                                            "osCpe" : "cpe:/o:fedoraproject:fedora:36"
                                                    }
                                                    
                                                    Module ISO8859-1.so with build-id d0d762b9872f23b0d923bd898d5b8f80b4a71cb7
                                                    Module libpk-gtk-module.so with build-id f9085fc07471c5b410ff6a64c1ca25e557f90458
                                                    Stack trace of thread 1725:
                                                    #0  0x00007f37a3a2ae3c __pthread_kill_implementation (libc.so.6 + 0x92e3c)
                                                    #1  0x00007f37a39daa16 raise (libc.so.6 + 0x42a16)
                                                    #2  0x0000561335d0b462 dump_gjs_stack_on_signal_handler (gnome-shell + 0x3462)
                                                    #3  0x00007f37a39daac0 __restore_rt (libc.so.6 + 0x42ac0)
                                                    #4  0x00007f37a3a2ae3c __pthread_kill_implementation (libc.so.6 + 0x92e3c)
                                                    #5  0x00007f37a39daa16 raise (libc.so.6 + 0x42a16)
                                                    #6  0x00007f37a39c482f abort (libc.so.6 + 0x2c82f)
                                                    #7  0x00007f37a4904d0c g_assertion_message.cold (libglib-2.0.so.0 + 0x1ed0c)
                                                    #8  0x00007f37a4964ace g_assertion_message_expr (libglib-2.0.so.0 + 0x7eace)
                                                    #9  0x00007f37a3e5c572 clutter_actor_set_mapped (libmutter-clutter-10.so.0 + 0x3c572)
                                                    #10 0x00007f37a4a52c79 g_signal_emit_valist (libgobject-2.0.so.0 + 0x30c79)
                                                    #11 0x00007f37a4a52db3 g_signal_emit (libgobject-2.0.so.0 + 0x30db3)
                                                    #12 0x00007f37a3e65659 clutter_actor_hide (libmutter-clutter-10.so.0 + 0x45659)
                                                    #13 0x00007f37a303e746 ffi_call_unix64 (libffi.so.8 + 0x7746)
                                                    #14 0x00007f37a303b4d2 ffi_call_int.lto_priv.0 (libffi.so.8 + 0x44d2)
                                                    #15 0x00007f37a3f81466 _ZN3Gjs8Function6invokeEP9JSContextRKN2JS8CallArgsENS3_6HandleIP8JSObjectEEP11_GIArgument.localalias.lto_priv.0 (libgjs.so.0 + 0x4c466)
                                                    #16 0x00007f37a3f81b37 _ZN3Gjs8Function4callEP9JSContextjPN2JS5ValueE (libgjs.so.0 + 0x4cb37)
                                                    #17 0x000032842121525d n/a (n/a + 0x0)
                                                    #18 0x000056133a701d28 n/a (n/a + 0x0)
                                                    #19 0x0000328421215df9 n/a (n/a + 0x0)
                                                    #20 0x000056133a747508 n/a (n/a + 0x0)
                                                    #21 0x0000328421215df9 n/a (n/a + 0x0)
                                                    #22 0x000056133a7a5448 n/a (n/a + 0x0)
                                                    #23 0x000032842117556f n/a (n/a + 0x0)
                                                    #24 0x00007f37a2520e93 _ZL8EnterJitP9JSContextRN2js8RunStateEPh (libmozjs-91.so.0 + 0x735e93)
                                                    #25 0x00007f37a1f2e192 _ZN2js9RunScriptEP9JSContextRNS_8RunStateE (libmozjs-91.so.0 + 0x143192)
                                                    #26 0x00007f37a1f2e620 _ZN2js23InternalCallOrConstructEP9JSContextRKN2JS8CallArgsENS_14MaybeConstructENS_10CallReasonE (libmozjs-91.so.0 + 0x143620)
                                                    #27 0x00007f37a1f2eae5 _ZN2js4CallEP9JSContextN2JS6HandleINS2_5ValueEEES5_RKNS_13AnyInvokeArgsENS2_13MutableHandleIS4_EENS_10CallReasonE (libmozjs-91.so.0 + 0x143ae5)
                                                    #28 0x00007f37a1f90b1c _Z15JS_CallFunctionP9JSContextN2JS6HandleIP8JSObjectEENS2_IP10JSFunctionEERKNS1_16HandleValueArrayENS1_13MutableHandleINS1_5ValueEEE (libmozjs-91.so.0 + 0x>
                                                    #29 0x00007f37a3f7fb72 _ZN3Gjs7Closure6invokeEN2JS6HandleIP8JSObjectEERKNS1_16HandleValueArrayENS1_13MutableHandleINS1_5ValueEEE (libgjs.so.0 + 0x4ab72)
                                                    #30 0x00007f37a3fb3581 _ZN3Gjs7Closure7marshalEP7_GValuejPKS1_PvS5_ (libgjs.so.0 + 0x7e581)
                                                    #31 0x00007f37a4a35e60 g_closure_invoke (libgobject-2.0.so.0 + 0x13e60)
                                                    #32 0x00007f37a4a62636 signal_emit_unlocked_R.isra.0 (libgobject-2.0.so.0 + 0x40636)
                                                    #33 0x00007f37a4a52b2e g_signal_emit_valist (libgobject-2.0.so.0 + 0x30b2e)
                                                    #34 0x00007f37a4a52db3 g_signal_emit (libgobject-2.0.so.0 + 0x30db3)
                                                    #35 0x00007f37a3ee4073 clutter_timeline_do_frame.isra.0 (libmutter-clutter-10.so.0 + 0xc4073)
                                                    #36 0x00007f37a3e8b8fd frame_clock_source_dispatch (libmutter-clutter-10.so.0 + 0x6b8fd)
                                                    #37 0x00007f37a493afaf g_main_context_dispatch (libglib-2.0.so.0 + 0x54faf)
                                                    #38 0x00007f37a4990228 g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xaa228)
                                                    #39 0x00007f37a493a6cf g_main_loop_run (libglib-2.0.so.0 + 0x546cf)
                                                    #40 0x00007f37a3c916c9 meta_context_run_main_loop (libmutter-10.so.0 + 0xd76c9)
                                                    #41 0x0000561335d0ae27 main (gnome-shell + 0x2e27)
                                                    #42 0x00007f37a39c5590 __libc_start_call_main (libc.so.6 + 0x2d590)
                                                    #43 0x00007f37a39c5649 __libc_start_main@@GLIBC_2.34 (libc.so.6 + 0x2d649)
                                                    #44 0x0000561335d0b095 _start (gnome-shell + 0x3095)
                                                    
                                                    Stack trace of thread 1733:
                                                    #0  0x00007f37a3aa1e8f __poll (libc.so.6 + 0x109e8f)
                                                    #1  0x00007f37a499019d g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xaa19d)
                                                    #2  0x00007f37a4938920 g_main_context_iteration (libglib-2.0.so.0 + 0x52920)
                                                    #3  0x00007f37a4938971 glib_worker_main (libglib-2.0.so.0 + 0x52971)
                                                    #4  0x00007f37a4965222 g_thread_proxy (libglib-2.0.so.0 + 0x7f222)
                                                    #5  0x00007f37a3a29017 start_thread (libc.so.6 + 0x91017)
                                                    #6  0x00007f37a3aae6d0 __clone3 (libc.so.6 + 0x1166d0)
                                                    
                                                    Stack trace of thread 1735:
                                                    #0  0x00007f37a3aa1e8f __poll (libc.so.6 + 0x109e8f)
                                                    #1  0x00007f37a499019d g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xaa19d)
                                                    #2  0x00007f37a493a6cf g_main_loop_run (libglib-2.0.so.0 + 0x546cf)
                                                    #3  0x00007f37a4b956ea gdbus_shared_thread_func.lto_priv.0 (libgio-2.0.so.0 + 0x1146ea)
                                                    #4  0x00007f37a4965222 g_thread_proxy (libglib-2.0.so.0 + 0x7f222)
                                                    #5  0x00007f37a3a29017 start_thread (libc.so.6 + 0x91017)
                                                    #6  0x00007f37a3aae6d0 __clone3 (libc.so.6 + 0x1166d0)

Comment 1 Chris Murphy 2022-03-12 01:01:34 UTC
Created attachment 1865600 [details]
coredumpctl gdb, thread apply all bt full

Comment 2 Fedora Blocker Bugs Application 2022-03-12 01:03:33 UTC
Proposed as a Blocker for 36-final by Fedora user chrismurphy using the blocker tracking app because:

 All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use. 
https://fedoraproject.org/wiki/Fedora_36_Final_Release_Criteria

Comment 3 Chris Murphy 2022-03-12 01:09:42 UTC
Possible dupes, bug 2063113, bug 2061998.

The beta release requirement is "No part of any release-blocking desktop's panel (or equivalent) configuration may crash on startup or be entirely non-functional." which it's not *entirely* non-functional, but it's a pretty bad regression compared to beta. In which case the catcha all beta release requirement "Bug hinders execution of required Beta test plans or dramatically reduces test coverage" because at this point I'm inching toward downgrading...

Comment 4 Adam Williamson 2022-03-14 17:11:01 UTC
Related MR was cited by jadahl in 2063113.

Comment 5 Adam Williamson 2022-03-14 17:14:01 UTC
brandon pointed out another potentially-related MR.

Comment 6 Geoffrey Marr 2022-03-14 18:55:16 UTC
Discussed during the 2022-03-14 blocker review meeting: [0]

The decision to classify this bug as both an "AcceptedBlocker (Final)" and an "AcceptedFreezeException (Beta)" was made as it's happened enough times to enough people to consider it a conditional violation of several criteria (e.g. the panel criterion) for now. We will backport the proposed fixes and do further testing to clarify the situation.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2022-03-14/f36-blocker-review.2022-03-14-16.01.txt

Comment 7 Adam Williamson 2022-03-14 19:03:29 UTC
*** Bug 2063113 has been marked as a duplicate of this bug. ***

Comment 8 Adam Williamson 2022-03-14 19:03:50 UTC
*** Bug 2061998 has been marked as a duplicate of this bug. ***

Comment 9 Adam Williamson 2022-03-14 19:05:00 UTC
Moving to mutter as the big fix seems to be there. The gnome-shell MR would help with one specific case but the mutter MR would prevent crashing in any case, AIUI.

Comment 10 Fedora Update System 2022-03-14 23:27:46 UTC
FEDORA-2022-f60236a3c5 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-f60236a3c5

Comment 11 Fedora Update System 2022-03-15 15:15:55 UTC
FEDORA-2022-f60236a3c5 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-f60236a3c5`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-f60236a3c5

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 lnie 2022-03-16 11:02:05 UTC
Checked with mutter-42~rc-5.fc36.x86_64.rpm ,didn't see the crash any more,though the system hang once with flood of "dconf_changeset_set: assertion 'dconf_is_path (path, NULL)' failed ' printed to journal
"

Comment 13 Fedora Update System 2022-03-16 14:56:22 UTC
FEDORA-2022-f60236a3c5 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-f60236a3c5`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-f60236a3c5

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Adam Williamson 2022-03-16 16:22:57 UTC
Thanks, lnie! Those errors can actually come from https://bugzilla.redhat.com/show_bug.cgi?id=2064473 , although I wouldn't expect that to cause a hang...

Comment 15 Fedora Update System 2022-03-24 00:56:22 UTC
FEDORA-2022-f60236a3c5 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.