Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2064077 - GNOME 42-rc notifies of available updates in live mode
Summary: GNOME 42-rc notifies of available updates in live mode
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution
Version: 36
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Aoife Moloney
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: openqa AcceptedFreezeException Accept...
: 2064248 (view as bug list)
Depends On:
Blocks: F36BetaFreezeException F36FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2022-03-15 01:40 UTC by Adam Williamson
Modified: 2023-05-09 13:56 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-03-16 16:05:56 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Fedora Pagure fedora-kickstarts pull-request 878 0 None None None 2022-03-15 15:44:52 UTC

Description Adam Williamson 2022-03-15 01:40:33 UTC
When booting the Workstation live from Fedora-Rawhide-20220308.n.0 or later, an updates notification appears shortly after boot. This is not meant to happen: there should be *no* update notifications in the live image.

The way we try to accomplish this is to set org.gnome.software.download-updates to false:

https://pagure.io/fedora-kickstarts/blob/main/f/fedora-live-workstation.ks#_23

this has worked fine for a long time. The obviously-relevant change in the Fedora-Rawhide-20220308.n.0 compose is that gnome-software went from 42~beta-3 to 42~rc-1 . gnome-shell did not change on 0308.n.0 , so assigning to gnome-software.

Some of the recent changes to src/gs-update-monitor.c look kinda suspicious here, but I don't entirely understand how everything in there works, so I won't point fingers any more specifically than that for now :D

Comment 1 Adam Williamson 2022-03-15 01:41:46 UTC
Oh, I set this to 36 because the same change is stable in 36 as of today. Proposing as a Final blocker: "Release-blocking desktops must notify the user of available updates, but must not do so when running as a live image" - https://fedoraproject.org/wiki/Fedora_36_Final_Release_Criteria#Update_notification . Also proposing as Beta FE.

Comment 2 Milan Crha 2022-03-15 06:36:39 UTC
From the upstream bug report:

I do not think it's a bug. You do not download the updates (as the option says), you only check for updates. The "suspicious" commit is [1].

What you really want is: gsettings set org.gnome.software allow-updates false.

[1] https://gitlab.gnome.org/GNOME/gnome-software/-/commit/333b740ade5d127503f88404ddc48fa393158c14

Comment 3 Milan Crha 2022-03-15 06:41:32 UTC
Looking in the code, you'll be safer when setting both allow-updates and download-updates to false.

Comment 4 Milan Crha 2022-03-15 14:12:17 UTC
*** Bug 2064248 has been marked as a duplicate of this bug. ***

Comment 5 Adam Williamson 2022-03-15 15:32:20 UTC
Uh, please don't close it as not a bug. It's definitely a bug, whether or not it's considered a bug in GNOME Software.

Comment 6 Milan Crha 2022-03-15 15:44:14 UTC
> Uh, please don't close it as not a bug.

Aha, okay, my fault. I didn't know where to move it.

Comment 7 Adam Williamson 2022-03-15 20:51:09 UTC
+3 BetaFE and FinalBlocker in https://pagure.io/fedora-qa/blocker-review/issue/667 , setting accepted.

Comment 8 Adam Williamson 2022-03-16 06:49:05 UTC
Fix is merged, setting ON_QA, should be fixed in next compose.

Comment 9 Adam Williamson 2022-03-16 16:05:56 UTC
Confirmed fixed in today's nightly.


Note You need to log in before you can comment on or make changes to this bug.