Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2064248 - updates notification appears even on a Live image
Summary: updates notification appears even on a Live image
Keywords:
Status: CLOSED DUPLICATE of bug 2064077
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Milan Crha
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F36FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2022-03-15 11:57 UTC by Kamil Páral
Modified: 2022-03-15 14:12 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-03-15 14:12:17 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
screenshot (deleted)
2022-03-15 11:58 UTC, Kamil Páral
no flags Details
system journal (deleted)
2022-03-15 11:58 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2022-03-15 11:57:40 UTC
Description of problem:
If I boot Fedora-Workstation-Live-x86_64-36_Beta-1.1.iso, I sometimes (not always) see "updates available" notification. That is wrong, the system should not ask the user to update when it's running from the Live system. There must be some regression since F35.

Version-Release number of selected component (if applicable):
Fedora-Workstation-Live-x86_64-36_Beta-1.1.iso
gnome-software-42~rc-2.fc36.x86_64
PackageKit-1.2.5-1.fc36.x86_64

How reproducible:
often, not always

Steps to Reproduce:
1. boot the Live image
2. wait a few minutes, the notification appears (sometimes)

Comment 1 Kamil Páral 2022-03-15 11:58:10 UTC
Created attachment 1866022 [details]
screenshot

Comment 2 Kamil Páral 2022-03-15 11:58:17 UTC
Created attachment 1866023 [details]
system journal

Comment 3 Kamil Páral 2022-03-15 11:59:03 UTC
Proposing as an F36 Final Blocker:
"Release-blocking desktops must notify the user of available updates, but must not do so when running as a live image. "
https://fedoraproject.org/wiki/Fedora_36_Final_Release_Criteria#Update_notification

Comment 4 Michael Catanzaro 2022-03-15 13:48:58 UTC
It's supposed to be disabled by https://pagure.io/fedora-kickstarts/blob/main/f/fedora-live-workstation.ks:

# disable gnome-software automatically downloading updates
cat >> /usr/share/glib-2.0/schemas/org.gnome.software.gschema.override << FOE
[org.gnome.software]
download-updates=false
FOE

Comment 5 Milan Crha 2022-03-15 14:12:17 UTC

*** This bug has been marked as a duplicate of bug 2064077 ***


Note You need to log in before you can comment on or make changes to this bug.