Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2064462 - X11: Failed to create foreign window for XID 0: clicking on already set up account in settings > online accounts does not open a new pop up window to show account sync settings
Summary: X11: Failed to create foreign window for XID 0: clicking on already set up ac...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-control-center
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: GNOME SIG Unassigned
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F36FinalBlocker F36FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2022-03-15 22:22 UTC by Ankur Sinha (FranciscoD)
Modified: 2023-09-15 01:52 UTC (History)
9 users (show)

Fixed In Version: gnome-control-center-42.0-2.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-04-03 00:15:38 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME gnome-control-center merge_requests 1272/ 0 None None None 2022-03-29 09:16:08 UTC

Description Ankur Sinha (FranciscoD) 2022-03-15 22:22:07 UTC
Description of problem:
In gnome-control-center under online accounts, when clicking an already existing account, like my Google account, no pop up window is shown to allow me to enable or disable specific sync settings.

No crash is seen, but on looking at the journal, I see that each time I click on the account, eg. Google, there's an entry in the journal that says:

gnome-control-c[86961]: Failed to create foreign window for XID 0

Version-Release number of selected component (if applicable):
gnome-control-center-42~rc-1.fc36.x86_64
gnome-shell-42~rc-2.fc36.x86_64


How reproducible:
Always

Steps to Reproduce:
1. Login to Gnome using X
2. Go to online accounts in gnome-control-center
3. Click on a pre-existing account to change some sync settings

Actual results:
Pop up showing sync settings does not appear

Expected results:
Pop up showing sync settings should appear

Additional info:
I also created a new account and see the same behaviour there also.

This does not seem to happen when using Wayland, so it seems to be something X specific.

Comment 1 Ankur Sinha (FranciscoD) 2022-03-24 16:07:39 UTC
Could someone take a look at this please? It makes the online accounts bit pretty useless...

Comment 2 Ankur Sinha (FranciscoD) 2022-03-29 09:16:08 UTC
Fixed upstream now:

https://gitlab.gnome.org/GNOME/gnome-control-center/-/merge_requests/1272/diffs

Comment 3 Fedora Blocker Bugs Application 2022-03-29 13:28:28 UTC
Proposed as a Blocker and Freeze Exception for 36-final by Fedora user ankursinha using the blocker tracking app because:

 Users on X will not be able to use Gnome Online accounts at all. This includes most Nvidia users (even though it can do Wayland, it seems to work better on X), or anyone using a platform like Zoom or Anydesk for work neither of which support Wayland yet.

A fix is available already, but has not made it's way into Fedora yet.

Comment 4 Fedora Update System 2022-03-30 22:40:20 UTC
FEDORA-2022-67fa3533bf has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-67fa3533bf

Comment 5 Fedora Update System 2022-03-31 18:25:21 UTC
FEDORA-2022-67fa3533bf has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-67fa3533bf`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-67fa3533bf

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2022-04-03 00:15:38 UTC
FEDORA-2022-67fa3533bf has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 7 Red Hat Bugzilla 2023-09-15 01:52:52 UTC
The needinfo request[s] on this closed bug have been removed as they have been unresolved for 365 days


Note You need to log in before you can comment on or make changes to this bug.