Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2066424 - keyring can't be unlocked after Workstation Live install
Summary: keyring can't be unlocked after Workstation Live install
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-initial-setup
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adam Williamson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException AcceptedBlocker
Depends On:
Blocks: F36BetaFreezeException F36FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2022-03-21 17:37 UTC by Kamil Páral
Modified: 2022-03-25 07:43 UTC (History)
15 users (show)

Fixed In Version: gnome-initial-setup-42.0-2.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-03-24 00:56:53 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
screenshot from seahorse (deleted)
2022-03-21 17:40 UTC, Kamil Páral
no flags Details
system journal (deleted)
2022-03-21 17:41 UTC, Kamil Páral
no flags Details
journal from F35 Workstation live install booted to g-i-s start (deleted)
2022-03-21 22:06 UTC, Adam Williamson
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME gnome-initial-setup issues 141 0 None None None 2022-03-22 00:43:31 UTC

Description Kamil Páral 2022-03-21 17:37:14 UTC
Description of problem:
I installed a clean f36 Beta RC1.2 Workstation Live. After rebooting into the system and going through gnome-initial-setup, I found out that the keyring is locked and I can't unlock it (it says invalid password each time). After installing Seahorse, I see that the default keyring is indeed locked, with some unknown password.

The only "workaround" I found is to remove the default keyring, log out and log back in, and GNOME will create a new default keyring, this time correctly with my current user password.

Version-Release number of selected component (if applicable):
gnome-keyring-40.0-4.fc36.x86_64

How reproducible:
always

Steps to Reproduce:
1. install a fresh Workstation Live system
2. reboot, go through initial setup
3. install seahorse, run it, and see that the default "login" keyring is locked
4. try to unlock it, see that your password is marked as incorrect, can't be unlocked

Comment 1 Kamil Páral 2022-03-21 17:40:14 UTC
Created attachment 1867288 [details]
screenshot from seahorse

Comment 2 Kamil Páral 2022-03-21 17:41:11 UTC
Created attachment 1867289 [details]
system journal

Comment 3 Kamil Páral 2022-03-21 17:41:50 UTC
Proposing as a Final blocker:
"Saving passwords to and retrieving passwords from the default keyring must work for all release-blocking desktops. "
https://fedoraproject.org/wiki/Fedora_36_Final_Release_Criteria#Desktop_keyring

Comment 4 Adam Williamson 2022-03-21 17:49:15 UTC
There sure do seem to be some significant errors in the logs:

Mar 21 18:37:17 localhost-live gnome-keyring-daemon[1549]: couldn't access control socket: /run/user/985/keyring/control: No such file or directory
Mar 21 18:37:17 localhost-live gnome-keyring-d[1549]: couldn't access control socket: /run/user/985/keyring/control: No such file or directory
Mar 21 18:37:17 localhost-live /usr/libexec/gdm-wayland-session[1036]: dbus-daemon[1036]: [session uid=985 pid=1036] Successfully activated service 'org.freedesktop.secrets'
Mar 21 18:37:17 localhost-live /usr/libexec/gdm-wayland-session[1036]: dbus-daemon[1036]: [session uid=985 pid=1036] Successfully activated service 'org.freedesktop.portal.Desktop'
Mar 21 18:37:17 localhost-live gnome-initial-s[1435]: Starting gnome-initial-setup
Mar 21 18:37:17 localhost-live gnome-initial-s[1435]: Production mode: changes will be saved to disk
Mar 21 18:37:17 localhost-live gnome-keyring-daemon[1561]: couldn't set environment variable in session: GDBus.Error:org.gnome.SessionManager.NotInInitialization: Setenv interface is only available during the DisplayServer and Initialization phase
Mar 21 18:37:17 localhost-live gnome-keyring-daemon[1561]: another secret service is running
...
Mar 21 18:37:35 localhost-live gnome-initial-s[1435]: Failed to change keyring password: GDBus.Error:org.freedesktop.Secret.Error.NoSuchObject: The collection does not exist

Comment 5 Matthias Clasen 2022-03-21 17:58:59 UTC
The last nontrivial commits in gnome-keyring upstream are 11 months old. Hmm

Comment 6 Adam Williamson 2022-03-21 18:02:30 UTC
Yeah, but "The collection does not exist" looks a lot like a 'real' error message coming back from the dbus call, not "I tried to talk to this thing and it just wasn't there" or anything like that. Also hmm :|

Comment 7 Adam Williamson 2022-03-21 18:04:35 UTC
gnome-keyring uses that exact error message in four places (pet peeve! always use different error messages from different code!), the most likely candidate I guess is here:

https://gitlab.gnome.org/GNOME/gnome-keyring/-/blob/master/daemon/dbus/gkd-secret-service.c#L847

Comment 8 Adam Williamson 2022-03-21 18:20:56 UTC
CCing Daiki - Matthias suggested he might have an idea here.

Comment 9 Adam Williamson 2022-03-21 18:38:41 UTC
I did an F35 install to compare. The messages are pretty similar, just without that error. Here's F36 around where that error occurs:

Mar 21 18:37:35 localhost-live useradd[1645]: add 'kparal' to group 'wheel'
Mar 21 18:37:35 localhost-live audit[1645]: USER_MGMT pid=1645 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:useradd_t:s0 msg='op=add-to-shadow-group grp="wheel" acct="kparal" exe="/usr/sbin/useradd" hostname=? addr=? terminal=? res=success'
Mar 21 18:37:35 localhost-live useradd[1645]: add 'kparal' to shadow group 'wheel'
Mar 21 18:37:35 localhost-live audit[1645]: USER_MGMT pid=1645 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:useradd_t:s0 msg='op=add-home-dir id=1000 exe="/usr/sbin/useradd" hostname=? addr=? terminal=? res=success'
Mar 21 18:37:35 localhost-live accounts-daemon[768]: request by system-bus-name::1.69 [/usr/libexec/gnome-initial-setup pid:1435 uid:985]: set password and hint of user 'kparal' (1000)
Mar 21 18:37:35 localhost-live audit[1654]: USER_CHAUTHTOK pid=1654 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:useradd_t:s0 msg='op=updating-password id=1000 exe="/usr/sbin/usermod" hostname=? addr=? terminal=? res=success'
Mar 21 18:37:35 localhost-live usermod[1654]: change user 'kparal' password
Mar 21 18:37:35 localhost-live gnome-initial-s[1435]: Failed to change keyring password: GDBus.Error:org.freedesktop.Secret.Error.NoSuchObject: The collection does not exist
Mar 21 18:37:35 localhost-live gdm-password][1663]: gkr-pam: unable to locate daemon control file
Mar 21 18:37:35 localhost-live gdm-password][1663]: gkr-pam: stashed password to try later in open session

And here's the same spot in F35 logs:

Mar 21 13:33:31 fedora useradd[1528]: add 'test' to group 'wheel'
Mar 21 13:33:31 fedora useradd[1528]: add 'test' to shadow group 'wheel'
Mar 21 13:33:31 fedora audit[1528]: USER_MGMT pid=1528 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:useradd_t:s0 msg='op=add-home-dir id=1000 exe="/usr/sbin/useradd" hostname=? addr=? terminal=? res=success'
Mar 21 13:33:31 fedora accounts-daemon[747]: request by system-bus-name::1.70 [/usr/libexec/gnome-initial-setup pid:1366 uid:983]: set password and hint of user 'test' (1000)
Mar 21 13:33:31 fedora audit[1537]: USER_CHAUTHTOK pid=1537 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:useradd_t:s0 msg='op=updating-password id=1000 exe="/usr/sbin/usermod" hostname=? addr=? terminal=? res=success'
Mar 21 13:33:31 fedora usermod[1537]: change user 'test' password
Mar 21 13:33:33 fedora audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-hostnamed comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Mar 21 13:33:33 fedora systemd[1]: systemd-hostnamed.service: Deactivated successfully.
Mar 21 13:33:33 fedora audit: BPF prog-id=52 op=UNLOAD
Mar 21 13:33:33 fedora audit: BPF prog-id=51 op=UNLOAD
Mar 21 13:33:33 fedora gdm-password][1549]: gkr-pam: unable to locate daemon control file
Mar 21 13:33:33 fedora audit[1549]: USER_AUTH pid=1549 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 msg='op=PAM:authentication grantors=pam_usertype,pam_localuser,pam_unix,pam_gnome_keyring acct="test" exe="/usr/libexec/gdm-session-worker" hostname=fedora addr=? terminal=/dev/tty1 res=success'
Mar 21 13:33:33 fedora gdm-password][1549]: gkr-pam: stashed password to try later in open session

So, same stuff (including gkr-pam errors), but not the "Failed to change keyring password: GDBus.Error:org.freedesktop.Secret.Error.NoSuchObject: The collection does not exist" error. And indeed on F35, if you run seahorse after logging in, the login keyring shows as unlocked.

Comment 10 Adam Williamson 2022-03-21 21:15:40 UTC
Proposing this as a Beta FE too, we would definitely like to fix it for Beta if possible. I'm trying to look into it ATM.

Comment 11 Adam Williamson 2022-03-21 21:52:27 UTC
I booted clean F35 and F36 installs to the same point - the first page of gnome-initial-setup showing - and used a debug shell to poke around a bit. The outputs of `ps aux | grep keyring` and `ps aux | grep dbus` seem interesting. Here's F35 keyring:

gnome-i+    1380  0.0  0.2 452492  5548 tty1     Sl+  16:44   0:00 gnome-keyring-daemon --unlock
root        1532  0.0  0.0   3324  1572 tty9     S+   16:48   0:00 grep keyring

F35 dbus:

dbus         661  0.0  0.2  10224  4564 ?        Ss   16:44   0:00 /usr/bin/dbus-broker-launch --scope system --audit
dbus         676  0.2  0.2   9388  5352 ?        S    16:44   0:00 dbus-broker --log 4 --controller 9 --machine-id 0db9a3688176457c973f75a1c7cf70af --max-bytes 536870912 --max-fds 4096 --max-matches 131072 --audit
gnome-i+     890  0.0  0.3 374236  6068 tty1     Ssl+ 16:44   0:00 /usr/libexec/gdm-wayland-session dbus-run-session -- gnome-session --autostart /usr/share/gdm/greeter/autostart  --session gnome-initial-setup
gnome-i+     892  0.0  0.1   9696  3900 ?        Ss   16:44   0:00 /usr/bin/dbus-broker-launch --scope user
gnome-i+     893  0.0  0.1   4832  2996 ?        S    16:44   0:00 dbus-broker --log 4 --controller 9 --machine-id 0db9a3688176457c973f75a1c7cf70af --max-bytes 100000000000000 --max-fds 25000000000000 --max-matches 5000000000
gnome-i+     895  0.0  0.0   6672  1524 tty1     S+   16:44   0:00 dbus-run-session -- gnome-session --autostart /usr/share/gdm/greeter/autostart --session gnome-initial-setup
gnome-i+     896  0.1  0.2  10248  5804 tty1     S+   16:44   0:00 dbus-daemon --nofork --print-address 4 --session
gnome-i+     929  0.0  0.2   9556  4980 tty1     S+   16:44   0:00 /usr/bin/dbus-daemon --config-file=/usr/share/defaults/at-spi2/accessibility.conf --nofork --print-address 3
root        1527  0.0  0.0   3324  1464 tty9     S+   16:47   0:00 grep dbus

Here's F36 keyring:

gnome-i+    1469  0.0  0.2 453036  8560 tty1     Sl+  14:20   0:00 /usr/bin/gnome-keyring-daemon --start --foreground --components=secrets
gnome-i+    1484  0.0  0.1 453196  5676 tty1     Sl+  14:20   0:00 gnome-keyring-daemon --unlock
root        1916  0.0  0.0   3296  1524 tty9     R+   16:50   0:00 grep keyring

and F36 dbus:

dbus         733  0.0  0.1  11276  5416 ?        Ss   14:20   0:00 /usr/bin/dbus-broker-launch --scope system --audit
dbus         748  0.0  0.1   9664  5532 ?        S    14:20   0:00 dbus-broker --log 4 --controller 9 --machine-id f28f57933f9c4c3bb5ee481bdf384c37 --max-bytes 536870912 --max-fds 4096 --max-matches 131072 --audit
gnome-i+     969  0.0  0.1 374828  5988 tty1     Ssl+ 14:20   0:00 /usr/libexec/gdm-wayland-session dbus-run-session -- gnome-session --autostart /usr/share/gdm/greeter/autostart  --session gnome-initial-setup
gnome-i+     971  0.0  0.1  10356  4180 ?        Ss   14:20   0:00 /usr/bin/dbus-broker-launch --scope user
gnome-i+     972  0.0  0.0   4844  1400 ?        S    14:20   0:00 dbus-broker --log 4 --controller 9 --machine-id f28f57933f9c4c3bb5ee481bdf384c37 --max-bytes 100000000000000 --max-fds 25000000000000 --max-matches 5000000000
gnome-i+     974  0.0  0.0   6468  1488 tty1     S+   14:20   0:00 dbus-run-session -- gnome-session --autostart /usr/share/gdm/greeter/autostart --session gnome-initial-setup
gnome-i+     975  0.0  0.1   9988  6000 tty1     S+   14:20   0:00 dbus-daemon --nofork --print-address 4 --session
gnome-i+    1016  0.0  0.1   9264  5136 tty1     S+   14:20   0:00 /usr/bin/dbus-daemon --config-file=/usr/share/defaults/at-spi2/accessibility.conf --nofork --print-address 3
gnome-i+    1261  0.0  0.0   8124   376 tty1     S    14:20   0:00 dbus-launch --autolaunch=f28f57933f9c4c3bb5ee481bdf384c37 --binary-syntax --close-stderr
gnome-i+    1265  0.0  0.0   9332  2864 ?        Ss   14:20   0:00 /usr/bin/dbus-daemon --syslog-only --fork --print-pid 5 --print-address 7 --session
gnome-i+    1286  0.0  0.1   9332  4656 ?        S    14:20   0:00 /usr/bin/dbus-daemon --config-file=/usr/share/defaults/at-spi2/accessibility.conf --nofork --print-address 3
root        1719  0.0  0.0   3296  1484 tty9     S+   14:58   0:00 grep dbus

So F36 has one extra `gnome-keyring-daemon` process and three extra dbus-related processes at this point in boot compared to F35. Not sure why not, but it smells like that could be related here - like we wind up talking to the wrong keyring daemon, or the wrong dbus session, or something?

Comment 12 Adam Williamson 2022-03-21 22:06:06 UTC
Created attachment 1867314 [details]
journal from F35 Workstation live install booted to g-i-s start

Here's the journal from my F35 Workstation clean install and boot for comparison. There seems to be quite a lot going on in the F36 boot that just isn't happening in the F35 boot. Trying to see where the extra gnome-keyring-daemon process comes from, there seems to be a whole bunch of extra service activations in kparal's F36 logs that just aren't there in F35, which lead up to the extra gnome-keyring-daemon process (pid 1549):

Mar 21 18:37:16 localhost-live /usr/libexec/gdm-wayland-session[1036]: dbus-daemon[1036]: [session uid=985 pid=1036] Activating service name='org.freedesktop.portal.Desktop' requested by ':1.61' (uid=985 pid=1435 comm="/usr/libexec/gnome-initial-setup" label="system_u:system_r:xdm_t:s0-s0:c0.c1023")
Mar 21 18:37:16 localhost-live /usr/libexec/gdm-wayland-session[1036]: dbus-daemon[1036]: [session uid=985 pid=1036] Activating service name='org.freedesktop.portal.Documents' requested by ':1.66' (uid=985 pid=1495 comm="/usr/libexec/xdg-desktop-portal" label="system_u:system_r:xdm_t:s0-s0:c0.c1023")
Mar 21 18:37:16 localhost-live /usr/libexec/gdm-wayland-session[1036]: dbus-daemon[1036]: [session uid=985 pid=1036] Successfully activated service 'org.freedesktop.portal.Documents'
Mar 21 18:37:16 localhost-live audit[1500]: ANOM_ABEND auid=4294967295 uid=985 gid=982 ses=4294967295 subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 pid=1500 comm="xdg-document-po" exe="/usr/libexec/xdg-document-portal" sig=11 res=1
Mar 21 18:37:16 localhost-live kernel: show_signal_msg: 179 callbacks suppressed
Mar 21 18:37:16 localhost-live kernel: xdg-document-po[1500]: segfault at c ip 00007f14c87e4e5a sp 00007ffd4a6c2520 error 4 in libfuse.so.2.9.9[7f14c87e3000+1c000]
Mar 21 18:37:16 localhost-live kernel: Code: f3 0f 1e fa f2 ff 25 75 71 03 00 0f 1f 44 00 00 f3 0f 1e fa f2 ff 25 6d 71 03 00 0f 1f 44 00 00 48 8b 04 25 00 00 00 00 0f 0b <8b> 04 25 0c 00 00 00 0f 0b 66 2e 0f 1f 84 00 00 00 00 00 0f 1f 00
Mar 21 18:37:16 localhost-live systemd[1]: Created slice system-systemd\x2dcoredump.slice - Slice /system/systemd-coredump.
Mar 21 18:37:16 localhost-live audit: BPF prog-id=88 op=LOAD
Mar 21 18:37:16 localhost-live audit: BPF prog-id=89 op=LOAD
Mar 21 18:37:16 localhost-live audit: BPF prog-id=90 op=LOAD
Mar 21 18:37:16 localhost-live systemd[1]: Started systemd-coredump - Process Core Dump (PID 1505/UID 0).
Mar 21 18:37:16 localhost-live audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-coredump@0-1505-0 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Mar 21 18:37:16 localhost-live systemd-coredump[1506]: Cannot resolve systemd-coredump user. Proceeding to dump core as root: No such process
Mar 21 18:37:16 localhost-live systemd-coredump[1506]: Process 1500 (xdg-document-po) of user 985 dumped core.
[core dump trimmed]
Mar 21 18:37:16 localhost-live systemd[1]: run-user-985-doc.mount: Deactivated successfully.
Mar 21 18:37:16 localhost-live audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-coredump@0-1505-0 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Mar 21 18:37:16 localhost-live /usr/libexec/gdm-wayland-session[1036]: dbus-daemon[1036]: [session uid=985 pid=1036] Activating service name='org.freedesktop.impl.portal.desktop.gnome' requested by ':1.66' (uid=985 pid=1495 comm="/usr/libexec/xdg-desktop-portal" label="system_u:system_r:xdm_t:s0-s0:c0.c1023")
Mar 21 18:37:16 localhost-live systemd[1]: systemd-coredump: Deactivated successfully.
Mar 21 18:37:16 localhost-live audit: BPF prog-id=0 op=UNLOAD
Mar 21 18:37:16 localhost-live audit: BPF prog-id=0 op=UNLOAD
Mar 21 18:37:16 localhost-live audit: BPF prog-id=0 op=UNLOAD
Mar 21 18:37:17 localhost-live /usr/libexec/gdm-wayland-session[1036]: dbus-daemon[1036]: [session uid=985 pid=1036] Successfully activated service 'org.freedesktop.impl.portal.desktop.gnome'
Mar 21 18:37:17 localhost-live rtkit-daemon[767]: Supervising 6 threads of 3 processes of 1 users.
Mar 21 18:37:17 localhost-live rtkit-daemon[767]: Supervising 6 threads of 3 processes of 1 users.
Mar 21 18:37:17 localhost-live rtkit-daemon[767]: Supervising 6 threads of 3 processes of 1 users.
Mar 21 18:37:17 localhost-live /usr/libexec/gdm-wayland-session[1036]: dbus-daemon[1036]: [session uid=985 pid=1036] Activating service name='org.freedesktop.impl.portal.desktop.gtk' requested by ':1.66' (uid=985 pid=1495 comm="/usr/libexec/xdg-desktop-portal" label="system_u:system_r:xdm_t:s0-s0:c0.c1023")
Mar 21 18:37:17 localhost-live /usr/libexec/gdm-wayland-session[1036]: dbus-daemon[1036]: [session uid=985 pid=1036] Successfully activated service 'org.freedesktop.impl.portal.desktop.gtk'
Mar 21 18:37:17 localhost-live /usr/libexec/gdm-wayland-session[1036]: dbus-daemon[1036]: [session uid=985 pid=1036] Activating service name='org.freedesktop.secrets' requested by ':1.66' (uid=985 pid=1495 comm="/usr/libexec/xdg-desktop-portal" label="system_u:system_r:xdm_t:s0-s0:c0.c1023")
Mar 21 18:37:17 localhost-live gnome-keyring-daemon[1549]: couldn't access control socket: /run/user/985/keyring/control: No such file or directory
Mar 21 18:37:17 localhost-live gnome-keyring-d[1549]: couldn't access control socket: /run/user/985/keyring/control: No such file or directory

The F35 logs don't have any of that stuff. The word 'portal' only appears a few times in the F35 logs, relating to org.freedesktop.portal.IBus and org.freedesktop.impl.portal.PermissionStore - none of this desktop portal stuff.

Comment 13 Adam Williamson 2022-03-21 22:33:59 UTC
OK, so if I kill the extra gnome-keyring-daemon process - the `/usr/bin/gnome-keyring-daemon --start --foreground --components=secrets` one - before I do the user creation step in g-i-s, the "Failed to change keyring password: GDBus.Error:org.freedesktop.Secret.Error.NoSuchObject: The collection does not exist" error does not appear and the keyring is unlocked. If I leave that extra process around, the error appears and the keyring is locked. I tested both ways twice, so I think that's the key (pardon the pun) here.

So, I guess we need to work out why this extra gnome-keyring-daemon process is showing up in the g-i-s session. If it is the desktop portal stuff (which I believe is the stuff that's necessary for flatpaks to work, right?), why is that happening?

Comment 14 Adam Williamson 2022-03-21 23:07:16 UTC
Another difference to F35 - during start of the g-i-s session, F35 logs this:

Mar 21 16:44:14 localhost-live systemd[1]: Started Session c1 of User gnome-initial-setup.
Mar 21 16:44:14 localhost-live systemd[880]: Created slice User Core Session Slice.
Mar 21 16:44:14 localhost-live systemd[880]: Starting D-Bus User Message Bus...
Mar 21 16:44:14 localhost-live dbus-broker-launch[892]: Policy to allow eavesdropping in /usr/share/dbus-1/session.conf +31: Eavesdropping is deprecated and ignored
Mar 21 16:44:14 localhost-live dbus-broker-launch[892]: Policy to allow eavesdropping in /usr/share/dbus-1/session.conf +33: Eavesdropping is deprecated and ignored
Mar 21 16:44:14 localhost-live dbus-broker-lau[892]: Ready
Mar 21 16:44:14 localhost-live systemd[880]: Started D-Bus User Message Bus.
Mar 21 16:44:14 localhost-live gnome-session[897]: gnome-session-binary[897]: WARNING: Failed to upload environment to systemd: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Name "org.freedesktop.systemd1" does not exist
Mar 21 16:44:14 localhost-live gnome-session-binary[897]: WARNING: Failed to upload environment to systemd: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Name "org.freedesktop.systemd1" does not exist
Mar 21 16:44:14 localhost-live gnome-session[897]: gnome-session-binary[897]: WARNING: Failed to reset failed state of units: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Name "org.freedesktop.systemd1" does not exist
Mar 21 16:44:14 localhost-live gnome-session-binary[897]: WARNING: Failed to reset failed state of units: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Name "org.freedesktop.systemd1" does not exist
Mar 21 16:44:14 localhost-live gnome-session[897]: gnome-session-binary[897]: WARNING: Falling back to non-systemd startup procedure due to error: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Name "org.freedesktop.systemd1" does not exist
Mar 21 16:44:14 localhost-live gnome-session-binary[897]: WARNING: Falling back to non-systemd startup procedure due to error: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Name "org.freedesktop.systemd1" does not exist
Mar 21 16:44:15 localhost-live gnome-shell[907]: Running GNOME Shell (using mutter 41.0) as a Wayland display server

The corresponding F36 section looks different:

Mar 21 18:37:13 localhost-live systemd[1]: Started session-c1.scope - Session c1 of User gnome-initial-setup.
Mar 21 18:37:13 localhost-live gdm-launch-environment][1003]: pam_unix(gdm-launch-environment:session): session opened for user gnome-initial-setup(uid=985) by (uid=0)
Mar 21 18:37:13 localhost-live audit[1003]: USER_START pid=1003 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 msg='op=PAM:session_open grantors=pam_keyinit,pam_keyinit,pam_limits,pam_systemd,pam_unix,pam_umask acct="gnome-initial-setup" exe="/usr/libexec/gdm-session-worker" hostname=localhost-live addr=? terminal=/dev/tty1 res=success'
Mar 21 18:37:13 localhost-live systemd[1020]: Created slice session.slice - User Core Session Slice.
Mar 21 18:37:13 localhost-live systemd[1020]: Starting dbus-broker.service - D-Bus User Message Bus...
Mar 21 18:37:13 localhost-live dbus-broker-launch[1032]: Policy to allow eavesdropping in /usr/share/dbus-1/session.conf +31: Eavesdropping is deprecated and ignored
Mar 21 18:37:13 localhost-live dbus-broker-launch[1032]: Policy to allow eavesdropping in /usr/share/dbus-1/session.conf +33: Eavesdropping is deprecated and ignored
Mar 21 18:37:13 localhost-live systemd[1020]: Started dbus-broker.service - D-Bus User Message Bus.
Mar 21 18:37:13 localhost-live dbus-broker-lau[1032]: Ready
Mar 21 18:37:13 localhost-live /usr/libexec/gdm-wayland-session[1036]: dbus-daemon[1036]: [session uid=985 pid=1036] Activating service name='org.gtk.vfs.Daemon' requested by ':1.0' (uid=985 pid=1038 comm="gsettings get org.gnome.system.locale region" label="system_u:system_r:xdm_t:s0-s0:c0.c1023")
Mar 21 18:37:13 localhost-live /usr/libexec/gdm-wayland-session[1036]: dbus-daemon[1036]: [session uid=985 pid=1036] Successfully activated service 'org.gtk.vfs.Daemon'
Mar 21 18:37:13 localhost-live /usr/libexec/gdm-wayland-session[1047]: fuse: failed to open /dev/fuse: Permission denied
Mar 21 18:37:13 localhost-live gnome-session[1037]: gnome-session-binary[1037]: GLib-GIO-CRITICAL: g_bus_get_sync: assertion 'error == NULL || *error == NULL' failed
Mar 21 18:37:13 localhost-live gnome-session[1037]: gnome-session-binary[1037]: GLib-GIO-CRITICAL: g_bus_get_sync: assertion 'error == NULL || *error == NULL' failed
Mar 21 18:37:13 localhost-live gnome-session-binary[1037]: GLib-GIO-CRITICAL: g_bus_get_sync: assertion 'error == NULL || *error == NULL' failed
Mar 21 18:37:13 localhost-live gnome-session-binary[1037]: GLib-GIO-CRITICAL: g_bus_get_sync: assertion 'error == NULL || *error == NULL' failed
Mar 21 18:37:13 localhost-live gnome-shell[1053]: Running GNOME Shell (using mutter 42.rc) as a Wayland display server

more assertion errors, no "Falling back to non-systemd startup procedure". Not sure if that may be relevant.

Comment 15 Adam Williamson 2022-03-22 00:05:35 UTC
Looks like this really is a gnome-initial-setup bug, in fact. If I downgrade to gnome-initial-setup-41.0-1.fc35 - which is the version F35 had - the extra gnome-keyring-daemon process goes away, and all the stuff about portals in the journal goes away too. I'll see if I can isolate the change between 41.0 and 42~rc that causes the problem.

Comment 16 Adam Williamson 2022-03-22 00:43:31 UTC
OK, this is somehow triggered by the addition of dark theme support to g-i-s(!) Reported upstream, update with that change reverted coming.

Comment 17 Fedora Update System 2022-03-22 00:55:18 UTC
FEDORA-2022-b55b46db86 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-b55b46db86

Comment 18 Adam Williamson 2022-03-22 01:20:07 UTC
+4 final blocker and +3 beta FE in https://pagure.io/fedora-qa/blocker-review/issue/682 , marking accepted both.

Comment 19 Kamil Páral 2022-03-22 09:24:08 UTC
(In reply to Fedora Update System from comment #17)
> FEDORA-2022-b55b46db86 has been submitted as an update to Fedora 36.
> https://bodhi.fedoraproject.org/updates/FEDORA-2022-b55b46db86

I tested this by installing Workstation and then updating g-i-s in rescue mode before the first boot of the initial system. The problem is fixed.

Comment 20 Fedora Update System 2022-03-22 17:55:01 UTC
FEDORA-2022-b55b46db86 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-b55b46db86`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-b55b46db86

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 21 Fedora Update System 2022-03-24 00:56:53 UTC
FEDORA-2022-b55b46db86 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.