Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2066427 - symlink /var/lib/rpm->/usr/lib/sysimage/rpm does not exist
Summary: symlink /var/lib/rpm->/usr/lib/sysimage/rpm does not exist
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Neal Gompa
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F36FinalBlocker 2042099
TreeView+ depends on / blocked
 
Reported: 2022-03-21 18:08 UTC by Chris Murphy
Modified: 2022-03-26 15:28 UTC (History)
8 users (show)

Fixed In Version: rpm-4.17.0-10.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-03-26 15:28:45 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Chris Murphy 2022-03-21 18:08:25 UTC
Description of problem:

Following a clean install, /var/lib/rpm does not exist.

Version-Release number of selected component (if applicable):
rpm-4.17.0-9.fc36.x86_64

How reproducible:
Always


Steps to Reproduce:
1. Clean install Fedora-Workstation-Live-x86_64-36_Beta-1.3.iso
2.
3.

Actual results:

/var/lib/rpm does not exist on the Live media, is not created on the installation destination.


Expected results:

There should be a symlink /var/lib/rpm->/usr/lib/sysimage/rpm symlink


Additional info:

A snapshot from a clean install of Fedora-Workstation-Live-x86_64-36-20220220.n.0.iso also is missing the symlink so I don't think this is a new problem.

Comment 1 Fedora Blocker Bugs Application 2022-03-21 18:26:51 UTC
Proposed as a Blocker for 36-final by Fedora user chrismurphy using the blocker tracking app because:

 https://fedoraproject.org/wiki/Changes/RelocateRPMToUsr

NOTE: the bug does not affect upgrades, just new clean installs.

A condition of the change is there should be a symlink /var/lib/rpm -> /usr/lib/sysimage/rpm and the change does block release. We're past freeze so the contingency probably doesn't apply.

Since the missing symlink isn't breaking any dnf or PackageKit functionality, or seemingly anything else out of the box, I think we're on solid ground saying "well it's a beta" and documenting this in common bugs. And making this a final blocker, so that's what I'm proposing.

Comment 2 Fedora Update System 2022-03-21 23:44:46 UTC
FEDORA-2022-c564d315fc has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-c564d315fc

Comment 3 Chris Murphy 2022-03-21 23:53:30 UTC
Updating to rpm-4.17.0-10.fc36 fixed this on a f36 installation that was missing /var/lib/rpm.

Comment 4 Fedora Update System 2022-03-22 17:54:52 UTC
FEDORA-2022-c564d315fc has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-c564d315fc`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-c564d315fc

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2022-03-26 15:28:45 UTC
FEDORA-2022-c564d315fc has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.