Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2069164 - Most buttons on the GNOME virtual keyboard don't work
Summary: Most buttons on the GNOME virtual keyboard don't work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F36FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2022-03-28 12:03 UTC by Kamil Páral
Modified: 2022-05-03 14:41 UTC (History)
9 users (show)

Fixed In Version: gnome-shell-42.0-2.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-04-01 04:52:25 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME gnome-shell merge_requests 2237 0 None None None 2022-03-28 16:27:45 UTC

Description Kamil Páral 2022-03-28 12:03:19 UTC
Description of problem:
If you invoke the GNOME virtual keyboard and try to type something, you'll soon discover that most letters don't work, they don't input anything. For example, from the top line "qwertyuiop", only "euio" are typed in, all other characters are ignored.

Version-Release number of selected component (if applicable):
gnome-shell-42~rc-3.fc36.x86_64
mutter-42~rc-5.fc36.x86_64

How reproducible:
always

Steps to Reproduce:
1. enable Screen Keyboard in GNOME Settings -> Accessibility
2. open e.g. Text Editor app
3. click inside, a virtual keyboard should pop up at the bottom of the screen
4. try to type letters, most don't do anything

Additional info:
I'm not sure whether this keyboard is integrated in gnome-shell, or whether this bug should be reported against some other package which provides that functionality.

Comment 1 Kamil Páral 2022-03-28 12:08:38 UTC
Proposing as a Final blocker. Possibly these criteria could be related:
https://fedoraproject.org/wiki/Fedora_36_Final_Release_Criteria#Default_application_functionality
https://fedoraproject.org/wiki/Fedora_36_Final_Release_Criteria#Default_panel_functionality

Please note that the accessibility menu is displayed by default on the login screen (referring to the "Default panel functionality" criterion). That means that you can't even log in using this virtual keyboard. (Also, the keyboard on the login screen disappears after each pressed letter, which is doubly annoying, but probably a separate issue).

Comment 2 Adam Williamson 2022-03-28 16:27:46 UTC
garnacho says there's a fix for this upstream, linked.

Comment 3 Geoffrey Marr 2022-03-28 19:36:24 UTC
Discussed during the 2022-03-28 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedBlocker (Final)" was made as it violates the following criterion:

"A system installed with a release-blocking desktop must boot to a log in screen where it is possible to log in to a working desktop", in cases where use of the on-screen keyboard is necessary due to lack of a physical keyboard, or accessibility requirements.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2022-03-28/f36-blocker-review.2022-03-28-16.00.txt

Comment 4 Adam Williamson 2022-03-28 23:01:49 UTC
Looks like that fix was actually merged in 42.0, so the pending megaupdate should fix this.

Comment 5 Fedora Update System 2022-03-28 23:03:00 UTC
FEDORA-2022-a69718b1e1 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-a69718b1e1

Comment 6 Adam Williamson 2022-03-28 23:33:27 UTC
oh, nope. that megaupdate somehow did not include a gnome-shell build...

Comment 7 Fedora Update System 2022-03-28 23:37:24 UTC
FEDORA-2022-8b3e009de7 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-8b3e009de7

Comment 8 Adam Williamson 2022-03-28 23:38:19 UTC
OK, fix confirmed here with that update I just created.

Comment 9 Fedora Update System 2022-03-29 01:23:39 UTC
FEDORA-2022-8b3e009de7 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-8b3e009de7`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-8b3e009de7

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2022-04-01 04:52:25 UTC
FEDORA-2022-8b3e009de7 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.