Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2069876 - SELinux is preventing fprintd from 'write' accesses on the file persist.
Summary: SELinux is preventing fprintd from 'write' accesses on the file persist.
Keywords:
Status: CLOSED DUPLICATE of bug 2010925
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 36
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Pytela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:bdd87a8514dea337df3869bc9d7...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-03-29 22:56 UTC by Andrew Thurman
Modified: 2022-03-30 07:01 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-03-30 07:01:07 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Andrew Thurman 2022-03-29 22:56:07 UTC
Description of problem:
Happens when waking up from suspend along with SELinux is preventing gst-plugin-scan from write access on the file trace_marker_raw.

Also experiencing freezing when returning from suspend, still unsure if related as difficult to reproduce.
SELinux is preventing fprintd from 'write' accesses on the file persist.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that fprintd should be allowed write access on the persist file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'fprintd' --raw | audit2allow -M my-fprintd
# semodule -X 300 -i my-fprintd.pp

Additional Information:
Source Context                system_u:system_r:fprintd_t:s0
Target Context                system_u:object_r:sysfs_t:s0
Target Objects                persist [ file ]
Source                        fprintd
Source Path                   fprintd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
SELinux Policy RPM            selinux-policy-targeted-36.5-1.fc36.noarch
Local Policy RPM              selinux-policy-targeted-36.5-1.fc36.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 5.17.1-300.fc36.x86_64 #1 SMP
                              PREEMPT Mon Mar 28 15:27:56 UTC 2022 x86_64 x86_64
Alert Count                   480
First Seen                    2022-03-19 21:55:14 EDT
Last Seen                     2022-03-29 18:51:33 EDT
Local ID                      919a8e62-d2cc-44e5-b72e-fb2edfa120d1

Raw Audit Messages
type=AVC msg=audit(1648594293.927:297): avc:  denied  { write } for  pid=3020 comm="fprintd" name="persist" dev="sysfs" ino=48622 scontext=system_u:system_r:fprintd_t:s0 tcontext=system_u:object_r:sysfs_t:s0 tclass=file permissive=0


Hash: fprintd,fprintd_t,sysfs_t,file,write

Version-Release number of selected component:
selinux-policy-targeted-36.5-1.fc36.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.17.1
hashmarkername: setroubleshoot
kernel:         5.17.1-300.fc36.x86_64
type:           libreport

Potential duplicate: bug 2010925

Comment 1 Zdenek Pytela 2022-03-30 07:01:07 UTC

*** This bug has been marked as a duplicate of bug 2010925 ***


Note You need to log in before you can comment on or make changes to this bug.