Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2071098 - "Installing software" and other strings displayed during installation are untranslated
Summary: "Installing software" and other strings displayed during installation are unt...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vendula Poncova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException AcceptedBlocker
Depends On:
Blocks: F36FinalBlocker F36FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2022-04-01 19:28 UTC by Daniel Rusek
Modified: 2022-04-14 23:23 UTC (History)
12 users (show)

Fixed In Version: anaconda-36.16.5-1.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-04-14 23:23:39 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
Untranslated string (deleted)
2022-04-01 19:28 UTC, Daniel Rusek
no flags Details

Description Daniel Rusek 2022-04-01 19:28:09 UTC
Created attachment 1870004 [details]
Untranslated string

Description of problem:
The "Installing software" and other strings that are displayed next to the spinner during Fedora installation are always displayed as untranslated (English) on non-English locale although they are fully translated in the Anaconda po file.

Version-Release number of selected component (if applicable):
anaconda-36.16.2-4.fc36.x86_64

How reproducible:
Every time (on Rawhide and F36).

Steps to Reproduce:
1. Install Fedora Rawhide or Fedora 36 with non-English locale that has these strings fully translated.
2. See the text next to the spinner.

Actual results:
"Installing software" and other strings that are displayed next to the spinner during Fedora installation are always in English.

Expected results:
"Installing software" and other strings that are displayed next to the spinner during Fedora installation are in correct language.

Comment 1 Fedora Blocker Bugs Application 2022-04-04 16:00:03 UTC
Proposed as a Freeze Exception for 36-final by Fedora user lruzicka using the blocker tracking app because:

 The proposition was required by @jkonecny. This will enable them to translate some untranslated strings in Anaconda.

Comment 2 Kamil Páral 2022-04-04 17:52:46 UTC
This might even be a blocker :)
https://fedoraproject.org/wiki/Fedora_36_Final_Release_Criteria#Installer_translations

Comment 3 František Zatloukal 2022-04-04 18:48:01 UTC
Discussed during the 2022-04-04 blocker review meeting: [1]

The decision to classify this bug as an AcceptedFreezeException was made:

"It is a noticeable issue that cannot be fixed with an update."

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2022-04-04/f36-blocker-review.2022-04-04-16.00.log.html

Comment 4 Vendula Poncova 2022-04-06 11:17:34 UTC
It looks like Anaconda DBus modules were always producing wrong translations in the live environment due to https://github.com/rhinstaller/anaconda/pull/4026. This fix could have some side effects, so we will apply it only to Rawhide and use a workaround in Fedora 36. See: https://github.com/rhinstaller/anaconda/pull/4024

Comment 5 František Zatloukal 2022-04-08 09:13:19 UTC
Discussed in ticket: https://pagure.io/fedora-qa/blocker-review/issue/698

The decision to classify this bug as an AcceptedBlocker was made:

This is violation of Final release criterion "The installer must correctly display all sufficiently complete translations available for use."

Comment 6 Fedora Update System 2022-04-12 11:03:35 UTC
FEDORA-2022-92570f3943 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-92570f3943

Comment 7 Kamil Páral 2022-04-12 12:15:15 UTC
(In reply to Fedora Update System from comment #6)
> FEDORA-2022-92570f3943 has been submitted as an update to Fedora 36.
> https://bodhi.fedoraproject.org/updates/FEDORA-2022-92570f3943

The installation progress strings are now translated. Tested with Czech language.

Comment 8 Fedora Update System 2022-04-12 14:46:20 UTC
FEDORA-2022-92570f3943 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-92570f3943`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-92570f3943

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2022-04-14 23:23:39 UTC
FEDORA-2022-92570f3943 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.