Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2072632 - RFE epel9: Request slurm builds for epel9
Summary: RFE epel9: Request slurm builds for epel9
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: slurm
Version: epel9
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Philip Kovacs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2099477 (view as bug list)
Depends On: 2034538 2124948
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-04-06 16:38 UTC by Trey Dockendorf
Modified: 2022-12-27 00:36 UTC (History)
5 users (show)

Fixed In Version: slurm-22.05.6-1.el9 slurm-22.05.6-3.el9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-12-07 03:15:16 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 2070427 1 unspecified CLOSED [RFE: EPEL9] EPEL9 branch for pdsh 2023-06-14 00:31:47 UTC

Description Trey Dockendorf 2022-04-06 16:38:56 UTC
I would like to request a Slurm build for epel9.  I have been asked to build pdsh for epel9 and it requires Slurm.

Comment 1 Jordan Conway 2022-08-08 19:14:09 UTC
It looks like the blocker ticket for this has been resolved and hdf5 is now in epel9. I'm very interested in seeing Slurm in epel9 as well.

Comment 2 Jordan Conway 2022-08-15 14:51:52 UTC
I tested and successfully built slurm on Rocky Linux 9 with your repo.  I did run into missing libjwt, but it seems that libjwt has now also been added to epel9 testing. https://bugzilla.redhat.com/show_bug.cgi?id=2103624

Comment 3 Jordan Conway 2022-08-26 14:44:04 UTC
libjwt is now in epel9 stable. I'd love to see a slurm build.
These changes worked for me to build it locally on Rocky Linux 9.

```
diff --git a/slurm.spec b/slurm.spec
index 9513edd..2d8a9db 100644
--- a/slurm.spec
+++ b/slurm.spec
@@ -81,8 +81,8 @@ BuildRequires:  zlib-devel
 BuildRequires:  ucx-devel
 %endif

-# create slurm-slurmrestd package for Fedora >= 34 and EPEL7/8
-%if (0%{?fedora} >= 34) || 0%{?el7} || 0%{?el8}
+# create slurm-slurmrestd package for Fedora >= 34 and EPEL7/8/9
+%if (0%{?fedora} >= 34) || 0%{?el7} || 0%{?el8} || 0%{?el9}
 BuildRequires:  http-parser-devel
 BuildRequires:  json-c-devel
 BuildRequires:  libjwt-devel
@@ -180,7 +180,7 @@ Requires: %{name}%{?_isa} = %{version}-%{release}
 Slurm database daemon. Used to accept and process database RPCs and upload
 database changes to slurmctld daemons on each cluster.

-%if (0%{?fedora} >= 34) || 0%{?el7} || 0%{?el8}
+%if (0%{?fedora} >= 34) || 0%{?el7} || 0%{?el8} || 0%{?el9}
 %package slurmrestd
 Summary: Slurm REST API deamon
 Requires: %{name}%{?_isa} = %{version}-%{release}
@@ -446,7 +446,7 @@ rm -f %{buildroot}%{_unitdir}/slurmrestd.service
 %{_bindir}/%{name}-setuser
 %{_libdir}/%{name}/accounting_storage_*.so
 %{_libdir}/%{name}/acct_gather_*.so
-%if (0%{?fedora} >= 34) || 0%{?el7} || 0%{?el8}
+%if (0%{?fedora} >= 34) || 0%{?el7} || 0%{?el8} || 0%{?el9}
 %{_libdir}/%{name}/auth_jwt.so
 %endif
 %{_libdir}/%{name}/auth_munge.so
@@ -639,7 +639,7 @@ fi
 # Slurm-slurmrestd
 # ----------------

-%if (0%{?fedora} >= 34) || 0%{?el7} || 0%{?el8}
+%if (0%{?fedora} >= 34) || 0%{?el7} || 0%{?el8} || 0%{?el9}
 %files slurmrestd
 %{_libdir}/%{name}/openapi_dbv0_0_36.so
 %{_libdir}/%{name}/openapi_v0_0_36.so
```

Comment 4 Philip Kovacs 2022-08-27 16:20:08 UTC
This is on my radar.  I saw that libjwt went stable.  I need to request the epel 9 branch and decide which version of slurm makes sense to use.  I cannot upgrade slurm as frequently in epel as in Fedora.

Comment 5 Teemu Järvinen 2022-08-30 11:06:44 UTC
May I suggest that you build version 22.05. The reasoning is that it is the first and only version with cgroupsv2 support and RHEL 9 is using cgroupsv2 by default. Thus have cgroups support for SLURM, and ability to kill automatically jobs that use more resources than requested, needs either version 22.05 of SLURM or downgrading to cgroupsv1 for main OS.

Comment 6 Philip Kovacs 2022-09-06 01:47:30 UTC
*** Bug 2099477 has been marked as a duplicate of this bug. ***

Comment 7 Philip Kovacs 2022-09-06 01:50:11 UTC
I submitted the branch request and am upgrading rawhide to 22.05.03, so expect progress on epel 9 soon -- thanks for your patience.

https://pagure.io/releng/fedora-scm-requests/issue/47396

Comment 8 Philip Kovacs 2022-09-07 03:06:55 UTC
The epel 9 branch is created and populated and I've been trying to get a clean build on it.  Three of the 4 architectures build fine, but arch s390x on epel9 does not appear to have numactl-devel.

Comment 9 Philip Kovacs 2022-11-28 01:07:47 UTC
I'm moving forward with this, first by upgrading slurm to 22.05.6 (latest) in f36, f37, f38 and second, by adding a check for package numactl-devel so that for platform epel9 on arch 390x, we avoid trying to pull in numactl-devel which remains unavailable for that platform/arch combination.   The only downside is that the task/affinity slurm plugin won't be available on s390x/el9, but that should be a minor omission given that other task plugins will be available if needed.

Comment 10 Fedora Update System 2022-11-28 01:51:01 UTC
FEDORA-EPEL-2022-9a2d01a59e has been submitted as an update to Fedora EPEL 9. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-9a2d01a59e

Comment 11 Fedora Update System 2022-11-29 02:46:36 UTC
FEDORA-EPEL-2022-9a2d01a59e has been pushed to the Fedora EPEL 9 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-9a2d01a59e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2022-12-07 03:15:16 UTC
FEDORA-EPEL-2022-9a2d01a59e has been pushed to the Fedora EPEL 9 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 13 Pierre Girard 2022-12-15 15:32:06 UTC
Hello,
  when trying to install slurm I get this message about a missing mailx dependency.

Error:
 Problem: package slurm-slurmd-22.05.6-1.el9.x86_64 requires slurm(x86-64) = 22.05.6-1.el9, but none of the providers can be installed
  - conflicting requests
  - nothing provides mailx needed by slurm-22.05.6-1.el9.x86_64

On almalinux, the mailx program seems to be provided by s-nail and is already installed on the system
# which mailx
/bin/mailx

# LANG=C dnf whatprovides mailx
Last metadata expiration check: 0:01:54 ago on Thu Dec 15 10:27:25 2022.
s-nail-14.9.22-6.el9.x86_64 : Environment for sending and receiving mail
Repo        : @System
Matched from:
Filename    : /usr/bin/mailx
Provide    : /bin/mailx

s-nail-14.9.22-6.el9.x86_64 : Environment for sending and receiving mail
Repo        : appstream
Matched from:
Filename    : /usr/bin/mailx
Provide    : /bin/mailx

Would it be possible to change the required dependency from mailx to s-nail, unless there's another way of installing mailx that I'm not aware of.

# cat /etc/os-release
NAME="AlmaLinux"
VERSION="9.1 (Lime Lynx)"
ID="almalinux"
ID_LIKE="rhel centos fedora"
VERSION_ID="9.1"
PLATFORM_ID="platform:el9"
PRETTY_NAME="AlmaLinux 9.1 (Lime Lynx)"
ANSI_COLOR="0;34"
LOGO="fedora-logo-icon"
CPE_NAME="cpe:/o:almalinux:almalinux:9::baseos"
HOME_URL="https://almalinux.org/"
DOCUMENTATION_URL="https://wiki.almalinux.org/"
BUG_REPORT_URL="https://bugs.almalinux.org/"

ALMALINUX_MANTISBT_PROJECT="AlmaLinux-9"
ALMALINUX_MANTISBT_PROJECT_VERSION="9.1"
REDHAT_SUPPORT_PRODUCT="AlmaLinux"
REDHAT_SUPPORT_PRODUCT_VERSION="9.1"

Thanks.

Comment 14 Philip Kovacs 2022-12-15 22:04:24 UTC
OK, the mailx issue is a problem with this line in the slurm spec:

Requires: mailx

If I change that to:

Requires: /bin/mailx

then the dnf/rpm dependency search will see that either package, mailx or s-nail. can provide that file.

I'll push a fix up.  Thanks for the report.

Comment 15 Fedora Update System 2022-12-18 01:22:34 UTC
FEDORA-EPEL-2022-1002069a15 has been submitted as an update to Fedora EPEL 9. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-1002069a15

Comment 16 Fedora Update System 2022-12-19 01:34:13 UTC
FEDORA-EPEL-2022-1002069a15 has been pushed to the Fedora EPEL 9 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-1002069a15

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 17 Fedora Update System 2022-12-27 00:36:36 UTC
FEDORA-EPEL-2022-1002069a15 has been pushed to the Fedora EPEL 9 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.