Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2073238 - rebuild hwinfo 21.68-1 against libx86emu 3.5-1 for EPEL7
Summary: rebuild hwinfo 21.68-1 against libx86emu 3.5-1 for EPEL7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: hwinfo
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-04-08 02:41 UTC by Carl George 🤠
Modified: 2022-04-10 19:30 UTC (History)
2 users (show)

Fixed In Version: hwinfo-21.68-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-04-10 19:30:17 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Carl George 🤠 2022-04-08 02:41:45 UTC
Description of problem:
libx86emu-3.5-1.el7 was pushed to EPEL7 [0].  It contains an soname bump from 1 to 3.  This is considered an incompatible upgrade and is not allowed by EPEL policy [1].  It breaks the installation of hwinfo-21.68-1.el7.  This was first noticed on the epel-devel mailing list [2].  The same thing also happened in EPEL8 [3].  Since the incompatible libx86emu has already been pushed, the quickest fix is to just rebuild hwinfo against the new soname.


Version-Release number of selected component (if applicable):
hwinfo-21.68-1.el7
libx86emu-3.5-1.el7


Steps to Reproduce:
1. yum install hwinfo


Actual results:
Error: Package: hwinfo-21.68-1.el7.x86_64 (epel)
           Requires: libx86emu.so.1()(64bit)


Expected results:
successful installation


Additional info:
[0] https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-255a3ea874
[1] https://docs.fedoraproject.org/en-US/epel/epel-policy/
[2] https://lists.fedoraproject.org/archives/list/epel-devel@lists.fedoraproject.org/thread/TO7LJKJZEKGYVAHJOBGBKJB5T3S67LA5/
[3] bug 2071639

Comment 1 Fedora Update System 2022-04-08 03:36:52 UTC
FEDORA-EPEL-2022-72167dbb66 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-72167dbb66

Comment 2 Fedora Update System 2022-04-08 20:37:38 UTC
FEDORA-EPEL-2022-72167dbb66 has been pushed to the Fedora EPEL 7 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-72167dbb66

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 3 Fedora Update System 2022-04-10 19:30:17 UTC
FEDORA-EPEL-2022-72167dbb66 has been pushed to the Fedora EPEL 7 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.