Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2073353 - RPM repos can't be disabled in GNOME Software after F35->F36 upgrade
Summary: RPM repos can't be disabled in GNOME Software after F35->F36 upgrade
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Milan Crha
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F36FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2022-04-08 09:50 UTC by Kamil Páral
Modified: 2022-04-12 07:19 UTC (History)
4 users (show)

Fixed In Version: gnome-software-42.0-2.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-04-11 22:52:27 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
RPM repos in upgraded F36 (deleted)
2022-04-08 09:51 UTC, Kamil Páral
no flags Details
RPM repos in cleanly installed F36 (deleted)
2022-04-08 09:51 UTC, Kamil Páral
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME gnome-software merge_requests 1318 0 None opened gs-plugin-provenance: Handle repositories specifically 2022-04-11 10:35:20 UTC

Description Kamil Páral 2022-04-08 09:50:06 UTC
Description of problem:
If I perform a clean F36 installation, I can toggle on/off all Fedora RPM repos in GNOME Software -> Software Repositories. However, when I upgrade F35 to F36, all the RPM repos are force-enabled and can't be disabled. This also includes updates-testing repos. See screenshots.

There is something broken in gnome-software for upgraded systems.

Note: 
Version-Release number of selected component (if applicable):
gnome-software-42.0-1.fc36.x86_64 (in both cases)

How reproducible:
always

Steps to Reproduce:
1. clean install F35 Workstation Live
2. sudo dnf system-upgrade download --releasever=36
3. sudo dnf system-upgrade reboot
4. boot into F36, start gnome-software -> Software Repositories, see RPM repos force-enabled


Additional info:
For comparison, the default behavior in F35 was that 'fedora' and 'updates' repos were force-enabled, the rest was free to be toggled. (That doesn't mean that F36 can't change that behavior, but it should behave the same for clean installs and upgrades).

Comment 1 Kamil Páral 2022-04-08 09:51:02 UTC
Created attachment 1871433 [details]
RPM repos in upgraded F36

Comment 2 Kamil Páral 2022-04-08 09:51:17 UTC
Created attachment 1871434 [details]
RPM repos in cleanly installed F36

Comment 3 Kamil Páral 2022-04-08 09:53:13 UTC
Proposing for a blocker discussion. This criterion seems impacted:
https://fedoraproject.org/wiki/Fedora_36_Final_Release_Criteria#Installing.2C_removing_and_updating_software
in particular "Configure software sources by enabling/disabling pre-defined official repositories and then adjust the available software pool accordingly".

Comment 4 František Zatloukal 2022-04-09 22:27:21 UTC
Discussed in ticket: https://pagure.io/fedora-qa/blocker-review/issue/732

The decision to classify this bug as an AcceptedBlocker was made:

"This issue violates the "The default graphical package manager for a given software type must appropriately: Configure software sources by enabling/disabling pre-defined official repositories and then adjust the available software pool accordingly" criterion."

Comment 5 Milan Crha 2022-04-11 07:08:23 UTC
Thanks for a bug report. I think the only reason to have this being done is a weird value of the settings key:

   $ gsettings get org.gnome.software required-repos

There is a related key:

   $ gsettings get org.gnome.software official-repos

but that is not supposed to influence the sensitivity of the checks, it's the first key for.

Could you check what values are stored in both installs, please?

Comment 6 Kamil Páral 2022-04-11 08:43:38 UTC
F36 install:

$ gsettings get org.gnome.software required-repos
['fedora', 'updates']

$ gsettings get org.gnome.software official-repos
['anaconda', 'fedora', 'fedora-debuginfo', 'fedora-source', 'koji-override-0', 'koji-override-1', 'rawhide', 'rawhide-debuginfo', 'rawhide-source', 'updates', 'updates-debuginfo', 'updates-source', 'updates-testing', 'updates-testing-debuginfo', 'updates-testing-source', 'fedora-modular', 'fedora-modular-debuginfo', 'fedora-modular-source', 'rawhide-modular', 'rawhide-modular-debuginfo', 'rawhide-modular-source', 'fedora-cisco-openh264', 'fedora-cisco-openh264-debuginfo']

F35->F36 upgrade:

$ gsettings get org.gnome.software required-repos
['fedora', 'updates']

$ gsettings get org.gnome.software official-repos
['anaconda', 'fedora', 'fedora-debuginfo', 'fedora-source', 'koji-override-0', 'koji-override-1', 'rawhide', 'rawhide-debuginfo', 'rawhide-source', 'updates', 'updates-debuginfo', 'updates-source', 'updates-testing', 'updates-testing-debuginfo', 'updates-testing-source', 'fedora-modular', 'fedora-modular-debuginfo', 'fedora-modular-source', 'rawhide-modular', 'rawhide-modular-debuginfo', 'rawhide-modular-source', 'fedora-cisco-openh264', 'fedora-cisco-openh264-debuginfo']

Comment 7 Milan Crha 2022-04-11 08:52:48 UTC
Thanks. If I read it correctly, they are the same and contain and expected value. I'll try to reproduce it here.

Comment 8 Milan Crha 2022-04-11 10:35:21 UTC
I could reproduce it too and I found the problem. I opened a merge request upstream [1], which I'll backport and I'll create an update for gnome-software meanwhile.

[1] https://gitlab.gnome.org/GNOME/gnome-software/-/merge_requests/1318

Comment 9 Fedora Update System 2022-04-11 10:50:30 UTC
FEDORA-2022-e5ddaf87b7 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-e5ddaf87b7

Comment 10 Kamil Páral 2022-04-11 11:49:18 UTC
(In reply to Fedora Update System from comment #9)
> FEDORA-2022-e5ddaf87b7 has been submitted as an update to Fedora 36.
> https://bodhi.fedoraproject.org/updates/FEDORA-2022-e5ddaf87b7

Only 'fedora' and 'updates' repos can't now be disabled, all others can, even on upgraded systems. Seems to be fixed.

Comment 11 Fedora Update System 2022-04-11 14:57:42 UTC
FEDORA-2022-e5ddaf87b7 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-e5ddaf87b7`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-e5ddaf87b7

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2022-04-11 22:52:27 UTC
FEDORA-2022-e5ddaf87b7 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.