Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2074586 - After update from 3.1.12-14 to 3.1.13-1 client can't connect anymore
Summary: After update from 3.1.12-14 to 3.1.13-1 client can't connect anymore
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: netatalk
Version: epel8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Andrew Bauer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2075735 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-04-12 14:54 UTC by ict
Modified: 2022-05-26 03:29 UTC (History)
9 users (show)

Fixed In Version: netatalk-3.1.13-3.fc36 netatalk-3.1.13-3.fc34 netatalk-3.1.13-3.fc35 netatalk-3.1.13-3.el8 netatalk-3.1.13-3.el9 netatalk-3.1.13-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-05-26 01:07:05 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description ict 2022-04-12 14:54:16 UTC
Description of problem:Client cannot connect anymore


Version-Release number of selected component (if applicable):3.1.13-1


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Apr 12 08:29:14.737978 afpd[1175463] {dsi_tcp.c:241} (info:DSI): AFP/TCP session from 192.168.1.62:49524
Apr 12 08:29:14.739997 afpd[986453] {main.c:149} (info:AFPDaemon): child[1175462]: exited 4
Apr 12 08:29:14.740026 afpd[986453] {main.c:151} (info:AFPDaemon): child[1175463]: done
Apr 12 08:29:14.812519 afpd[1175464] {dsi_tcp.c:241} (info:DSI): AFP/TCP session from 192.168.1.62:49525
Apr 12 08:29:14.813817 afpd[1175464] {uams_dhx2_pam.c:329} (info:UAMS): DHX2 login: dtp
Apr 12 08:29:14.831836 afpd[1175464] {uams_dhx2_pam.c:214} (info:UAMS): PAM DHX2: PAM Success
Apr 12 08:29:14.895929 afpd[1175464] {uams_dhx2_pam.c:709} (info:UAMS): DHX2: PAM Auth OK!
Apr 12 08:29:14.895959 afpd[1175464] {auth.c:235} (note:AFPDaemon): Login by dtp (AFP3.4)
Apr 12 08:29:14.896836 afpd[1175464] {auth.c:272} (info:AFPDaemon): login: force gid: 1011
Apr 12 08:29:14.900538 afpd[1175464] {fault.c:123} (severe:Default): ===============================================================
Apr 12 08:29:14.900554 afpd[1175464] {fault.c:124} (severe:Default): INTERNAL ERROR: Signal 11 in pid 1175464 (3.1.13)
Apr 12 08:29:14.900559 afpd[1175464] {fault.c:125} (severe:Default): ===============================================================
Apr 12 08:29:14.900718 afpd[1175464] {fault.c:96} (severe:Default): PANIC: internal error
Apr 12 08:29:14.900725 afpd[1175464] {fault.c:97} (severe:Default): BACKTRACE: 12 stack frames:
Apr 12 08:29:14.900729 afpd[1175464] {fault.c:103} (severe:Default):  #0 /lib64/libatalk.so.18(netatalk_panic+0x39) [0x7f6861a41099]
Apr 12 08:29:14.900733 afpd[1175464] {fault.c:103} (severe:Default):  #1 /lib64/libatalk.so.18(+0x421e0) [0x7f6861a411e0]
Apr 12 08:29:14.900736 afpd[1175464] {fault.c:103} (severe:Default):  #2 /lib64/libc.so.6(+0x37400) [0x7f685e991400]
Apr 12 08:29:14.900740 afpd[1175464] {fault.c:103} (severe:Default):  #3 /lib64/libatalk.so.18(+0x1ac40) [0x7f6861a19c40]
Apr 12 08:29:14.900743 afpd[1175464] {fault.c:103} (severe:Default):  #4 /lib64/libatalk.so.18(ad_open+0x4c6) [0x7f6861a1b086]
Apr 12 08:29:14.900747 afpd[1175464] {fault.c:103} (severe:Default):  #5 /usr/sbin/afpd(+0x3255e) [0x557c63b5c55e]
Apr 12 08:29:14.900750 afpd[1175464] {fault.c:103} (severe:Default):  #6 /usr/sbin/afpd(+0x332b5) [0x557c63b5d2b5]
Apr 12 08:29:14.900753 afpd[1175464] {fault.c:103} (severe:Default):  #7 /usr/sbin/afpd(afp_openvol+0x361) [0x557c63b5da81]
Apr 12 08:29:14.900771 afpd[1175464] {fault.c:103} (severe:Default):  #8 /usr/sbin/afpd(afp_over_dsi+0x67e) [0x557c63b3b2ee]
Apr 12 08:29:14.900775 afpd[1175464] {fault.c:103} (severe:Default):  #9 /usr/sbin/afpd(main+0x9b8) [0x557c63b39188]
Apr 12 08:29:14.900778 afpd[1175464] {fault.c:103} (severe:Default):  #10 /lib64/libc.so.6(__libc_start_main+0xf3) [0x7f685e97d493]
Apr 12 08:29:14.900782 afpd[1175464] {fault.c:103} (severe:Default):  #11 /usr/sbin/afpd(_start+0x2e) [0x557c63b394ce]
Apr 12 08:29:14.901659 afpd[986453] {main.c:154} (info:AFPDaemon): child[1175464]: killed by signal 6

Comment 1 Andrew Bauer 2022-04-12 17:34:11 UTC
This has been reported upstream at the following locations. Hopefully this will get the attention of the authors quickly:

https://github.com/Netatalk/Netatalk/issues/175

https://sourceforge.net/p/netatalk/bugs/670/

https://sourceforge.net/p/netatalk/bugs/669/

Comment 2 Andrew Bauer 2022-04-15 12:09:02 UTC
*** Bug 2075735 has been marked as a duplicate of this bug. ***

Comment 3 Andrew Bauer 2022-04-15 15:09:01 UTC
For those willing to experiment, please try the following patched build from my copr repo. 

https://copr.fedorainfracloud.org/coprs/kni/netatalk/

This is for testing only, not for production!
Normally I'd test this myself, but I am headed out of town for the next week and a half.

This build adds the following patch. I do not know if this will fix the issue or not, but it seems related.
https://github.com/Netatalk/Netatalk/pull/174

Comment 4 Andrew Bauer 2022-05-01 12:07:30 UTC
The upstream project is looking for yesteryear testers of pr 174, which mY fix the issue. Further discussion is herehttps://github.com/Netatalk/Netatalk/pull/174

This is the same patch I previously built on copr. Feedback is requested.

Comment 5 Andrew Bauer 2022-05-01 12:08:45 UTC
Sorry for the spelling. This was from mobile

Comment 6 Andrew Bauer 2022-05-03 12:44:36 UTC
I've added Netatalk 3.1.12 to the copr repo linked earlier, to make it easier to dnf downgrade to the previous version for the time being.

Comment 7 Leonid Podolny 2022-05-17 22:06:25 UTC
Also happens in Fedora 36. Testing the copr release.

Comment 8 Leonid Podolny 2022-05-17 22:33:02 UTC
The backup is still running, but at least it was able to login without crashing, so the patch seems to be working.

Comment 9 Andrew Bauer 2022-05-17 23:36:33 UTC
Since there appear to be some reports of success here and on the netatalk github site, I am going to push new packages that include PR#174
https://github.com/Netatalk/Netatalk/pull/174

Once these packages reach stable, please open a new bug report to report any new or existing issues.

Comment 10 Fedora Update System 2022-05-17 23:59:46 UTC
FEDORA-EPEL-2022-34ce1d6b90 has been submitted as an update to Fedora EPEL 9. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-34ce1d6b90

Comment 11 Fedora Update System 2022-05-18 00:00:24 UTC
FEDORA-2022-2b29f8e3c6 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-2b29f8e3c6

Comment 12 Fedora Update System 2022-05-18 00:00:56 UTC
FEDORA-2022-6506f47659 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-6506f47659

Comment 13 Fedora Update System 2022-05-18 00:01:33 UTC
FEDORA-EPEL-2022-e13ef43731 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-e13ef43731

Comment 14 Fedora Update System 2022-05-18 00:02:04 UTC
FEDORA-2022-da649d6eb7 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2022-da649d6eb7

Comment 15 Fedora Update System 2022-05-18 00:02:33 UTC
FEDORA-EPEL-2022-9ce6578c4b has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-9ce6578c4b

Comment 16 Fedora Update System 2022-05-18 01:20:28 UTC
FEDORA-EPEL-2022-e13ef43731 has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-e13ef43731

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 17 Fedora Update System 2022-05-18 02:08:45 UTC
FEDORA-2022-6506f47659 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-6506f47659`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-6506f47659

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 18 Fedora Update System 2022-05-18 02:29:15 UTC
FEDORA-2022-2b29f8e3c6 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-2b29f8e3c6`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-2b29f8e3c6

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 19 Fedora Update System 2022-05-18 02:34:29 UTC
FEDORA-2022-da649d6eb7 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-da649d6eb7`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-da649d6eb7

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 20 Fedora Update System 2022-05-18 03:05:23 UTC
FEDORA-EPEL-2022-34ce1d6b90 has been pushed to the Fedora EPEL 9 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-34ce1d6b90

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 21 Fedora Update System 2022-05-18 03:08:06 UTC
FEDORA-EPEL-2022-9ce6578c4b has been pushed to the Fedora EPEL 7 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-9ce6578c4b

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 22 Fedora Update System 2022-05-26 01:07:05 UTC
FEDORA-2022-2b29f8e3c6 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 23 Fedora Update System 2022-05-26 01:18:01 UTC
FEDORA-2022-da649d6eb7 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 24 Fedora Update System 2022-05-26 01:34:17 UTC
FEDORA-2022-6506f47659 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 25 Fedora Update System 2022-05-26 01:39:00 UTC
FEDORA-EPEL-2022-e13ef43731 has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 26 Fedora Update System 2022-05-26 02:56:26 UTC
FEDORA-EPEL-2022-34ce1d6b90 has been pushed to the Fedora EPEL 9 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 27 Fedora Update System 2022-05-26 03:29:13 UTC
FEDORA-EPEL-2022-9ce6578c4b has been pushed to the Fedora EPEL 7 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.