Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 2078626 - Please add inih-devel to CRB 9
Summary: Please add inih-devel to CRB 9
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 9
Classification: Red Hat
Component: inih
Version: CentOS Stream
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: 9.0
Assignee: Eric Sandeen
QA Contact: Zorro Lang
URL:
Whiteboard:
Depends On:
Blocks: 2066516 2075385 2092955 2096097
TreeView+ depends on / blocked
 
Reported: 2022-04-25 20:37 UTC by Robert Scheck
Modified: 2022-11-15 13:16 UTC (History)
8 users (show)

Fixed In Version: inih-49-6.el9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-11-15 11:20:53 UTC
Type: Bug
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker RHELPLAN-119903 0 None None None 2022-04-25 20:43:00 UTC
Red Hat Product Errata RHEA-2022:8359 0 None None None 2022-11-15 11:21:01 UTC

Description Robert Scheck 2022-04-25 20:37:59 UTC
Description of problem:
In order to build tio for EPEL 9, we need inih-devel available at build-time in CRB 9. Please add inih-devel to CRB 9 for this.

Unfortunately, there is not really an alternative to inih, because inih is already a simple INI file parser which is only a couple of pages of code.

Comment 1 Robert Scheck 2022-06-02 15:45:55 UTC
Steve, may I kindly ask you for some reaction here?

Cross-filed case 03234842 in the Red Hat customer portal. Please let us know if you need a business justification because above reasoning in the initial description is not good enough.

Comment 3 Steve Whitehouse 2022-06-06 09:24:04 UTC
I'm a bit confused about this request. What is this package and why is it being requested? Is it filesystems or HA related?

Comment 4 Robert Scheck 2022-06-06 10:09:21 UTC
I am in general following https://docs.fedoraproject.org/en-US/epel/epel-policy-missing-sub-packages/#long_term for inih-devel to get a current version of tio built for EPEL 9.

Comment 5 Steve Whitehouse 2022-06-06 11:07:39 UTC
Hmm, ok. I wonder why this has come through to me in that case. I've never maintained that package, so it isn't something I'm familiar with. I suspect that there has been some mix up in terms of the bugzilla assignment and you may need to find someone else to assist. I'll ask the fs team anyway, but it doesn't sound like something that we would normally be involved with.

Comment 6 Steve Whitehouse 2022-06-06 11:15:34 UTC
Ok, managed to solve some of this... it is apparently a dependency of xfsprogs! So that would perhaps explain why it has landed in my direction... still it is not something that we maintain I think, we just use it in one case. It may be that all other users have gone, so it defaulted ownership to us, perhaps... I don't think we want to maintain it in CRB as a general rule, but we'd have to look in more detail at the implications in order to fully understand the situation.

Comment 7 Robert Scheck 2022-06-06 11:19:34 UTC
Yes, since at least RHEL 8.6, inih is a dependency of xfsprogs. And thanks for investigating.

Comment 8 Eric Sandeen 2022-06-07 15:55:40 UTC
This is fine with me, I filed a ticket to request this, we'll see if it works.

Comment 9 Eric Sandeen 2022-06-08 13:05:32 UTC
Hi Zorro - can I get a QE ack on this so we can approve this bug? This will not require any QE work at all, it's simply making these headers available to users for development, but that can't proceed without all of the usual bug approvals.

Thanks,
-Eric

Comment 10 Zorro Lang 2022-06-09 03:31:48 UTC
(In reply to Eric Sandeen from comment #9)
> Hi Zorro - can I get a QE ack on this so we can approve this bug? This will
> not require any QE work at all, it's simply making these headers available
> to users for development, but that can't proceed without all of the usual
> bug approvals.

So we need a new erratum for this new package?
The inih-devel package is in Buildroot repo [1], so we would like to public and support it for customer by fs-devel/qe team?

Thanks,
Zorro

[1]
Available Packages
Name         : inih-devel
Version      : 49
Release      : 5.el9
Architecture : i686
Size         : 12 k
Source       : inih-49-5.el9.src.rpm
Repository   : beaker-BUILDROOT
Summary      : Development package for inih
URL          : https://github.com/benhoyt/inih
License      : BSD
Description  : This package contains development files for inih.
             : 
             : The inih package provides simple INI file parser which is only a couple of
             : pages of code, and it was designed to be small and simple, so it's good for
             : embedded systems.

> 
> Thanks,
> -Eric

Comment 11 Eric Sandeen 2022-06-13 16:03:46 UTC
Built inih-49-6.el9 for the required revision bump.

Comment 22 errata-xmlrpc 2022-11-15 11:20:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (inih bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2022:8359


Note You need to log in before you can comment on or make changes to this bug.