Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2079308 - pictures in Pictures folder aren't shown in the Photos
Summary: pictures in Pictures folder aren't shown in the Photos
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-photos
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: GNOME SIG Unassigned
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F36FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2022-04-27 11:10 UTC by lnie
Modified: 2022-05-04 00:23 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-05-04 00:23:29 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
journal (deleted)
2022-04-27 11:10 UTC, lnie
no flags Details
Normal behavior on F36 Work iso (RC 1.2) (deleted)
2022-04-28 13:02 UTC, Geraldo Simião
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME gnome-photos issues 196 0 None opened Pictures added to Pictures folder do not show up in Photos 2022-04-28 22:37:14 UTC

Description lnie 2022-04-27 11:10:59 UTC
Created attachment 1875340 [details]
journal

Description of problem:
The pictures will show after a reboot,but I think they are supposed to shown immediately as f35 dose

Version-Release number of selected component (if applicable):
gnome-photos-42.0-1.fc36.x86_64

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Fedora Blocker Bugs Application 2022-04-27 11:13:05 UTC
Proposed as a Blocker for 36-final by Fedora user lnie using the blocker tracking app because:

 seems affects:
https://fedoraproject.org/wiki/Fedora_36_Final_Release_Criteria#Default_application_functionality

Comment 2 Kamil Páral 2022-04-27 11:59:01 UTC
I can confirm this. Adding pictures to ~/Pictures doesn't display them in gnome-photos. I have to log out and log back in in order to make gnome-photos show them. This applies even when it already shows some pictures and I want to add a new one. I again have to re-log. On initial start, gnome-photos clearly says that contents to ~/Pictures will be shown, but it fails to do that. This works perfectly in F35.

Comment 3 Lukas Ruzicka 2022-04-27 12:23:34 UTC
I am seeing this too. I am quite surprised that there is a Photo application also, as I though that Image Viewer is the application to watch photos. It is also interesting, that if you go and open a picture using the File Open dialogue, it will open in Image Viewer and the Photo window remains empty.

Comment 4 Geraldo Simião 2022-04-27 13:48:16 UTC
I cannot reproduce this bug on a RC 1.1 workstation iso, perhaps because of new gtk4 versions I installed?

libproxy-webkitgtk4-0.4.17-4.fc36.x86_64
libnma-gtk4-1.8.34-2.fc36.x86_64
colord-gtk4-0.3.0-1.fc36.x86_64
gtk4-debuginfo-4.6.2-3.fc36.x86_64
gtk4-4.6.2-3.fc36.x86_64

Comment 5 Kamil Páral 2022-04-27 14:01:13 UTC
I installed a fresh RC 1.1 Workstation and I see the same bug as described.

Comment 6 Adam Williamson 2022-04-27 15:40:17 UTC
Lukas: Photos is intended as a "photo manager"-type application - like Shotwell - rather than as an "image viewer".

Comment 7 Adam Williamson 2022-04-27 16:22:18 UTC
+4 in https://pagure.io/fedora-qa/blocker-review/issue/785 , marking accepted.

Comment 8 Geraldo Simião 2022-04-27 18:41:45 UTC
I checked the RC 1.2 image too, and still cannot reproduce this bug.

Comment 9 Geraldo Simião 2022-04-28 13:02:28 UTC
Created attachment 1875662 [details]
Normal behavior on F36 Work iso (RC 1.2)

Comment 10 Geraldo Simião 2022-04-28 13:24:52 UTC
Now I made e new VM, a new fresh installation of the RC 1.2 ISO and now the bug appears here.
So, my findings are: 
- with live-session tested several times and not once the bug shows itself
- with installed VM tested several times and the bug shows sometimes

Comment 11 Adam Williamson 2022-04-28 22:37:15 UTC
I can also reproduce this in an installed VM. Reported upstream.

Comment 12 Luya Tshimbalanga 2022-04-29 01:30:56 UTC
Same issue (In reply to Geraldo Simião from comment #9)
> Created attachment 1875662 [details]
> Normal behavior on F36 Work iso (RC 1.2)

When dealing with more than thousand pictures, Photos took a long time to load them. Previous releases used to frequently crash.

Comment 13 Ray Strode [halfline] 2022-05-02 19:28:49 UTC
I have a guess from just reading through the code that may or may not work. Can someone give this scratch build a try?

https://koji.fedoraproject.org/koji/taskinfo?taskID=86547488

Comment 14 Kamil Páral 2022-05-02 20:16:51 UTC
(In reply to Ray Strode [halfline] from comment #13)
> https://koji.fedoraproject.org/koji/taskinfo?taskID=86547488

I tested this and it looks very good.
1. Moving a picture to a folder makes gnome-photos show it, often even live. Sometimes app restart is needed. But it works now.
2. Removing a picture from a folder removes it from gnome-photos after app start/restart (doesn't do it live). Also fixed.
3. Pictures seem to be tracked in ~/Pictures, ~/Downloads and ~/Desktop. I thought this was some mistake, but it behaves the same in F35. So probably intentional.

Can you please create a bodhi update?

Comment 15 Adam Williamson 2022-05-02 20:24:12 UTC
Yep, confirmed, I also re-tested with the scratch build and it works for me too.

Comment 16 Fedora Update System 2022-05-02 20:37:56 UTC
FEDORA-2022-626ba8041d has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-626ba8041d

Comment 17 Geraldo Simião 2022-05-03 06:43:43 UTC
(In reply to Fedora Update System from comment #16)
> FEDORA-2022-626ba8041d has been submitted as an update to Fedora 36.
> https://bodhi.fedoraproject.org/updates/FEDORA-2022-626ba8041d

It looks here this update really fixed the bug. Great!!!

Comment 18 Geraldo Simião 2022-05-03 07:42:08 UTC
Just tested the Fedora-Workstation-Live-x86_64-36-1.3.iso, wich have tracker-miners-3.3.0-2.fc36, and the is working fine, pictures are indeed showing in photos, no bug.

Comment 19 Lukas Ruzicka 2022-05-03 12:02:47 UTC
I can confirm, Photos are showing the content of the Pictures folder.

Comment 20 Fedora Update System 2022-05-03 13:32:23 UTC
FEDORA-2022-626ba8041d has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-626ba8041d`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-626ba8041d

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 21 Fedora Update System 2022-05-04 00:23:29 UTC
FEDORA-2022-626ba8041d has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.