Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2079412 - gnome-software claims unable to install one package after have it installed
Summary: gnome-software claims unable to install one package after have it installed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Milan Crha
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F36FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2022-04-27 13:50 UTC by lnie
Modified: 2022-04-28 09:41 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-04-28 09:41:54 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
journal (deleted)
2022-04-27 13:50 UTC, lnie
no flags Details
screencast (deleted)
2022-04-27 13:51 UTC, lnie
no flags Details
installing terminator from gnome software (deleted)
2022-04-27 18:30 UTC, Geraldo Simião
no flags Details
no error messagens here at RC 1.2 (deleted)
2022-04-27 18:31 UTC, Geraldo Simião
no flags Details
Terminator corretcly installed and working, no error messages (deleted)
2022-04-27 18:32 UTC, Geraldo Simião
no flags Details

Description lnie 2022-04-27 13:50:29 UTC
Created attachment 1875386 [details]
journal

Description of problem:
As shown in the attached screencast,Terminal is installed,but software claims it's not installed,at least hexchat is also affected.

Version-Release number of selected component (if applicable):
gnome-software-42.0-4.fc36.x86_64

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 lnie 2022-04-27 13:51:39 UTC
Created attachment 1875387 [details]
screencast

Comment 2 Fedora Blocker Bugs Application 2022-04-27 15:09:28 UTC
Proposed as a Blocker for 36-final by Fedora user lnie using the blocker tracking app because:

 seems affects:
The installed system must be able appropriately to install, remove, and update software with the default tool for the relevant software type in all release-blocking desktops (e.g. default graphical package manager). This includes downloading of packages to be installed/updated.

Comment 3 Milan Crha 2022-04-27 15:11:30 UTC
Thanks for a bug report. Could you retest with just released gnome-software 42.1, please? It's built here:
https://koji.fedoraproject.org/koji/buildinfo?buildID=1956511

Also, how did you install the Terminator, please?

Comment 4 Milan Crha 2022-04-27 15:21:36 UTC
I tried to reproduce this, by installing Terminator in the Software, then it was properly shown as installed. After that I restarted gnome-software process and the Terminator was still shown as installed. After that I restarted the whole machine and the Terminator was still shown as installed.

I've been also using gnome-software-42.0-4.fc36.x86_64

Considering it's an RPM version, the installed/not installed state depends on PackageKit, which packages it lists as installed. Could its cache (/var/lib/PackageKit | /var/cache/PackageKit) be broken in some way?

A similar pkcon command is:

   $ pkcon get-packages --plain | grep Installed | grep terminator

Comment 5 Ben Cotton 2022-04-27 15:41:28 UTC
I can't reproduce this with gnome-software-42.0-4.fc36.x86_64

Comment 6 Lukas Ruzicka 2022-04-27 15:56:27 UTC
It has worked for me, I did not see this happening.

Comment 7 Geraldo Simião 2022-04-27 18:30:39 UTC
Created attachment 1875430 [details]
installing terminator from gnome software

Tested here on RC 1.2 all is fine.

Comment 8 Geraldo Simião 2022-04-27 18:31:25 UTC
Created attachment 1875431 [details]
no error messagens here at RC 1.2

Comment 9 Geraldo Simião 2022-04-27 18:32:39 UTC
Created attachment 1875433 [details]
Terminator corretcly installed and working, no error messages

Fedora-Workstation-Live-x86_64-36-1.2.iso

Comment 10 lnie 2022-04-28 09:41:54 UTC
>Also, how did you install the Terminator, please?

On a fresh installed system,open the software and click the "Install" button  ,maybe twice,as sometimes software there seems no response after click the "Install" button,I mean no progress bar,
and "Open" button is shown instead of "Install"after installation is finished.
But I'm not able to reproduce this any more no matter how hard I try,even though I see it twice last night.
Closing,will try to get more information if I see this again.


Note You need to log in before you can comment on or make changes to this bug.