Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2080694 - Kernel 5.17.4 and below cause soft-brick with Ryzen 5700U based laptops
Summary: Kernel 5.17.4 and below cause soft-brick with Ryzen 5700U based laptops
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F36FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2022-05-01 02:03 UTC by Steven Haigh
Modified: 2022-05-02 19:43 UTC (History)
21 users (show)

Fixed In Version: kernel-5.17.5-300.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-05-02 19:43:39 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Steven Haigh 2022-05-01 02:03:43 UTC
Kernel version 5.17.5 fixes some major issues with Ryzen 5700U based laptops that cause them to be soft-bricked when shutting down or suspending.

The tl;dr version is that the kernel causes a faulty initialisation with the GPIO controller on the platform that handles events like the power button press, lid open / close and suspend / resume triggers.

In the worst case, this means that booting a F36 Live ISO with a kernel lower than 5.17.5 has the possibility to soft-brick the laptop after shutdown. The user would not need to actually install Fedora, just boot from the ISO.

To avoid this, please ensure that any install media produces has *AT LEAST* kernel version 5.17.5 - which I have personally tested and can confirm the problem is resolved.

My discovery of the issue:
https://gitlab.freedesktop.org/drm/amd/-/issues/1995

Fix:
https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=linux-5.17.y&id=d3f54679c6560e4e95f835107098395028ee360c

Comment 1 Fedora Blocker Bugs Application 2022-05-01 02:22:26 UTC
Proposed as a Blocker and Freeze Exception for 36-final by Fedora user crcinau using the blocker tracking app because:

 If the install media or live ISOs ship with a kernel version below 5.17.5, then laptops based on Ryzen 5700U CPUs will soft-brick on power down or suspend.

More details in the bug report.

Comment 2 Adam Williamson 2022-05-01 06:14:58 UTC
Justin, do you have anything to note here ahead of blocker review on Monday? Thanks!

Comment 3 Adam Williamson 2022-05-02 15:50:45 UTC
+8 in https://pagure.io/fedora-qa/blocker-review/issue/798 , marking accepted.

Comment 4 Fedora Update System 2022-05-02 17:43:55 UTC
FEDORA-2022-d37373c604 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-d37373c604

Comment 5 Fedora Update System 2022-05-02 19:43:39 UTC
FEDORA-2022-d37373c604 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.