Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2081213 - pgadmin4 requires to small range of python3dist(authlib)
Summary: pgadmin4 requires to small range of python3dist(authlib)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pgadmin4
Version: 36
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Sandro Mani
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-05-03 05:28 UTC by Edgar Hoch
Modified: 2022-05-11 01:19 UTC (History)
1 user (show)

Fixed In Version: pgadmin4-6.8-3.fc36
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-05-11 01:19:33 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Edgar Hoch 2022-05-03 05:28:45 UTC
Description of problem:
dnf cannot upgrade python3-authlib-0.15.5-1.fc36.noarch to python3-authlib-1.0.1-2.fc36.noarch because of a too small version range required by pgadmin4.

dnf error:

 Problem: package pgadmin4-6.8-1.fc36.x86_64 requires (python3dist(authlib) >= 0.15 with python3dist(authlib) < 0.16), but none of the providers can be installed
  - cannot install both python3-authlib-1.0.1-2.fc36.noarch and python3-authlib-0.15.5-1.fc36.noarch
  - cannot install the best update candidate for package python3-authlib-0.15.5-1.fc36.noarch
  - cannot install the best update candidate for package pgadmin4-6.8-1.fc36.x86_64


Version-Release number of selected component (if applicable):
pgadmin4-6.7-3.fc36.x86_64
pgadmin4-6.8-1.fc36.x86_64
python3-authlib-0.15.5-1.fc36.noarch
python3-authlib-1.0.1-2.fc36.noarch


How reproducible:
Always

Steps to Reproduce:
1. Install Fedora 36 (Prerelease) with repo updates enabled
2. Installation must include packages 
pgadmin4-6.7-3.fc36.x86_64
python3-authlib-0.15.5-1.fc36.noarch

3. Run "dnf upgrade --enablerepo=updates-testing" (because many updates currently are waiting in testing until 0-day Fedora 36 release)

4. Repeat the command to see what has left.


Actual results:
dnf cannot upgrade python3-authlib.

Expected results:
dnf upgrade python3-authlib.

Comment 1 Fedora Update System 2022-05-03 06:00:12 UTC
FEDORA-2022-585bc1d3fa has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-585bc1d3fa

Comment 2 Fedora Update System 2022-05-03 13:33:24 UTC
FEDORA-2022-585bc1d3fa has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-585bc1d3fa`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-585bc1d3fa

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 3 Fedora Update System 2022-05-11 01:19:33 UTC
FEDORA-2022-585bc1d3fa has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.