Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2083896 - [abrt] hydrapaper: _type_register(): types.py:217:_type_register:RuntimeError: could not create new GType: hydrapaper+main_stack+HydraPapaerMainStack (subclass of AdwViewStack)
Summary: [abrt] hydrapaper: _type_register(): types.py:217:_type_register:RuntimeError...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hydrapaper
Version: 36
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Artem
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:acd3b24b0ab33751dc7443d43e9...
: 2127691 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-05-11 00:23 UTC by matt.dubell
Modified: 2022-10-19 06:38 UTC (History)
3 users (show)

Fixed In Version: hydrapaper-3.3.1-2.fc36
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-10-19 06:38:56 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: backtrace (deleted)
2022-05-11 00:23 UTC, matt.dubell
no flags Details
File: cpuinfo (deleted)
2022-05-11 00:23 UTC, matt.dubell
no flags Details
File: environ (deleted)
2022-05-11 00:23 UTC, matt.dubell
no flags Details
File: mountinfo (deleted)
2022-05-11 00:23 UTC, matt.dubell
no flags Details
File: namespaces (deleted)
2022-05-11 00:23 UTC, matt.dubell
no flags Details
File: open_fds (deleted)
2022-05-11 00:23 UTC, matt.dubell
no flags Details

Description matt.dubell 2022-05-11 00:23:33 UTC
Description of problem:
Launched Hydrapaper while in dark mode (GNOME 42). 

Workaround: remove rpm. Install flathub 3.3.1 version.

Version-Release number of selected component:
hydrapaper-1:3.2.0-3.fc36

Additional info:
reporter:       libreport-2.17.1
cgroup:         0::/user.slice/user-1000.slice/user/session.slice/vte-spawn-f6b2b051-0183-4f46-900b-43e9fb407939.scope
cmdline:        /usr/bin/python3 /usr/bin/hydrapaper
crash_function: _type_register
exception_type: RuntimeError
executable:     /usr/bin/hydrapaper
interpreter:    python3-3.10.4-1.fc36.x86_64
kernel:         5.17.5-300.fc36.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
types.py:217:_type_register:RuntimeError: could not create new GType: hydrapaper+main_stack+HydraPapaerMainStack (subclass of AdwViewStack)

Traceback (most recent call last):
  File "/usr/bin/hydrapaper", line 73, in <module>
    from hydrapaper import __main__
  File "/usr/lib/python3.10/site-packages/hydrapaper/__main__.py", line 6, in <module>
    from .app_window import HydraPaperAppWindow
  File "/usr/lib/python3.10/site-packages/hydrapaper/app_window.py", line 3, in <module>
    from .main_stack import HydraPapaerMainStack
  File "/usr/lib/python3.10/site-packages/hydrapaper/main_stack.py", line 6, in <module>
    class HydraPapaerMainStack(Adw.ViewStack):
  File "/usr/lib64/python3.10/site-packages/gi/types.py", line 226, in __init__
    super(GObjectMeta, cls).__init__(name, bases, dict_)
  File "/usr/lib64/python3.10/site-packages/gi/types.py", line 205, in __init__
    cls._type_register(cls.__dict__)
  File "/usr/lib64/python3.10/site-packages/gi/types.py", line 217, in _type_register
    _gi.type_register(cls, namespace.get('__gtype_name__'))
RuntimeError: could not create new GType: hydrapaper+main_stack+HydraPapaerMainStack (subclass of AdwViewStack)

Local variables in innermost frame:
cls: <class 'hydrapaper.main_stack.HydraPapaerMainStack'>
namespace: mappingproxy({'__module__': 'hydrapaper.main_stack', '__init__': <function HydraPapaerMainStack.__init__ at 0x7f0c662e56c0>, '__doc__': None, '__gsignals__': {}})

Comment 1 matt.dubell 2022-05-11 00:23:35 UTC
Created attachment 1878482 [details]
File: backtrace

Comment 2 matt.dubell 2022-05-11 00:23:36 UTC
Created attachment 1878483 [details]
File: cpuinfo

Comment 3 matt.dubell 2022-05-11 00:23:37 UTC
Created attachment 1878484 [details]
File: environ

Comment 4 matt.dubell 2022-05-11 00:23:38 UTC
Created attachment 1878485 [details]
File: mountinfo

Comment 5 matt.dubell 2022-05-11 00:23:39 UTC
Created attachment 1878486 [details]
File: namespaces

Comment 6 matt.dubell 2022-05-11 00:23:40 UTC
Created attachment 1878487 [details]
File: open_fds

Comment 7 aaron.castro.ulloa 2022-05-20 23:34:37 UTC
Similar problem has been detected:

Steps:
1. Open hydraPaper from the UI using the default desktop environment GNOME 3
2. HydraPaper crashes and does not open

reporter:       libreport-2.17.1
cmdline:        /usr/bin/python3 /usr/bin/hydrapaper
crash_function: _type_register
exception_type: RuntimeError
executable:     /usr/bin/hydrapaper
interpreter:    python3-3.10.4-1.fc36.x86_64
kernel:         5.17.8-300.fc36.x86_64
package:        hydrapaper-1:3.2.0-3.fc36
reason:         types.py:217:_type_register:RuntimeError: could not create new GType: hydrapaper+main_stack+HydraPapaerMainStack (subclass of AdwViewStack)
runlevel:       N 5
type:           Python3
uid:            1000

Comment 8 aaron.castro.ulloa 2022-06-05 20:16:09 UTC
Similar problem has been detected:

1. Open HydraPaper
2. The program does not start, it crashes

reporter:       libreport-2.17.1
cmdline:        /usr/bin/python3 /usr/bin/hydrapaper
crash_function: _type_register
exception_type: RuntimeError
executable:     /usr/bin/hydrapaper
interpreter:    python3-3.10.4-1.fc36.x86_64
kernel:         5.17.9-300.fc36.x86_64
package:        hydrapaper-1:3.2.0-3.fc36
reason:         types.py:217:_type_register:RuntimeError: could not create new GType: hydrapaper+main_stack+HydraPapaerMainStack (subclass of AdwViewStack)
runlevel:       N 5
type:           Python3
uid:            1000

Comment 9 David Lima 2022-06-15 14:28:45 UTC
Similar problem has been detected:

Opening hydrapaper 3.2.0 on Fedora 36 crashes immediately and the application does not start at all

reporter:       libreport-2.17.1
cmdline:        /usr/bin/python3 /usr/bin/hydrapaper
cpuinfo:        
crash_function: _type_register
environ:        
exception_type: RuntimeError
executable:     /usr/bin/hydrapaper
interpreter:    python3-3.10.4-1.fc36.x86_64
kernel:         5.17.5-300.fc36.x86_64
mountinfo:      
open_fds:       
package:        hydrapaper-1:3.2.0-3.fc36
reason:         types.py:217:_type_register:RuntimeError: could not create new GType: hydrapaper+main_stack+HydraPapaerMainStack (subclass of AdwViewStack)
type:           Python3

Comment 10 Marcus Summers 2022-06-21 20:07:40 UTC
Similar problem has been detected:

Attempted to open the application when crash occurred.

reporter:       libreport-2.17.1
cgroup:         0::/user.slice/user-1000.slice/user/app.slice/app-gnome-org.gabmus.hydrapaper-204896.scope
cmdline:        /usr/bin/python3 /usr/bin/hydrapaper
crash_function: _type_register
exception_type: RuntimeError
executable:     /usr/bin/hydrapaper
interpreter:    python3-3.10.5-2.fc36.x86_64
kernel:         5.18.5-200.fc36.x86_64
package:        hydrapaper-1:3.2.0-3.fc36
reason:         types.py:217:_type_register:RuntimeError: could not create new GType: hydrapaper+main_stack+HydraPapaerMainStack (subclass of AdwViewStack)
runlevel:       N 5
type:           Python3
uid:            1000

Comment 11 Joshua Rich 2022-09-07 22:44:55 UTC
Similar problem has been detected:

Just installed the app and it crashed when launching it from Software.

reporter:       libreport-2.17.2
cgroup:         0::/user.slice/user-1000.slice/user/app.slice/app-glib-org.gabmus.hydrapaper-11976.scope
cmdline:        /usr/bin/python3 /usr/bin/hydrapaper
crash_function: _type_register
exception_type: RuntimeError
executable:     /usr/bin/hydrapaper
interpreter:    python3-3.10.6-1.fc36.x86_64
kernel:         5.19.6-200.fc36.x86_64
package:        hydrapaper-1:3.2.0-3.fc36
reason:         types.py:217:_type_register:RuntimeError: could not create new GType: hydrapaper+main_stack+HydraPapaerMainStack (subclass of AdwViewStack)
runlevel:       N 5
type:           Python3
uid:            1000

Comment 12 searge 2022-09-18 07:24:01 UTC
*** Bug 2127691 has been marked as a duplicate of this bug. ***

Comment 13 Fedora Update System 2022-10-10 03:35:21 UTC
FEDORA-2022-b6b8ca439a has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-b6b8ca439a

Comment 14 Fedora Update System 2022-10-10 11:50:45 UTC
FEDORA-2022-b6b8ca439a has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-b6b8ca439a`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-b6b8ca439a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 15 Fedora Update System 2022-10-19 06:38:56 UTC
FEDORA-2022-b6b8ca439a has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.