Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2084299 - F37FailsToInstall: 0ad
Summary: F37FailsToInstall: 0ad
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: 0ad
Version: 37
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kalev Lember
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F38FailsToInstall F37FailsToInstall 2062915
TreeView+ depends on / blocked
 
Reported: 2022-05-11 21:00 UTC by Miro Hrončok
Modified: 2022-10-03 00:20 UTC (History)
7 users (show)

Fixed In Version: 0ad-0.0.26-2.fc37 0ad-0.0.26-2.fc38 0ad-0.0.26-3.fc37
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-09-30 15:59:01 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Miro Hrončok 2022-05-11 21:00:27 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (0ad) Fails To Install in Fedora 37:

can't install 0ad:
  - nothing provides libboost_filesystem.so.1.76.0()(64bit) needed by 0ad-0.0.25b-2.fc36.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-37-x86_64 --disablerepo='*' --enablerepo=local install 0ad


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Miro Hrončok 2022-05-19 10:22:23 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 2 Bruno Wolff III 2022-05-19 18:48:18 UTC
I've spent a small amount of time on this, but it looks like it is going to take several hours to figure out what to do and more hours might be need waiting for test builds. My plan is to try to fix this.
I believe there are actually two issues blocking the rebuilds needed to be compatible with the latest boost, which is what is blocking installs. One of these build issues is present on f36, and I'll probably try to get that one foxed first as it will make testing fixes simpler.

Comment 3 Bruno Wolff III 2022-06-10 09:21:15 UTC
It looks like 0.0.26 rc1 is available (https://releases.wildfiregames.com/rc/), so looking at moving to the next release is possible as a solution for this. That also would be a chunk of work to recheck licensing and bundled stuff and possibly other stuff I'm not aware of. We might be able to stop using the bundled mozjs.

Comment 4 Ben Cotton 2022-08-09 13:38:39 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 37 development cycle.
Changing version to 37.

Comment 5 Kalev Lember 2022-09-30 13:43:11 UTC
OK, this should be sorted out now. pcpa and I teamed up for this and he updated 0ad to 0.0.26 and I figured out how to backport mozjs patches to support Python 3.11 and setuptools 60+ that are in F37:

https://src.fedoraproject.org/rpms/0ad/c/8dfbd049c0d6d6ccfcce3e392de84183a5bbeb86?branch=rawhide
https://src.fedoraproject.org/rpms/0ad/c/5c30a2e401024844a77f851f34aae51e918d105f?branch=rawhide

Comment 6 Fedora Update System 2022-09-30 14:17:05 UTC
FEDORA-2022-41f00827a6 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-41f00827a6

Comment 7 Fedora Update System 2022-09-30 15:53:53 UTC
FEDORA-2022-dbb72c8ec0 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2022-dbb72c8ec0

Comment 8 Fedora Update System 2022-09-30 15:59:01 UTC
FEDORA-2022-dbb72c8ec0 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 9 Fedora Update System 2022-10-01 02:13:07 UTC
FEDORA-2022-41f00827a6 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-41f00827a6`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-41f00827a6

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2022-10-02 01:22:38 UTC
FEDORA-2022-41f00827a6 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-41f00827a6`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-41f00827a6

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2022-10-03 00:20:25 UTC
FEDORA-2022-41f00827a6 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.