Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2086176 - [glog][epel]: please build glog in epel9
Summary: [glog][epel]: please build glog in epel9
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: glog
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: John Khvatov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 2035373
TreeView+ depends on / blocked
 
Reported: 2022-05-14 12:24 UTC by Kaleb KEITHLEY
Modified: 2023-09-15 01:54 UTC (History)
4 users (show)

Fixed In Version: glog-0.3.5-15.el9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-06-17 00:33:21 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Kaleb KEITHLEY 2022-05-14 12:24:42 UTC
Description of problem:

glog(-devel) is a BR for libarrow, which in term is a BR ceph quincy (17.2.x). While ceph itself will not (ever) be built in EPEL, there are Ceph developers who want to use CentOS Stream or RHEL with EPEL.

Note: libarrow and all its dependencies, including glog-devel, are already available from the CentOS Storage SIG. I'm told though that many Ceph devs prefer to use EPEL over the CentOS Storage SIG.


Version-Release number of selected component (if applicable):

glog-0.3.5

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

It builds without any changes necessary from rawhide source.  See https://koji.fedoraproject.org/koji/taskinfo?taskID=87038113

If you don't wish to build glog in EPEL yourself, please add the epel-packagers-sig group as co-maintainer, or (less preferable) add me as a co-maintainer, just for EPEL9 builds.

Thanks

Comment 1 Kaleb KEITHLEY 2022-05-23 16:22:27 UTC
If you don't wish to build glog in EPEL yourself, please add the epel-packagers-sig group as collaborator, or (less preferable) add me (FAS: kkeithle) as a collaborator, just for EPEL9 builds.

Thanks

Comment 2 Kaleb KEITHLEY 2022-06-06 11:36:57 UTC
epel-packagers-sig collaborator requested, see https://pagure.io/releng/issue/10824

Comment 3 Fedora Update System 2022-06-08 14:18:22 UTC
FEDORA-EPEL-2022-f8de818769 has been submitted as an update to Fedora EPEL 9. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-f8de818769

Comment 4 Fedora Update System 2022-06-09 00:23:19 UTC
FEDORA-EPEL-2022-f8de818769 has been pushed to the Fedora EPEL 9 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-f8de818769

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2022-06-17 00:33:21 UTC
FEDORA-EPEL-2022-f8de818769 has been pushed to the Fedora EPEL 9 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 6 Red Hat Bugzilla 2023-09-15 01:54:49 UTC
The needinfo request[s] on this closed bug have been removed as they have been unresolved for 365 days


Note You need to log in before you can comment on or make changes to this bug.