Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2088269 - SELinux is preventing systemd-user-ru from 'unlink' accesses on the lnk_file user.
Summary: SELinux is preventing systemd-user-ru from 'unlink' accesses on the lnk_file ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 36
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Zdenek Pytela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:6fa836ecff90d93e0d02c4a1381...
: 2095145 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-05-19 06:10 UTC by andres.julian
Modified: 2022-08-05 01:34 UTC (History)
9 users (show)

Fixed In Version: selinux-policy-36.13-3.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-08-05 01:34:29 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github fedora-selinux selinux-policy pull 1293 0 None open Add permissions to manage lnk_files into gnome_manage_home_config 2022-07-27 16:14:31 UTC

Description andres.julian 2022-05-19 06:10:45 UTC
Description of problem:
SELinux is preventing systemd-user-ru from 'unlink' accesses on the lnk_file user.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that systemd-user-ru should be allowed unlink access on the user lnk_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'systemd-user-ru' --raw | audit2allow -M my-systemduserru
# semodule -X 300 -i my-systemduserru.pp

Additional Information:
Source Context                system_u:system_r:systemd_logind_t:s0
Target Context                unconfined_u:object_r:config_home_t:s0
Target Objects                user [ lnk_file ]
Source                        systemd-user-ru
Source Path                   systemd-user-ru
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
SELinux Policy RPM            selinux-policy-targeted-36.8-2.fc36.noarch
Local Policy RPM              selinux-policy-targeted-36.8-2.fc36.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 5.17.6-300.fc36.x86_64 #1 SMP
                              PREEMPT Mon May 9 15:47:11 UTC 2022 x86_64 x86_64
Alert Count                   1
First Seen                    2022-05-18 16:32:50 CEST
Last Seen                     2022-05-18 16:32:50 CEST
Local ID                      de4f0f11-e9b2-44a6-9f68-911a46636a42

Raw Audit Messages
type=AVC msg=audit(1652884370.574:523): avc:  denied  { unlink } for  pid=45745 comm="systemd-user-ru" name="user" dev="tmpfs" ino=240 scontext=system_u:system_r:systemd_logind_t:s0 tcontext=unconfined_u:object_r:config_home_t:s0 tclass=lnk_file permissive=0


Hash: systemd-user-ru,systemd_logind_t,config_home_t,lnk_file,unlink

Version-Release number of selected component:
selinux-policy-targeted-36.8-2.fc36.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.17.1
hashmarkername: setroubleshoot
kernel:         5.17.6-300.fc36.x86_64
type:           libreport

Potential duplicate: bug 1909344

Comment 1 pbathily1 2022-06-09 06:50:09 UTC
*** Bug 2095145 has been marked as a duplicate of this bug. ***

Comment 2 matyasrudzan 2022-08-02 16:12:13 UTC
Similar problem has been detected:

Computer just signed me out and for a moment I got black screen, then I got back into login screen, signed in and reported error

It happened when I was running command for finding out manufacturer, I wanted to fix my tablet pc screen from being rotated 90 degrees on login screen each time, but this bug happened.

It wasnt the first time it happened, it was a few times before but I havent seen the SELinux error before.

hashmarkername: setroubleshoot
kernel:         5.18.13-200.fc36.x86_64
package:        selinux-policy-targeted-36.10-1.fc36.noarch
reason:         SELinux is preventing systemd-user-ru from 'unlink' accesses on the lnk_file /var/lib/snapd/snap/core20/1587/etc/apparmor.d/abstractions/user-tmp.
type:           libreport

Comment 3 Fedora Update System 2022-08-03 07:59:50 UTC
FEDORA-2022-139ec288ca has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-139ec288ca

Comment 4 Fedora Update System 2022-08-04 02:41:45 UTC
FEDORA-2022-139ec288ca has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-139ec288ca`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-139ec288ca

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2022-08-05 01:34:29 UTC
FEDORA-2022-139ec288ca has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.