Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2089022 - New separated subscription-manager-rhsm-certificates package conflicts with existing subscription-manager-rhsm-certificates
Summary: New separated subscription-manager-rhsm-certificates package conflicts with e...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: subscription-manager
Version: 36
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Jiri Hnidek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2120380 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-05-22 14:09 UTC by Martin Jackson
Modified: 2022-09-12 17:39 UTC (History)
14 users (show)

Fixed In Version: subscription-manager-1.29.30-1.fc36 subscription-manager-1.29.30-1.fc37
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-08-27 20:45:50 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Fedora Package Sources subscription-manager pull-request 7 0 None None None 2022-08-25 04:36:04 UTC

Description Martin Jackson 2022-05-22 14:09:02 UTC
Description of problem: It seems that a new package has landed in F36 that provides subscription-manager-rhsm-certificates: 

Name         : subscription-manager-rhsm-certificates
Version      : 20220425
Release      : 1.fc36
Architecture : noarch
Size         : 19 k
Source       : subscription-manager-rhsm-certificates-20220425-1.fc36.src.rpm
Repository   : imladris_f36_x86_64_f36_x86_64_updates
Summary      : Certificates required to communicate with a Red Hat Unified Entitlement Platform
URL          : https://www.candlepinproject.org/
License      : GPLv2
Description  : This package contains certificates required for communicating with the REST interface
             : of a Red Hat Unified Entitlement Platform, used for the management of system
             : entitlements and to receive access to content.


Version-Release number of selected component (if applicable): 
Version      : 1.29.21
Release      : 2.fc36
Architecture : x86_64



How reproducible: Always


Steps to Reproduce:
1. Install subscription-manager-rhsm-certificates
2. Updates fail due to strict dependency
3.

Actual results: Packages fail to upgrade


Expected results: Update proceeds normally 


Additional info:

It looks like the fix for https://bugzilla.redhat.com/show_bug.cgi?id=2086704 landed before an update to subscription manager. It seems this should be fixable by pushing an update to subscription-manager that loosens the requirement.

Comment 1 Pavel Raiskup 2022-07-13 07:09:59 UTC
Gently ping on this very annoying issue:

$ sudo dnf update
Last metadata expiration check: 0:09:23 ago on Wed 13 Jul 2022 08:59:27 AM CEST.
Dependencies resolved.

 Problem: package python3-subscription-manager-rhsm-1.29.21-2.fc36.x86_64 requires subscription-manager-rhsm-certificates = 1.29.21-2.fc36, but none of the providers can be installed
  - cannot install both subscription-manager-rhsm-certificates-20220425-1.fc36.noarch and subscription-manager-rhsm-certificates-1.29.21-2.fc36.x86_64
  - cannot install the best update candidate for package subscription-manager-rhsm-certificates-1.29.21-2.fc36.x86_64
  - cannot install the best update candidate for package python3-subscription-manager-rhsm-1.29.21-2.fc36.x86_64
========================================================================
 Package                           Arch   Version         Repo     Size
========================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 subscription-manager-rhsm-certificates
                                   noarch 20220425-1.fc36 updates  19 k

Transaction Summary
========================================================================
Skip  1 Package

Nothing to do.
Complete!

Comment 2 Ryan 2022-07-23 08:40:34 UTC
I also have this problem on fc36-x86_64. I performed a --best --allowerasing to see whether it would only remove the python3-subscription-manager-rhsm, but it turns out that virt-who relies on both packages at version 1.29.21-2 currently.

Comment 3 James Boyle 2022-08-23 13:41:12 UTC
Hello,

I've got the same issue as well.  It has been occurring for quite a while.  I can't recall whether it was immediately after upgrading to Fedora 36 or if it took some months after upgrading to manifest.  I'm pasting in the dnf output for reference.

# dnf -y upgrade
Updating Subscription Management repositories.
Unable to read consumer identity

This system is not registered with an entitlement server. You can use subscription-manager to register.

Last metadata expiration check: 0:10:28 ago on Tue 23 Aug 2022 09:21:01 AM EDT.
Dependencies resolved.

 Problem: package python3-subscription-manager-rhsm-1.29.21-2.fc36.x86_64 requires subscription-manager-rhsm-certificates = 1.29.21-2.fc36, but none of the providers can be installed
  - cannot install both subscription-manager-rhsm-certificates-20220425-1.fc36.noarch and subscription-manager-rhsm-certificates-1.29.21-2.fc36.x86_64
  - cannot install the best update candidate for package subscription-manager-rhsm-certificates-1.29.21-2.fc36.x86_64
  - cannot install the best update candidate for package python3-subscription-manager-rhsm-1.29.21-2.fc36.x86_64
==================================================================================================
 Package                                     Arch        Version               Repository    Size
==================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 subscription-manager-rhsm-certificates      noarch      20220425-1.fc36       updates       19 k

Transaction Summary
==================================================================================================
Skip  1 Package

Nothing to do.
Complete!
# dnf --best --allowerasing upgrade
Updating Subscription Management repositories.
Unable to read consumer identity

This system is not registered with an entitlement server. You can use subscription-manager to register.

Last metadata expiration check: 0:11:13 ago on Tue 23 Aug 2022 09:21:01 AM EDT.
Error: 
 Problem: cannot install the best update candidate for package python3-subscription-manager-rhsm-1.29.21-2.fc36.x86_64
  - problem with installed package python3-subscription-manager-rhsm-1.29.21-2.fc36.x86_64
  - package python3-subscription-manager-rhsm-1.29.21-2.fc36.x86_64 requires subscription-manager-rhsm-certificates = 1.29.21-2.fc36, but none of the providers can be installed
  - cannot install the best update candidate for package subscription-manager-rhsm-certificates-1.29.21-2.fc36.x86_64
  - cannot install both subscription-manager-rhsm-certificates-20220425-1.fc36.noarch and subscription-manager-rhsm-certificates-1.29.21-2.fc36.x86_64
(try to add '--skip-broken' to skip uninstallable packages)
#

Also, Bug 2120380 may be a duplicate of this bug

Comment 4 Pino Toscano 2022-08-23 15:07:44 UTC
*** Bug 2120380 has been marked as a duplicate of this bug. ***

Comment 5 Jiri Hnidek 2022-08-24 13:34:25 UTC
Hi
All new builds for F36, F37 and rawhide finished successfully and this issue should be fixed. New sub-man RPM does not require specific sub-man-rhsm-certs package and new sub-man-rhsm-certs RPM obsoletes old sub-man-rhsm-certs RPM. Can we close this BZ ATM? New builds can be seen here:

sub-man: https://koji.fedoraproject.org/koji/packageinfo?packageID=13057
sub-man-rhsm-certs: https://koji.fedoraproject.org/koji/packageinfo?packageID=35613
sub-man-cockpit: https://koji.fedoraproject.org/koji/packageinfo?packageID=35620

Jiri

Comment 6 Martin Jackson 2022-08-24 14:56:13 UTC
Yes, thank you! I've installed the builds and they coexist as expected.

Comment 7 Fedora Update System 2022-08-25 11:35:24 UTC
FEDORA-2022-86942750fe has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-86942750fe

Comment 8 Fedora Update System 2022-08-25 11:35:25 UTC
FEDORA-2022-f4ba547dad has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-f4ba547dad

Comment 9 Fedora Update System 2022-08-26 10:32:44 UTC
FEDORA-2022-f4ba547dad has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-f4ba547dad`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-f4ba547dad

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2022-08-26 11:56:39 UTC
FEDORA-2022-86942750fe has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-86942750fe`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-86942750fe

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2022-08-27 20:45:50 UTC
FEDORA-2022-86942750fe has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 12 Fedora Update System 2022-09-12 17:39:21 UTC
FEDORA-2022-f4ba547dad has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.