Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2089844 - osc-0.178.0 is available
Summary: osc-0.178.0 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: osc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Haïkel Guémar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-05-24 14:41 UTC by Upstream Release Monitoring
Modified: 2022-06-04 01:16 UTC (History)
5 users (show)

Fixed In Version: osc-0.178.0-326.20.2.fc37 osc-0.178.0-326.20.2.fc35 osc-0.178.0-326.20.2.fc34 osc-0.178.0-326.20.2.fc36
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-05-26 12:10:53 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Upstream Release Monitoring 2022-05-24 14:41:34 UTC
Latest upstream release: 0.178.0
Current version/release in rawhide: 0.177.0-324.28.1.fc37
URL: https://github.com/openSUSE/osc

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/11452/

Comment 1 Upstream Release Monitoring 2022-05-24 14:41:38 UTC
Scratch build failed. Details below:

GenericError: File upload failed: cli-build/1653403297.517294.oLoKzSVW/osc-0.178.0-1.fc34.src.rpm
Traceback:
  File "/usr/local/lib/python3.9/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
  File "/usr/local/lib/python3.9/site-packages/hotness/builders/koji.py", line 198, in build
    output["build_id"] = self._scratch_build(session, package.name, srpm)
  File "/usr/local/lib/python3.9/site-packages/hotness/builders/koji.py", line 451, in _scratch_build
    session.uploadWrapper(source, serverdir)
  File "/usr/lib/python3.9/site-packages/koji/__init__.py", line 3053, in uploadWrapper
    self.fastUpload(localfile, path, name, callback, blocksize, overwrite, volume=volume)
  File "/usr/lib/python3.9/site-packages/koji/__init__.py", line 2988, in fastUpload
    raise GenericError("File upload failed: %s/%s" % (path, name))

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 2 Fedora Update System 2022-05-26 12:07:47 UTC
FEDORA-2022-ce1b221bb1 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-ce1b221bb1

Comment 3 Fedora Update System 2022-05-26 12:10:53 UTC
FEDORA-2022-ce1b221bb1 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 4 Fedora Update System 2022-05-26 12:11:57 UTC
FEDORA-2022-ebf223d8e5 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2022-ebf223d8e5

Comment 5 Fedora Update System 2022-05-26 12:12:22 UTC
FEDORA-2022-b7227c716d has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-b7227c716d

Comment 6 Fedora Update System 2022-05-26 12:12:48 UTC
FEDORA-2022-ad591911a3 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-ad591911a3

Comment 7 Fedora Update System 2022-05-27 01:41:01 UTC
FEDORA-2022-b7227c716d has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-b7227c716d`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-b7227c716d

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2022-05-27 01:56:01 UTC
FEDORA-2022-ebf223d8e5 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-ebf223d8e5`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-ebf223d8e5

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2022-05-27 02:16:26 UTC
FEDORA-2022-ad591911a3 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-ad591911a3`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-ad591911a3

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2022-06-03 03:34:15 UTC
FEDORA-2022-b7227c716d has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 11 Fedora Update System 2022-06-03 04:08:44 UTC
FEDORA-2022-ebf223d8e5 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 12 Fedora Update System 2022-06-04 01:16:04 UTC
FEDORA-2022-ad591911a3 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.