Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2090769 - F37FailsToInstall: python3-zope-component
Summary: F37FailsToInstall: python3-zope-component
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-zope-component
Version: 37
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nick Bebout
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2110755 (view as bug list)
Depends On: 2090791 2117112
Blocks: F38FailsToInstall F37FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2022-05-26 14:08 UTC by Miro Hrončok
Modified: 2022-08-11 17:37 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-08-11 17:37:18 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Miro Hrončok 2022-05-26 14:08:27 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (python-zope-component) Fails To Install in Fedora 37:

can't install python3-zope-component:
  - nothing provides python3.10dist(zope-hookable) >= 4.2 needed by python3-zope-component-5.0.1-1.fc37.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-37-x86_64 --disablerepo='*' --enablerepo=local install python3-zope-component


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Miro Hrončok 2022-06-03 11:51:05 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 2 Miro Hrončok 2022-06-17 09:17:55 UTC
This now blocks the Python 3.11 rebuild.

  Error: 
   Problem: conflicting requests
    - nothing provides python3.11dist(zope-hookable) >= 4.2 needed by python3-zope-component-5.0.1-2.fc37.noarch

This affects:

certbot
mailman3
python-pyramid
python-testfixtures

Amnd all other packages that depend on this. Which are at least 7 packages for python-pyramid and 17 certbot plugins for certbot.

Comment 3 Miro Hrončok 2022-06-17 11:20:15 UTC
I've managed to build python-zope-component-4.3.0-19.fc37 with Python 3.11 from git history. So this does not block the rebuild any more. It will block installation after the side tag is merged.

Comment 4 Miro Hrončok 2022-06-20 09:44:44 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 37.

Thanks for taking care of it!

Comment 5 Miro Hrončok 2022-06-20 11:10:48 UTC
Reopening this one. It' been de-facto untagged but the problem still exists in dist git.

Comment 6 Miro Hrončok 2022-07-21 12:54:18 UTC
The mass rebuild will uncover this. Please act.

Comment 7 Miro Hrončok 2022-07-23 19:13:11 UTC
python-zope-component-5.0.1-3.fc37 was built in the mass rebuild. Once that build gets tagged into f37, this will once again be a problem.

Comment 8 Miro Hrončok 2022-07-25 20:11:54 UTC
*** Bug 2110755 has been marked as a duplicate of this bug. ***

Comment 9 Miro Hrončok 2022-07-25 20:13:07 UTC
(In reply to Miro Hrončok from comment #7)
> python-zope-component-5.0.1-3.fc37 was built in the mass rebuild. Once that
> build gets tagged into f37, this will once again be a problem.

And, that happened today.

Comment 10 Ben Cotton 2022-08-09 13:38:48 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 37 development cycle.
Changing version to 37.

Comment 11 Fedora Update System 2022-08-10 14:21:20 UTC
FEDORA-2022-3d5fc6323b has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2022-3d5fc6323b

Comment 12 Fedora Update System 2022-08-10 14:30:36 UTC
FEDORA-2022-3d5fc6323b has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 13 Fedora Update System 2022-08-10 14:31:57 UTC
FEDORA-2022-6ad9f0a3e9 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-6ad9f0a3e9

Comment 14 Fedora Update System 2022-08-11 17:37:18 UTC
FEDORA-2022-6ad9f0a3e9 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.